changeset 43:365d3f380d8d

pulled in changes from Holgi
author Dirk Olmes <dirk@xanthippe.ping.de>
date Fri, 20 Jun 2008 15:09:02 +0200
parents 3038225a5ded (current diff) 5ecdf92ae1be (diff)
children 2804e3abde18
files app-admin/collectd/collectd-4.3.3.ebuild
diffstat 5 files changed, 247 insertions(+), 249 deletions(-) [+]
line wrap: on
line diff
--- a/app-admin/collectd/Manifest	Sun Jun 15 00:43:10 2008 +0200
+++ b/app-admin/collectd/Manifest	Fri Jun 20 15:09:02 2008 +0200
@@ -1,4 +1,4 @@
 AUX collectd-4.3.3.confd 519 RMD160 f4f3a699b9e8ce3e11522a3a521089793824fffd SHA1 2477a4acab05455ea7e1072663dcb5c381f175a6 SHA256 f043ad355fd7f5d2f017207d6cec7be5ac8c27d12aca19f1fd6541ea230d24b6
 AUX collectd-4.3.3.initd 801 RMD160 3e195dba9144906e4a364635eb48236f35e81100 SHA1 b4fdf02ea754c6a6067b895213cb9b8ed4a8bb76 SHA256 edf081f989a38c77ec4f5de3050b8e7ee96a8a420e15ac02d1d0bb8546391c8d
-DIST collectd-4.3.3.tar.bz2 852371 RMD160 c1838045599003cd8831461abe8a1118ada3deec SHA1 55ba81031d8a4dc3c525046f1aba186b04d2f470 SHA256 8d4caa33b44431ff71e2ef6878c1815c602b46de3b67d4a94047c15aecb80fda
-EBUILD collectd-4.3.3.ebuild 8672 RMD160 47327f6863cbfebd66cadd0ba63e75e1bb7666b3 SHA1 96d4cf3a718953731ab588a5e8e524b4f2009b43 SHA256 a8a3f810bb0493d966f938908c193df7a942fe701a8d0720049dd49ca9d58fdb
+DIST collectd-4.4.1.tar.bz2 921902 RMD160 d12c40e27c7fe6838cd6a490c44661af67abed08 SHA1 d927bbf045179359ad4bd29ed0ad77fd6105e2d4 SHA256 2e0373bb4e9e78f52739975575f1ad4874311853551b59c8562b5848a38eb85a
+EBUILD collectd-4.4.1.ebuild 8672 RMD160 47327f6863cbfebd66cadd0ba63e75e1bb7666b3 SHA1 96d4cf3a718953731ab588a5e8e524b4f2009b43 SHA256 a8a3f810bb0493d966f938908c193df7a942fe701a8d0720049dd49ca9d58fdb
--- a/app-admin/collectd/collectd-4.3.3.ebuild	Sun Jun 15 00:43:10 2008 +0200
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,239 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit autotools eutils flag-o-matic linux-info
-
-DESCRIPTION="A small daemon which collects system performance statistics"
-HOMEPAGE="http://collectd.org/"
-
-SRC_URI="${HOMEPAGE}/files/${P}.tar.bz2"
-LICENSE="GPL-2"
-
-SLOT="0"
-
-KEYWORDS="~x86 ~amd64"
-IUSE="
-    apache2 apcups dns email hal hddtemp ithreads lighttpd lm_sensors memcache
-    mysql network nfs nginx ntp nut perl qemu rrdtool snmp syslog vserver xen
-"
-
-DEPEND="
-    apache2?	( >=net-misc/curl-7.17.0 )
-    lighttpd?	( >=net-misc/curl-7.17.0 )
-    nginx?	( >=net-misc/curl-7.17.0 )
-    dns?	( >=net-libs/libpcap-0.9.8 )
-    qemu?	( >=app-emulation/libvirt-0.3.3 )
-    xen?	( >=app-emulation/libvirt-0.3.3 )
-    mysql?	( >=virtual/mysql-5.0 )
-    perl?	( >=dev-lang/perl-5.8.8-r4 )
-    nut?	( >=sys-power/nut-2.2.0 )
-    rrdtool?	( >=net-analyzer/rrdtool-1.2.27 )
-    lm_sensors?	( >=sys-apps/lm_sensors-2.10.4 )
-    snmp?	( >=net-analyzer/net-snmp-5.4.1-r3 )
-    hal?	( >=sys-apps/hal-0.5.9.1-r3 )
-    >=dev-libs/libxml2-2.6.31
-"
-
-RDEPEND="
-    ${DEPEND}
-    apcups?	( >=sys-power/apcupsd-3.14.2 )
-    hddtemp?	( >=app-admin/hddtemp-0.3_beta15-r3 )
-    memcache?	( >=net-misc/memcached-1.2.2-r2 )
-    ntp?	( >=net-misc/ntp-4.2.4_p4 )
-    syslog?	( virtual/logger )
-    !hal?	( >=sys-apps/dmidecode-2.9 )
-"
-
-pkg_setup()
-{
-    linux-info_pkg_setup
-
-    if ( !(linux_chkconfig_present ACPI_BATTERY) ); then einfo
-	ewarn "ACPI_BATTERY needs to be enabled in your kernel for the battery plug-in to work correctly"; fi
-    if ( !(linux_chkconfig_present CPU_FREQ) ); then einfo
-	ewarn "CPU_FREQ needs to be enabled in your kernel for the cpufreq plug-in to work correctly"; fi
-    if ( !(linux_chkconfig_present SERIAL_CORE) ); then einfo
-	ewarn "SERIAL_CORE needs to be enabled in your kernel for the serial plug-in to work correctly"; fi
-    if ( !(linux_chkconfig_present SWAP) ); then einfo
-	ewarn "SWAP needs to be enabled in your kernel for the swap plug-in to work correctly"; fi
-    if ( (use vserver) && !(linux_chkconfig_present IP_VS) ); then einfo
-	ewarn "IP_VS should to be enabled in your kernel when the USE flag vserver is enabled"; fi
-    if (use qemu && !(built_with_use libvirt qemu) ); then
-	die "USE flag qemu requires that libvirt was compiled with the USE flag qemu"; fi
-    if (use xen  && !(built_with_use libvirt xen) ); then
-	die "USE flag xen requires that libvirt was compiled with the USE flag xen"; fi
-
-    if (use perl); then
-	if (use ithreads); then
-	    (built_with_use perl ithreads) \
-	    || die "The perl plug-in requires that libperl was compiled with the USE flag ithreads"
-	else
-	    einfo
-	    ewarn "The perl plug-in requires the ithreads USE flag."
-	fi
-    fi
-    einfo
-
-    if ( !(linux_chkconfig_present PROC_FS) ); then
-	## if ( use network ); then
-	##     die "${P} requires that PROC_FS is enabled in the kernel for the USE flag network"; fi
-	die "${P} requires that PROC_FS is enabled in your kernel"	## UPDATE LATER
-    fi
-
-    if ( !(use network) ); then
-	if ( use dns ); then		die "The USE flag dns requires that the USE flag network is enabled"; fi
-	if ( use email ); then		die "The USE flag email requires that the USE flag network is enabled"; fi
-	if ( use nfs ); then		die "The USE flag nfs requires that the USE flag network is enabled"; fi
-	if ( use ntp ); then		die "The USE flag ntp requires that the USE flag network is enabled"; fi
-	if ( use snmp ); then		die "The USE flag snmp requires that the USE flag network is enabled"; fi
-	if ( use vserver ); then	die "The USE flag vserver requires that the USE flag network is enabled"; fi
-    fi
-}
-
-src_unpack() {
-    if [ "${A}" != "" ]; then
-        unpack ${A}
-    fi
-
-    cd ${S}
-
-    sed -i -e '/^AC_PLUGIN/ s/\ [[].*[]],/[no],/' \
-	configure.in \
-	|| die "sed no-automagic-patch failed"
-
-    eautoreconf \
-	|| die "eautoreconf failed"
-}
-
-src_compile()
-{
-    local myconf
-    local disabled_plugins
-    
-    ### NEEDS TO BE FIXED PROBABLY
-    append-flags -I/usr/src/linux/include
-
-    if ( use apache2 || use lighttpd );
-	then myconf="${myconf} --enable-apache"; fi
-    myconf="${myconf} $(use_enable apcups)"
-    myconf="${myconf} --disable-apple_sensors"		## DISABLED
-	disabled_plugins="${disabled_plugins} apple_sensors"
-    myconf="${myconf} --enable-battery"			## Kernel check PROCFS
-    myconf="${myconf} --enable-cpu"			## PROCFS
-    myconf="${myconf} --enable-cpufreq"			## Kernel check SYSFS
-    myconf="${myconf} --enable-csv"			## no checks
-    myconf="${myconf} --enable-df"			## no checks
-    myconf="${myconf} --enable-disk"			## PROCFS
-    myconf="${myconf} $(use network && use_enable dns)"
-    myconf="${myconf} $(use network && use_enable email)"
-    myconf="${myconf} --enable-entropy"			## PROCFS
-    myconf="${myconf} --disable-exec"			## NEEDS USERS
-	disabled_plugins="${disabled_plugins} exec"
-    myconf="${myconf} $(use_enable hddtemp)"		## PROCFS
-    myconf="${myconf} $(use_enable network interface)"	## PROCFS
-    myconf="${myconf} --disable-iptables"		## BREAKS
-	disabled_plugins="${disabled_plugins} iptables"
-    myconf="${myconf} $(use network && use_enable vserver ipvs)"	## Kernel check NEEDS CFLAGS -I -- FIX LATER
-    myconf="${myconf} --enable-irq"			## PROCFS
-    if ( use qemu || use xen ); then			## NEEDS KERNEL CHECK
-	myconf="${myconf} --enable-libvirt"; fi
-    myconf="${myconf} --enable-load"			## PROCFS
-    myconf="${myconf} --enable-logfile"			## no checks
-    myconf="${myconf} --disable-mbmon"			## COULD NOT FIND DAEMON
-	disabled_plugins="${disabled_plugins} mbmon"
-    myconf="${myconf} $(use_enable memcache memcached)"
-    myconf="${myconf} --enable-memory"			## PROCFS
-    myconf="${myconf} --enable-multimeter"
-    myconf="${myconf} $(use_enable mysql)"
-    myconf="${myconf} --disable-netlink"		## BREAKS
-	disabled_plugins="${disabled_plugins} netlink"
-    myconf="${myconf} $(use_enable network)"		## NO PROCFS
-    myconf="${myconf} $(use network && use_enable nfs)"	## PROCFS
-    myconf="${myconf} $(use_enable nginx)"
-    myconf="${myconf} $(use network && use_enable ntp ntpd)"
-    myconf="${myconf} $(use_enable nut)"
-    myconf="${myconf} $(use ithreads && use_enable perl)"
-    myconf="${myconf} $(use_with perl perl-bindings)"
-    myconf="${myconf} $(use_enable network ping)"
-    myconf="${myconf} --enable-processes"		## PROCFS
-    myconf="${myconf} $(use_enable rrdtool)"
-    myconf="${myconf} $(use_enable lm_sensors sensors)"
-    myconf="${myconf} --enable-serial"			## Kernel check PROCFS
-    myconf="${myconf} $(use network && use_enable snmp)"
-    myconf="${myconf} --enable-swap"			## Kernel check PROCFS
-    myconf="${myconf} $(use_enable syslog)"
-    myconf="${myconf} --disable-tape"			## SOLARIS ???
-	disabled_plugins="${disabled_plugins} tape"
-    myconf="${myconf} $(use_enable network tcpconns)"	## PROCFS
-    myconf="${myconf} $(use_enable network unixsock)"
-    myconf="${myconf} --enable-users"
-    myconf="${myconf} --enable-uuid"			## Depends on hal or dmidecode PROCFS
-    myconf="${myconf} $(use network && use_enable vserver)"		## PROCFS
-    myconf="${myconf} $(use_enable network wireless)" 	## NEEDS KERNEL CHECK ## PROCFS
-    myconf="${myconf} --disable-xmms"			## NOT IN GENTOO
-	disabled_plugins="${disabled_plugins} xmms"
-
-    einfo
-    elog "The following plug-ins have been disabled in the ebuild"
-    elog ${disabled_plugins}
-    einfo
-
-    ### Configure
-    econf \
-	${myconf} \
-	--localstatedir=/var \
-	|| die "econf failed"
-
-    ### Build
-    emake \
-	|| die "emake failed"
-}
-
-src_install()
-{
-    emake \
-	DESTDIR="${D}" \
-	install || die "emake install failed"
-
-    ### Documentation
-    dodoc AUTHORS ChangeLog NEWS README TODO \
-	|| die "dodoc failed"
-
-    docinto contrib/SpamAssassin
-    dodoc contrib/SpamAssassin/* \
-	|| die "dodoc contrib failed"
-
-    docinto contrib/examples
-    dodoc contrib/examples/* \
-	|| die "dodoc contrib failed"
-
-    docinto contrib/iptables
-    dodoc contrib/iptables/* \
-	|| die "dodoc contrib failed"
-    docinto contrib
-
-    docinto contrib
-    dodoc contrib/README contrib/*\.[a-z]* \
-	|| die "dodoc contrib failed"
-
-    
-    keepdir /var/lib/collectd \
-	|| die "keepdir failed"
-
-    newinitd "${FILESDIR}/${PN}-4.3.2.initd" ${PN} \
-	|| die "newinitd failed"
-    
-    newconfd "${FILESDIR}/${PN}-4.3.2.confd" ${PN} \
-	|| die "newconfd failed"
-}
-
-pkg_postinst()
-{
-    einfo
-    einfo "collectd introduced some changes in the new 4.x series."
-    einfo "For further information, read http://collectd.org/migrate-v3-v4.shtml"
-    einfo "The migration script can be found at:"
-    einfo "/usr/share/doc/${P}/contrib/migrate-3-4.px.bz2"
-    einfo
-}
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/app-admin/collectd/collectd-4.4.1.ebuild	Fri Jun 20 15:09:02 2008 +0200
@@ -0,0 +1,239 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit autotools eutils flag-o-matic linux-info
+
+DESCRIPTION="A small daemon which collects system performance statistics"
+HOMEPAGE="http://collectd.org/"
+
+SRC_URI="${HOMEPAGE}/files/${P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~x86 ~amd64"
+IUSE="
+    apache2 apcups dns email hal hddtemp ithreads lighttpd lm_sensors memcache
+    mysql network nfs nginx ntp nut perl qemu rrdtool snmp syslog vserver xen
+"
+
+DEPEND="
+    apache2?	( >=net-misc/curl-7.17.0 )
+    lighttpd?	( >=net-misc/curl-7.17.0 )
+    nginx?	( >=net-misc/curl-7.17.0 )
+    dns?	( >=net-libs/libpcap-0.9.8 )
+    qemu?	( >=app-emulation/libvirt-0.3.3 )
+    xen?	( >=app-emulation/libvirt-0.3.3 )
+    mysql?	( >=virtual/mysql-5.0 )
+    perl?	( >=dev-lang/perl-5.8.8-r4 )
+    nut?	( >=sys-power/nut-2.2.0 )
+    rrdtool?	( >=net-analyzer/rrdtool-1.2.27 )
+    lm_sensors?	( >=sys-apps/lm_sensors-2.10.4 )
+    snmp?	( >=net-analyzer/net-snmp-5.4.1-r3 )
+    hal?	( >=sys-apps/hal-0.5.9.1-r3 )
+    >=dev-libs/libxml2-2.6.31
+"
+
+RDEPEND="
+    ${DEPEND}
+    apcups?	( >=sys-power/apcupsd-3.14.2 )
+    hddtemp?	( >=app-admin/hddtemp-0.3_beta15-r3 )
+    memcache?	( >=net-misc/memcached-1.2.2-r2 )
+    ntp?	( >=net-misc/ntp-4.2.4_p4 )
+    syslog?	( virtual/logger )
+    !hal?	( >=sys-apps/dmidecode-2.9 )
+"
+
+pkg_setup()
+{
+    linux-info_pkg_setup
+
+    if ( !(linux_chkconfig_present ACPI_BATTERY) ); then einfo
+	ewarn "ACPI_BATTERY needs to be enabled in your kernel for the battery plug-in to work correctly"; fi
+    if ( !(linux_chkconfig_present CPU_FREQ) ); then einfo
+	ewarn "CPU_FREQ needs to be enabled in your kernel for the cpufreq plug-in to work correctly"; fi
+    if ( !(linux_chkconfig_present SERIAL_CORE) ); then einfo
+	ewarn "SERIAL_CORE needs to be enabled in your kernel for the serial plug-in to work correctly"; fi
+    if ( !(linux_chkconfig_present SWAP) ); then einfo
+	ewarn "SWAP needs to be enabled in your kernel for the swap plug-in to work correctly"; fi
+    if ( (use vserver) && !(linux_chkconfig_present IP_VS) ); then einfo
+	ewarn "IP_VS should to be enabled in your kernel when the USE flag vserver is enabled"; fi
+    if (use qemu && !(built_with_use libvirt qemu) ); then
+	die "USE flag qemu requires that libvirt was compiled with the USE flag qemu"; fi
+    if (use xen  && !(built_with_use libvirt xen) ); then
+	die "USE flag xen requires that libvirt was compiled with the USE flag xen"; fi
+
+    if (use perl); then
+	if (use ithreads); then
+	    (built_with_use perl ithreads) \
+	    || die "The perl plug-in requires that libperl was compiled with the USE flag ithreads"
+	else
+	    einfo
+	    ewarn "The perl plug-in requires the ithreads USE flag."
+	fi
+    fi
+    einfo
+
+    if ( !(linux_chkconfig_present PROC_FS) ); then
+	## if ( use network ); then
+	##     die "${P} requires that PROC_FS is enabled in the kernel for the USE flag network"; fi
+	die "${P} requires that PROC_FS is enabled in your kernel"	## UPDATE LATER
+    fi
+
+    if ( !(use network) ); then
+	if ( use dns ); then		die "The USE flag dns requires that the USE flag network is enabled"; fi
+	if ( use email ); then		die "The USE flag email requires that the USE flag network is enabled"; fi
+	if ( use nfs ); then		die "The USE flag nfs requires that the USE flag network is enabled"; fi
+	if ( use ntp ); then		die "The USE flag ntp requires that the USE flag network is enabled"; fi
+	if ( use snmp ); then		die "The USE flag snmp requires that the USE flag network is enabled"; fi
+	if ( use vserver ); then	die "The USE flag vserver requires that the USE flag network is enabled"; fi
+    fi
+}
+
+src_unpack() {
+    if [ "${A}" != "" ]; then
+        unpack ${A}
+    fi
+
+    cd ${S}
+
+    sed -i -e '/^AC_PLUGIN/ s/\ [[].*[]],/[no],/' \
+	configure.in \
+	|| die "sed no-automagic-patch failed"
+
+    eautoreconf \
+	|| die "eautoreconf failed"
+}
+
+src_compile()
+{
+    local myconf
+    local disabled_plugins
+    
+    ### NEEDS TO BE FIXED PROBABLY
+    append-flags -I/usr/src/linux/include
+
+    if ( use apache2 || use lighttpd );
+	then myconf="${myconf} --enable-apache"; fi
+    myconf="${myconf} $(use_enable apcups)"
+    myconf="${myconf} --disable-apple_sensors"		## DISABLED
+	disabled_plugins="${disabled_plugins} apple_sensors"
+    myconf="${myconf} --enable-battery"			## Kernel check PROCFS
+    myconf="${myconf} --enable-cpu"			## PROCFS
+    myconf="${myconf} --enable-cpufreq"			## Kernel check SYSFS
+    myconf="${myconf} --enable-csv"			## no checks
+    myconf="${myconf} --enable-df"			## no checks
+    myconf="${myconf} --enable-disk"			## PROCFS
+    myconf="${myconf} $(use network && use_enable dns)"
+    myconf="${myconf} $(use network && use_enable email)"
+    myconf="${myconf} --enable-entropy"			## PROCFS
+    myconf="${myconf} --disable-exec"			## NEEDS USERS
+	disabled_plugins="${disabled_plugins} exec"
+    myconf="${myconf} $(use_enable hddtemp)"		## PROCFS
+    myconf="${myconf} $(use_enable network interface)"	## PROCFS
+    myconf="${myconf} --disable-iptables"		## BREAKS
+	disabled_plugins="${disabled_plugins} iptables"
+    myconf="${myconf} $(use network && use_enable vserver ipvs)"	## Kernel check NEEDS CFLAGS -I -- FIX LATER
+    myconf="${myconf} --enable-irq"			## PROCFS
+    if ( use qemu || use xen ); then			## NEEDS KERNEL CHECK
+	myconf="${myconf} --enable-libvirt"; fi
+    myconf="${myconf} --enable-load"			## PROCFS
+    myconf="${myconf} --enable-logfile"			## no checks
+    myconf="${myconf} --disable-mbmon"			## COULD NOT FIND DAEMON
+	disabled_plugins="${disabled_plugins} mbmon"
+    myconf="${myconf} $(use_enable memcache memcached)"
+    myconf="${myconf} --enable-memory"			## PROCFS
+    myconf="${myconf} --enable-multimeter"
+    myconf="${myconf} $(use_enable mysql)"
+    myconf="${myconf} --disable-netlink"		## BREAKS
+	disabled_plugins="${disabled_plugins} netlink"
+    myconf="${myconf} $(use_enable network)"		## NO PROCFS
+    myconf="${myconf} $(use network && use_enable nfs)"	## PROCFS
+    myconf="${myconf} $(use_enable nginx)"
+    myconf="${myconf} $(use network && use_enable ntp ntpd)"
+    myconf="${myconf} $(use_enable nut)"
+    myconf="${myconf} $(use ithreads && use_enable perl)"
+    myconf="${myconf} $(use_with perl perl-bindings)"
+    myconf="${myconf} $(use_enable network ping)"
+    myconf="${myconf} --enable-processes"		## PROCFS
+    myconf="${myconf} $(use_enable rrdtool)"
+    myconf="${myconf} $(use_enable lm_sensors sensors)"
+    myconf="${myconf} --enable-serial"			## Kernel check PROCFS
+    myconf="${myconf} $(use network && use_enable snmp)"
+    myconf="${myconf} --enable-swap"			## Kernel check PROCFS
+    myconf="${myconf} $(use_enable syslog)"
+    myconf="${myconf} --disable-tape"			## SOLARIS ???
+	disabled_plugins="${disabled_plugins} tape"
+    myconf="${myconf} $(use_enable network tcpconns)"	## PROCFS
+    myconf="${myconf} $(use_enable network unixsock)"
+    myconf="${myconf} --enable-users"
+    myconf="${myconf} --enable-uuid"			## Depends on hal or dmidecode PROCFS
+    myconf="${myconf} $(use network && use_enable vserver)"		## PROCFS
+    myconf="${myconf} $(use_enable network wireless)" 	## NEEDS KERNEL CHECK ## PROCFS
+    myconf="${myconf} --disable-xmms"			## NOT IN GENTOO
+	disabled_plugins="${disabled_plugins} xmms"
+
+    einfo
+    elog "The following plug-ins have been disabled in the ebuild"
+    elog ${disabled_plugins}
+    einfo
+
+    ### Configure
+    econf \
+	${myconf} \
+	--localstatedir=/var \
+	|| die "econf failed"
+
+    ### Build
+    emake \
+	|| die "emake failed"
+}
+
+src_install()
+{
+    emake \
+	DESTDIR="${D}" \
+	install || die "emake install failed"
+
+    ### Documentation
+    dodoc AUTHORS ChangeLog NEWS README TODO \
+	|| die "dodoc failed"
+
+    docinto contrib/SpamAssassin
+    dodoc contrib/SpamAssassin/* \
+	|| die "dodoc contrib failed"
+
+    docinto contrib/examples
+    dodoc contrib/examples/* \
+	|| die "dodoc contrib failed"
+
+    docinto contrib/iptables
+    dodoc contrib/iptables/* \
+	|| die "dodoc contrib failed"
+    docinto contrib
+
+    docinto contrib
+    dodoc contrib/README contrib/*\.[a-z]* \
+	|| die "dodoc contrib failed"
+
+    
+    keepdir /var/lib/collectd \
+	|| die "keepdir failed"
+
+    newinitd "${FILESDIR}/${PN}-4.3.2.initd" ${PN} \
+	|| die "newinitd failed"
+    
+    newconfd "${FILESDIR}/${PN}-4.3.2.confd" ${PN} \
+	|| die "newconfd failed"
+}
+
+pkg_postinst()
+{
+    einfo
+    einfo "collectd introduced some changes in the new 4.x series."
+    einfo "For further information, read http://collectd.org/migrate-v3-v4.shtml"
+    einfo "The migration script can be found at:"
+    einfo "/usr/share/doc/${P}/contrib/migrate-3-4.px.bz2"
+    einfo
+}
--- a/net-misc/e1000e/Manifest	Sun Jun 15 00:43:10 2008 +0200
+++ b/net-misc/e1000e/Manifest	Fri Jun 20 15:09:02 2008 +0200
@@ -1,2 +1,3 @@
 DIST e1000e-0.2.9.5.tar.gz 175390 RMD160 0234455b22b4cb61e2956d4729503a68a178db7c SHA1 e050692d0854b1308b9eb5042f166d34e33a75fa SHA256 051861bc49a759a519f77b10a7835059f270c280423c10f8da00a835430c62a9
-EBUILD e1000e-0.2.9.5.ebuild 1378 RMD160 d68c952a49dea8f7b106e722a3331efa46860de7 SHA1 d981ac0074d619f2f16587913870f5add26f53cb SHA256 6e60ea889bb86a8e1570a9a4afa653acfe927b8c3effbd3e3983dd8963024bc6
+EBUILD e1000e-0.2.9.5.ebuild 1187 RMD160 39892b555fbfae0f5a921640b9f7a6672a5d269a SHA1 6c992484bb31def68606054e69fb9978f27cd220 SHA256 319fb813eef746f8263ff84df28529b67733afecfd97c5fbcac8fcf4eb713c14
+MISC e1000e-0.2.9.5.ebuild~ 1200 RMD160 e6a381ceb28719e3da28745df2330d54d5942b72 SHA1 c8fbac1d72eb1d353f3aaff189ab286857987aac SHA256 82856e774e3ec5ae3b07d6d52d82fc23bcd37a63f7d213e08e33d46901d7f598
--- a/net-misc/e1000e/e1000e-0.2.9.5.ebuild	Sun Jun 15 00:43:10 2008 +0200
+++ b/net-misc/e1000e/e1000e-0.2.9.5.ebuild	Fri Jun 20 15:09:02 2008 +0200
@@ -36,14 +36,11 @@
 
 
 src_install() {
-    insinto "/lib/modules/${KV}/kernel/drivers/net/e1000"
-    doins "${S}/src/e1000.ko"
-    doman e1000.7
-    dodoc LICENSE README SUMS e1000.spec ldistrib.txt ${FILESDIR}/README.Gentoo
+    insinto "/lib/modules/${KV}/kernel/drivers/net/e1000e"
+    doins "${S}/src/e1000e.ko"
+    doman e1000e.7
+    dodoc COPYING README SUMS e1000e.spec
     einfo ""
     einfo "In case you have problems when loading the module, try to run depmod -A"
     einfo ""
-    einfo "If you experience problems with low-end switches, read"
-    einfo "/usr/share/doc/${PF}/README.Gentoo.gz for a possible workaround"
-    einfo ""
 }