changeset 77:3d2e64e09140

bump alpine to 2.0
author holger@hoho.dyndns.org
date Wed, 27 Aug 2008 14:27:14 +0200
parents f7de040b797f
children 47db27a12ba2
files mail-client/alpine/Manifest mail-client/alpine/alpine-1.10.ebuild mail-client/alpine/alpine-2.00.ebuild
diffstat 3 files changed, 137 insertions(+), 144 deletions(-) [+]
line wrap: on
line diff
--- a/mail-client/alpine/Manifest	Sat Aug 23 01:14:29 2008 +0200
+++ b/mail-client/alpine/Manifest	Wed Aug 27 14:27:14 2008 +0200
@@ -1,3 +1,3 @@
 DIST all.patch.gz 170342 RMD160 81647cc792f26da49ef6c5263ff0a5bc55e89d07 SHA1 c8a0daa6b98020f8fc21a68f99e87cc90711aee6 SHA256 d6908fcb25f18f42906c1793b741390f88b48adf5764ba33848f9b4a5018ead0
-DIST alpine-1.10.tar.bz2 4861929 RMD160 03f216b57517f377b7995d913f7d333242f70ab3 SHA1 fe8f83ad9f5b8e528ee61960877443d518af9eed SHA256 8c642829d19b776c153cc8e1d93992dc7986d44f687100823dbb51fe78116765
-EBUILD alpine-1.10.ebuild 3322 RMD160 04b6a9ac17309984df37944c3f61a7134c886891 SHA1 82f5ff5964b6f56083ceb0998365a04ed3caafe9 SHA256 b81e68f03562d44f5de0391fa0a2695be0bb9b7b5b835e69119a3137f6b8cdbd
+DIST alpine-2.00.tar.bz2 5222673 RMD160 9e67704b23b3973d8b878e65ad9e6f5026c10d13 SHA1 dcbd3c5419954f484ccf706feaba31ce48cdebc4 SHA256 c85db8405af90375ba2440c85b7952d80996154e9916b83acca558dc82e0a2a6
+EBUILD alpine-2.00.ebuild 3751 RMD160 e87a97e3b59b362b3d5749804dfb95ba5271d49d SHA1 deb8a8094f82c923a0503ac8ff9bd166fa9c1d5c SHA256 e3e0ce2fb098c71b750e7192c7760e9dabd056564e3b5a4c7b933daa64e6b473
--- a/mail-client/alpine/alpine-1.10.ebuild	Sat Aug 23 01:14:29 2008 +0200
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,142 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit eutils 
-
-DESCRIPTION="alternativly licensed pine with full UTF-8 support"
-HOMEPAGE="http://www.washington.edu/alpine/
-	  http://staff.washington.edu/chappa/alpine/"
-SRC_URI="ftp://ftp.cac.washington.edu/alpine/${P}.tar.bz2
-	 chappa? ( http://staff.washington.edu/chappa/alpine/patches/${P}/all.patch.gz )"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~x86 ~amd64 ~x86-fbsd"
-IUSE="chappa doc kerberos ldap nls spell ssl threads userland_BSD onlyalpine passfile"
-
-DEPEND="virtual/pam
-	>=sys-libs/ncurses-5.1
-	ssl? ( dev-libs/openssl )
-	ldap? ( net-nds/openldap )
-	kerberos? ( app-crypt/mit-krb5 )
-	spell? ( app-text/aspell )"
-RDEPEND="${DEPEND}
-	app-misc/mime-types
-	!onlyalpine? ( !app-editors/pico )
-	!onlyalpine? ( !mail-client/pine )
-	!<=net-mail/uw-imap-2004g"
-
-maildir_warn() {
-		einfo
-		einfo "This build of alpine has Maildir support built in as"
-		einfo "part of the chappa-all patch."
-		einfo
-		einfo "If you have a maildir at ~/Maildir it will be your"
-		einfo "default INBOX. The path may be changed with the"
-		einfo "\"maildir-location\" setting in alpine."
-		einfo
-		einfo "To use /var/spool/mail INBOX again, set"
-		einfo "\"disable-these-drivers=md\" in your .pinerc file."
-		einfo
-		einfo "Alternately, you might want to read following webpage, which explains how to"
-		einfo "use multiple mailboxes simultaneously:"
-		einfo
-		einfo "http://www.math.washington.edu/~chappa/pine/pine-info/collections/incoming-folders/"
-		einfo
-}
-
-pkg_setup() {
-	if use chappa; then
-		maildir_warn
-	fi
-}
-
-src_unpack() {
-	unpack ${A}
-	if use chappa; then
-		epatch ${WORKDIR}/all.patch
-	fi
-}
-
-src_compile() {
-	local myconf="--without-tcl --with-system-pinerc=/etc/pine.conf --with-system-fixed-pinerc=/etc/pine.conf.fixed"
-	if use ssl; then
-		myconf="${myconf} --with-ssl-certs-dir=/etc/ssl/certs"
-	else
-		myconf="${myconf} --without-ssl"
-	fi
-	if use ldap; then
-		myconf="${myconf}"
-	else
-		myconf="${myconf} --without-ldap"
-	fi
-	if user passfile; then
-		myconf="${myconf} --with-passfile=.pinepwd"
-	fi
-	if use kerberos; then
-		myconf="${myconf}"
-	else
-		myconf="${myconf} --without-krb5"
-	fi
-	if use threads; then
-		myconf="${myconf}"
-	else
-		myconf="${myconf} --without-pthread"
-	fi
-	if use spell; then
-		myconf="${myconf} --with-interactive-spellcheck=/usr/bin/aspell"
-	fi
-	if ! use nls; then
-		myconf="${myconf} --disable-nls"
-	fi
-	econf ${myconf} || die "configure problem"
-	if use userland_BSD; then
-		make
-	else
-		emake
-	fi
-}
-
-src_install() {
-	if use onlyalpine; then
-		dobin alpine/alpine
-		doman doc/alpine.1
-	else
-		if use userland_BSD; then
-			make DESTDIR=${D} install
-		else	
-			emake DESTDIR=${D} install
-		fi
-
-		doman doc/rpdump.1 doc/rpload.1 
-	fi
-
-	dodoc NOTICE
-	if use chappa; then
-		dodoc README.maildir
-	fi
-	
-	if use doc; then
-		dodoc README doc/brochure.txt doc/tech-notes.txt
-		docinto imap
-		dodoc imap/docs/*.txt imap/docs/CONFIG imap/docs/RELNOTES
-
-		docinto imap/rfc
-		dodoc imap/docs/rfc/*.txt
-
-		docinto html/tech-notes
-		dohtml -r doc/tech-notes/
-	fi
-}
-
-pkg_postinst() {
-	elog
-	if use spell; then
-		elog "In order to use spell checking"
-		elog "  emerge app-dicts/aspell-\<your_langs\>"
-		elog "and setup alpine with:"
-		elog "  Speller = /usr/bin/aspell -c"
-		elog
-	fi
-}
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/mail-client/alpine/alpine-2.00.ebuild	Wed Aug 27 14:27:14 2008 +0200
@@ -0,0 +1,135 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="alpine is the successor of the famous mail and news reader pine"
+HOMEPAGE="http://www.washington.edu/alpine/ http://staff.washington.edu/chappa/alpine/"
+SRC_URI="ftp://ftp.cac.washington.edu/alpine/${P}.tar.bz2
+	     chappa? ( http://staff.washington.edu/chappa/alpine/patches/${P}/all.patch.gz )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~x86-fbsd"
+IUSE="chappa doc ipv6 kerberos ldap nls onlyalpine passfile smime spell ssl threads topal userland_BSD"
+
+DEPEND="virtual/pam
+	    >=sys-libs/ncurses-5.1
+	    ssl? ( dev-libs/openssl )
+	    ldap? ( net-nds/openldap )
+	    kerberos? ( app-crypt/mit-krb5 )
+	    spell? ( app-text/aspell )
+	    topal? ( >=mail-client/topal-62 )"
+RDEPEND="${DEPEND}
+	app-misc/mime-types
+	!onlyalpine? ( !app-editors/pico )
+	!onlyalpine? ( !mail-client/pine )
+	!<=net-mail/uw-imap-2004g"
+
+maildir_warn() {
+		elog
+		elog "This build of ${PN} has Maildir support built in as"
+		elog "part of the chappa-all patch."
+		elog
+		elog "If you have a maildir at ~/Maildir it will be your"
+		elog "default INBOX. The path may be changed with the"
+		elog "\"maildir-location\" setting in alpine."
+		elog
+		elog "To use /var/spool/mail INBOX again, set"
+		elog "\"disable-these-drivers=md\" in your .pinerc file."
+		elog
+		elog "Alternately, you might want to read following webpage, which explains how to"
+		elog "use multiple mailboxes simultaneously:"
+		elog
+		elog "http://www.math.washington.edu/~chappa/pine/pine-info/collections/incoming-folders/"
+		elog
+}
+
+src_unpack() {
+	unpack ${A}
+	use chappa && epatch "${WORKDIR}"/all.patch
+	# topal needs updating for alpine 2.00
+	#use topal && epatch /usr/share/topal/patches/${P}.patch
+	use topal && die "topal needs updating for ${P}. Please disable it for now."
+}
+
+src_compile() {
+	local myconf="--without-tcl
+				  --with-system-pinerc=/etc/pine.conf
+				  --with-system-fixed-pinerc=/etc/pine.conf.fixed
+				  --with-ssl-certs-dir=/etc/ssl/certs"
+
+	use ssl || myconf="${myconf} --without-ssl"
+	use ldap || myconf="${myconf} --without-ldap"
+	use passfile && myconf="${myconf} --with-passfile=.pinepwd"
+	use kerberos || myconf="${myconf} --without-krb5"
+	use threads || myconf="${myconf} --without-pthread"
+	use spell && myconf="${myconf} --with-interactive-spellcheck=/usr/bin/aspell"
+	use nls || myconf="${myconf} --disable-nls"
+	use ipv6 || myconf="${myconf} --without-ipv6"
+	use smime || myconf="${myconf} --without-smime"
+
+	# fixme
+	# --with-system-mail-directory=DIR?
+
+	econf ${myconf} || die "configure problem"
+
+	use userland_BSD && make || emake
+}
+
+src_install() {
+	if use onlyalpine; then
+		dobin alpine/alpine
+		doman doc/alpine.1
+	else
+		if use userland_BSD; then
+			make DESTDIR="${D}" install
+		else
+			emake DESTDIR="${D}" install
+		fi
+
+		doman doc/rpdump.1 doc/rpload.1
+	fi
+
+	dodoc NOTICE
+	if use chappa; then
+		dodoc README.maildir
+	fi
+
+	if use doc; then
+		dodoc README doc/brochure.txt doc/tech-notes.txt
+		docinto imap
+		dodoc imap/docs/*.txt imap/docs/CONFIG imap/docs/RELNOTES
+
+		docinto imap/rfc
+		dodoc imap/docs/rfc/*.txt
+
+		docinto html/tech-notes
+		dohtml -r doc/tech-notes/
+	fi
+}
+
+pkg_postinst() {
+	use chappa && maildir_warn
+	if use spell; then
+		elog
+		elog "In order to use spell checking"
+		elog "  emerge app-dicts/aspell-\<your_langs\>"
+		elog "and setup alpine with:"
+		elog "  Speller = /usr/bin/aspell -c"
+		elog
+	fi
+	if use topal; then
+		elog
+		elog "In order to use gpg with topal"
+		elog "  read /usr/doc/topal/README.txt"
+		elog
+	fi
+	if use passfile ; then
+		elog
+		elog "${PN} will cache passwords between connections."
+		elog "File ~/.pinepw will be used for this."
+		elog
+	fi
+}