changeset 374:3f197242b810

remove custom qscintilla ebuild
author Dirk Olmes <dirk@xanthippe.ping.de>
date Thu, 11 Dec 2014 08:42:06 +0100
parents 33697a7eefba
children d130eab1967f
files dev-python/qscintilla-python/Manifest dev-python/qscintilla-python/qscintilla-python-2.7.2-r1.ebuild
diffstat 2 files changed, 0 insertions(+), 69 deletions(-) [+]
line wrap: on
line diff
--- a/dev-python/qscintilla-python/Manifest	Thu Dec 11 07:31:18 2014 +0100
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,2 +0,0 @@
-DIST QScintilla-gpl-2.7.2.tar.gz 2842625 SHA256 14b47d686dc1586321f84fcf3c9a911ddaace37a1cb0b1e6a6195e252e5bb69c SHA512 d3ca9d75687687210ca6ae3599fd44bfbbad8c99d6d38aaf1c92c83250dc0c5af1c713bdd74d077d0fb9ba1eccbd5e2910eef855d3656392c33c4832d46ff7fb WHIRLPOOL 1ea4a189a5998755afaa0fad111a7f2153e5ecbe13290d62930cce992b0159040de9cb304e848705abc3d0f1909a82fde908d8179ddd9de05970323cee5ffebe
-EBUILD qscintilla-python-2.7.2-r1.ebuild 1630 SHA256 c61a20c2854d7b7192545b1bcc8db33598b0cffe65aa6e1545e4f82b07f59726 SHA512 a6918bb7cddc134b2c36ea251faa7a940c2bee26d61831db4083f4371a08bc5284d6291317da8789e9913f9e51fbcc2556124e9534605137d918c139adb4dc03 WHIRLPOOL d4a78de063806e47c987c7d5559f6129c925dc421562307e9442186fb91f7747956703fd3bea3007f0c7cd1ad59470ac3a2959c965206cad629d84b464cd6016
--- a/dev-python/qscintilla-python/qscintilla-python-2.7.2-r1.ebuild	Thu Dec 11 07:31:18 2014 +0100
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,67 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/qscintilla-python-2.7.2.ebuild,v 1.10 2014/11/20 00:41:25 pesa Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )
-
-inherit eutils multilib python-r1 toolchain-funcs
-
-MY_P=QScintilla-gpl-${PV}
-
-DESCRIPTION="Python bindings for Qscintilla"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/qscintilla/intro"
-SRC_URI="mirror://sourceforge/pyqt/${MY_P}.tar.gz"
-
-LICENSE="|| ( GPL-2 GPL-3 )"
-SLOT="0"
-KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
-IUSE="debug"
-
-DEPEND="
-	${PYTHON_DEPS}
-	>=dev-python/sip-4.12:=[${PYTHON_USEDEP}]
-	=dev-python/PyQt4-4.10*[X,${PYTHON_USEDEP}]
-	dev-qt/qtcore:4
-	dev-qt/qtgui:4
-	~x11-libs/qscintilla-${PV}:=
-"
-RDEPEND="${DEPEND}"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-S=${WORKDIR}/${MY_P}/Python
-
-src_prepare() {
-	python_copy_sources
-}
-
-src_configure() {
-	configuration() {
-		local myconf=(
-			"${PYTHON}" configure-old.py
-			--apidir="${EPREFIX}"/usr/share/qt4/qsci
-			--destdir="$(python_get_sitedir)"/PyQt4
-			--sipdir="${EPREFIX}"/usr/share/sip
-			-n "${EPREFIX}"/usr/include/qt4
-			-o "${EPREFIX}"/usr/$(get_libdir)/qt4
-			-p 4
-			--no-timestamp
-			$(use debug && echo --debug)
-		)
-		echo "${myconf[@]}"
-		"${myconf[@]}" || die
-	}
-	python_parallel_foreach_impl run_in_build_dir configuration
-}
-
-src_compile() {
-	compilation() {
-		emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" LINK="$(tc-getCXX)"
-	}
-	python_foreach_impl run_in_build_dir compilation
-}
-
-src_install() {
-	python_foreach_impl run_in_build_dir default
-}