changeset 31:51b6b390a7d8

pull changes from Holgi's portage tree
author Dirk Olmes <dirk@xanthippe.ping.de>
date Mon, 09 Jun 2008 01:42:38 +0200
parents 442a7e018127 (current diff) 73894a55faf6 (diff)
children b23455d0adfe
files
diffstat 7 files changed, 103 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-nntp/leafnode/Manifest	Mon Jun 09 01:42:38 2008 +0200
@@ -0,0 +1,7 @@
+AUX fetchnews.cron 177 RMD160 b7bf11b578a225366e9edb25cbbe0cf4f4d8fb40 SHA1 5a84614e95f53f0f3bd216b4831e19d6e1803179 SHA256 4fc9999fb5598c5c6df96b72ca876cee5b7b485df5c86bb2f454f4a129dfe981
+AUX leafnode.xinetd 230 RMD160 f63477f421d3c5205d2c332317f43543bac00196 SHA1 f70cd64ef1aa9ca9ee67665195375c187ee38f3e SHA256 a8dd35146f27ad737eeab74512fb01f17ba526769d218fc4a9ff2225b0827828
+AUX local.groups 83 RMD160 98681fc4ab29dd001f97b4b98aa311df3f0ac900 SHA1 822c00162601007f85937acb3a913457ad00367c SHA256 e69c4ee697c241c4c4c2d863ee207e7e6a636f2d6c8d344507e9803a2c01411e
+AUX moderators 29 RMD160 31e2b6881cdaa97b22a40265581fd6ffc42bffca SHA1 bd6beec976325b1d7b2a59f18e587066161577a3 SHA256 4e887f2b97e2d4c287165d31c098f92d8d98b6740363abf6bfa7cbba268bbc3f
+AUX texpire.cron 158 RMD160 5dc4751c8b2c5a0f0845d6655a5b6f3ae25aad26 SHA1 a74b5cf877c1c33425efd2b1b64a25d5eff1fa52 SHA256 acd65f4a3b6ddbee3e1f21a4aa1ce0124e7983bfe9387bc379079c2e621f745f
+DIST leafnode-2.0.0.alpha20070602a.tar.bz2 357707 RMD160 078c77c1db5f8b2d2c2117a40088660f5a9c1a7b SHA1 16ad01982dc0bdba7572307094c3ffcb86a18bc9 SHA256 322daf48ff52124df2e2940e6bc86e7869648388076bb7aff5afb1a82233b2a0
+EBUILD leafnode-2.0.0_alpha20070602.ebuild 1642 RMD160 7baf16940fa669f85963c7ea14765232544e7f5c SHA1 02d5f350d812222226ad05a55892744b566fc74c SHA256 3fa2acbe9e18b2ff5be686e64f03a91dfaa69a457c90b5ba6c4caff6dcb18e9b
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-nntp/leafnode/files/fetchnews.cron	Mon Jun 09 01:42:38 2008 +0200
@@ -0,0 +1,10 @@
+#!/bin/sh
+#
+# Uncomment the following if you want to regularly
+# fetch new messages from your news server. 
+#
+#
+# This is part of the leafnode package.
+#
+
+#/usr/sbin/fetchnews 
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-nntp/leafnode/files/leafnode.xinetd	Mon Jun 09 01:42:38 2008 +0200
@@ -0,0 +1,12 @@
+# default: off
+# description: Leafnode - accepts connections on port 119 (NNTP)
+
+service nntp
+{
+	socket_type = stream
+	protocol    = tcp
+	wait        = no
+	user        = news
+	server      = /usr/sbin/leafnode
+	disable     = yes
+}
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-nntp/leafnode/files/local.groups	Mon Jun 09 01:42:38 2008 +0200
@@ -0,0 +1,2 @@
+local.testing	y	local group for testing
+local.special	m	local group with moderator
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-nntp/leafnode/files/moderators	Mon Jun 09 01:42:38 2008 +0200
@@ -0,0 +1,1 @@
+local.special:root@localhost
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-nntp/leafnode/files/texpire.cron	Mon Jun 09 01:42:38 2008 +0200
@@ -0,0 +1,10 @@
+#!/bin/sh
+#
+# Uncomment the following if you want to
+# clean up your news spool regularly.
+# 
+#
+# This is part of the leafnode package.
+#
+
+#/usr/sbin/texpire
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-nntp/leafnode/leafnode-2.0.0_alpha20070602.ebuild	Mon Jun 09 01:42:38 2008 +0200
@@ -0,0 +1,61 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/leafnode/leafnode-2.0.0_alpha20070108.ebuild,v 1.1 2007/02/18 21:13:31 swegener Exp $
+
+inherit flag-o-matic
+
+MY_P=${P/_/.}a
+
+DESCRIPTION="A USENET software package designed for small sites"
+SRC_URI="http://www-dt.e-technik.uni-dortmund.de/~ma/leafnode/beta/${MY_P}.tar.bz2"
+HOMEPAGE="http://www-dt.e-technik.uni-dortmund.de/~ma/leafnode/beta/"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE="ipv6 pam"
+
+DEPEND=">=dev-libs/libpcre-3.9
+	pam? ( sys-libs/pam )"
+RDEPEND="${DEPEND}
+	virtual/inetd"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+	append-ldflags $(bindnow-flags)
+
+	econf \
+		--sysconfdir=/etc/leafnode \
+		--with-runas-user=news \
+		--localstatedir=/var \
+		--with-spooldir=/var/spool/news \
+		$(use_with ipv6) \
+		$(use_with pam) \
+		|| die "econf failed"
+	emake || die "emake failed"
+}
+
+src_install() {
+	make DESTDIR="${D}" install || die "make install failed"
+
+	keepdir \
+		/var/lock/news \
+		/var/lib/news \
+		/var/spool/news
+
+	insinto /etc/leafnode
+	doins "${FILESDIR}"/{local.groups,moderators} || die "doins failed"
+
+	insinto /etc/xinetd.d
+	newins "${FILESDIR}"/leafnode.xinetd leafnode-nntp || die "newins failed"
+
+	exeinto /etc/cron.hourly
+	newexe "${FILESDIR}"/fetchnews.cron fetchnews || die "doexe failed"
+	exeinto /etc/cron.daily
+	newexe "${FILESDIR}"/texpire.cron texpire || die "doexe failed"
+
+	dodoc \
+		AUTHORS COPYING* CREDITS ChangeLog DEBUGGING ENVIRONMENT \
+		INSTALL NEWS TODO README || die "dodoc failed"
+	dohtml README.html || die "dohtml failed"
+}