changeset 78:47db27a12ba2

fix alpine build for --as-needed in LDFLAGS
author holger@hoho.dyndns.org
date Wed, 27 Aug 2008 20:38:51 +0200
parents 3d2e64e09140
children 7165b0bc5268
files mail-client/alpine/Manifest mail-client/alpine/alpine-2.00.ebuild
diffstat 2 files changed, 12 insertions(+), 4 deletions(-) [+]
line wrap: on
line diff
--- a/mail-client/alpine/Manifest	Wed Aug 27 14:27:14 2008 +0200
+++ b/mail-client/alpine/Manifest	Wed Aug 27 20:38:51 2008 +0200
@@ -1,3 +1,3 @@
 DIST all.patch.gz 170342 RMD160 81647cc792f26da49ef6c5263ff0a5bc55e89d07 SHA1 c8a0daa6b98020f8fc21a68f99e87cc90711aee6 SHA256 d6908fcb25f18f42906c1793b741390f88b48adf5764ba33848f9b4a5018ead0
 DIST alpine-2.00.tar.bz2 5222673 RMD160 9e67704b23b3973d8b878e65ad9e6f5026c10d13 SHA1 dcbd3c5419954f484ccf706feaba31ce48cdebc4 SHA256 c85db8405af90375ba2440c85b7952d80996154e9916b83acca558dc82e0a2a6
-EBUILD alpine-2.00.ebuild 3751 RMD160 e87a97e3b59b362b3d5749804dfb95ba5271d49d SHA1 deb8a8094f82c923a0503ac8ff9bd166fa9c1d5c SHA256 e3e0ce2fb098c71b750e7192c7760e9dabd056564e3b5a4c7b933daa64e6b473
+EBUILD alpine-2.00.ebuild 4053 RMD160 bc7833df191592dc23323336b91cb14608b91861 SHA1 5a86fcd5cde05c2cca15b7a2f4b0c166282f67eb SHA256 51e88fb32ac03764852fe1d2183c2efacc210b704346bcdf65f72cb1877f8021
--- a/mail-client/alpine/alpine-2.00.ebuild	Wed Aug 27 14:27:14 2008 +0200
+++ b/mail-client/alpine/alpine-2.00.ebuild	Wed Aug 27 20:38:51 2008 +0200
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
-inherit eutils
+inherit eutils flag-o-matic
 
 DESCRIPTION="alpine is the successor of the famous mail and news reader pine"
 HOMEPAGE="http://www.washington.edu/alpine/ http://staff.washington.edu/chappa/alpine/"
@@ -73,9 +73,17 @@
 	# fixme
 	# --with-system-mail-directory=DIR?
 
-	econf ${myconf} || die "configure problem"
+	# fixme
+	# --as-needed breaks linking of c-client for executables
+	# filter-ldflags --as-needed does not work for "-Wl,-O1,--as-needed,-z,now" ??
+	LDFLAGS=`echo $LDFLAGS | sed s/--as-needed//g | sed s/,,/,/g`
+	econf ${myconf} LDFLAGS="$LDFLAGS" || die "configure problem"
 
-	use userland_BSD && make || emake
+	if use userland_BSD; then
+		make || die "make failed"
+	else
+		emake || die "emake failed"
+	fi
 }
 
 src_install() {