changeset 112:4a719c618dfb

remove obsolete hg version
author Dirk Olmes <dirk.olmes@googlemail.com>
date Thu, 28 May 2009 10:32:12 +0200
parents 775ad69b0f88
children ae18a6f7faee 47262047ff3c
files dev-util/mercurial/Manifest dev-util/mercurial/files/70mercurial-gentoo.el dev-util/mercurial/mercurial-1.1.2.ebuild dev-util/mercurial/metadata.xml
diffstat 4 files changed, 0 insertions(+), 141 deletions(-) [+]
line wrap: on
line diff
--- a/dev-util/mercurial/Manifest	Thu May 28 10:29:39 2009 +0200
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,4 +0,0 @@
-AUX 70mercurial-gentoo.el 76 RMD160 1891ab510adb464211b4cc35c5b6e4b149da79fa SHA1 72eb35d2bf86fa8f806acfbc823b88fc5188741b SHA256 c215746e4a5375569808c6aa6ddabe08e82d33d744128179be3142d9cd53a5ab
-DIST mercurial-1.1.2.tar.gz 952241 RMD160 9dd2505ca8f378804ee64f1367473dcba1d568cb SHA1 b0f77198a96474fc72d38904ce60b007e4c7cc1a SHA256 dd18a3c3821d1638f202b4212a02b9349acac9333785e96e9a8119f6c21d5e44
-EBUILD mercurial-1.1.2.ebuild 3226 RMD160 743d444c471c607972c0cedb0da2599574b6672a SHA1 a29c432f1335a05cdf26aba60ccbb62e17540f5f SHA256 0f1b83d61da1f559d97d934c7c21601015cb8a622ece49344af3bc0294cca507
-MISC metadata.xml 645 RMD160 2a33b3987960796da78558e671c4e5e0c6f10241 SHA1 6cd04e19dc7796b53afe98a9831e128c4c96f3ca SHA256 e0b05e42345698eda32c513e3a8f14d8bf42d5344dcd804b1f2234da327524e2
--- a/dev-util/mercurial/files/70mercurial-gentoo.el	Thu May 28 10:29:39 2009 +0200
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,3 +0,0 @@
-;;; mercurial site-lisp configuration
-
-(add-to-list 'load-path "@SITELISP@")
\ No newline at end of file
--- a/dev-util/mercurial/mercurial-1.1.2.ebuild	Thu May 28 10:29:39 2009 +0200
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,118 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mercurial/mercurial-1.0.2.ebuild,v 1.7 2008/10/17 08:04:41 aballier Exp $
-
-inherit bash-completion elisp-common flag-o-matic eutils distutils
-
-DESCRIPTION="Scalable distributed SCM"
-HOMEPAGE="http://www.selenic.com/mercurial/"
-SRC_URI="http://www.selenic.com/mercurial/release/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ~hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="bugzilla emacs gpg test zsh-completion"
-
-CDEPEND=">=dev-lang/python-2.3"
-RDEPEND="${CDEPEND}
-	bugzilla? ( dev-python/mysql-python )
-	gpg? ( app-crypt/gnupg )
-	zsh-completion? ( app-shells/zsh )"
-DEPEND="${CDEPEND}
-	emacs? ( virtual/emacs )
-	test? ( app-arch/unzip
-		dev-python/pygments )"
-
-PYTHON_MODNAME="${PN} hgext"
-SITEFILE="70${PN}-gentoo.el"
-
-src_compile() {
-	filter-flags -ftracer -ftree-vectorize
-
-	distutils_src_compile
-
-	if use emacs; then
-		cd "${S}"/contrib
-		elisp-compile mercurial.el || die "elisp-compile failed!"
-	fi
-
-	rm -rf contrib/{win32,macosx}
-}
-
-src_install() {
-	distutils_src_install
-
-	dobashcompletion contrib/bash_completion ${PN}
-
-	if use zsh-completion ; then
-		insinto /usr/share/zsh/site-functions
-		newins contrib/zsh_completion _hg
-	fi
-
-	rm -f doc/*.?.txt
-	dodoc CONTRIBUTORS PKG-INFO README doc/*.txt
-	cp hgweb*.cgi "${D}"/usr/share/doc/${PF}/
-
-	dobin contrib/hgk
-	dobin contrib/hg-relink
-	dobin contrib/hg-ssh
-
-	rm -f contrib/hgk contrib/hg-relink contrib/hg-ssh
-
-	rm -f contrib/bash_completion
-	cp -r contrib "${D}"/usr/share/doc/${PF}/
-	doman doc/*.?
-
-	cat > "${T}/80mercurial" <<-EOF
-HG=/usr/bin/hg
-EOF
-	doenvd "${T}/80mercurial"
-
-	if use emacs; then
-		elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
-		elisp-site-file-install "${FILESDIR}"/${SITEFILE}
-	fi
-}
-
-src_test() {
-	local testdir="${T}/tests"
-	mkdir -p -m1777 "${testdir}" || die
-	cd "${S}/tests/"
-	rm -f *svn*		# Subversion tests fail with 1.5
-	rm -f test-convert-baz*		# GNU Arch baz
-	rm -f test-convert-cvs*		# CVS
-	rm -f test-convert-darcs*	# Darcs
-	rm -f test-convert-git*		# git
-	rm -f test-convert-mtn*		# monotone
-	rm -f test-convert-tla*		# GNU Arch tla
-	rm -f test-doctest*		# doctest always fails with python 2.5.x
-	if ! has userpriv ${FEATURES}; then
-		einfo "Removing tests which require user privileges to succeed"
-		rm -f test-command-template	# Test is broken when run as root
-		rm -f test-convert			# Test is broken when run as root
-		rm -f test-lock-badness		# Test is broken when run as root
-		rm -f test-permissions		# Test is broken when run as root
-		rm -f test-pull-permission	# Test is broken when run as root
-	fi
-	einfo "Running Mercurial tests ..."
-	python run-tests.py --tmpdir="${testdir}" || die "test failed"
-}
-
-pkg_postinst() {
-	distutils_pkg_postinst
-	use emacs && elisp-site-regen
-	bash-completion_pkg_postinst
-
-	elog "If you want to convert repositories from other tools using convert"
-	elog "extension please install correct tool:"
-	elog "  dev-util/cvs"
-	elog "  dev-util/darcs"
-	elog "  dev-util/git"
-	elog "  dev-util/monotone"
-	elog "  dev-util/subversion"
-}
-
-pkg_postrm() {
-	distutils_pkg_postrm
-	use emacs && elisp-site-regen
-}
--- a/dev-util/mercurial/metadata.xml	Thu May 28 10:29:39 2009 +0200
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,16 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-  <herd>no-herd</herd>
-  <maintainer>
-    <email>nelchael@gentoo.org</email>
-    <name>Krzysiek Pawlik</name>
-  </maintainer>
-  <use>
-    <flag name="bugzilla">Support bugzilla integration.</flag>
-    <flag name="darcs">Support conversion of Darcs repositories to Mercurial.</flag>
-    <flag name="git">Support conversion of Git repositories to Mercurial.</flag>
-    <flag name="gpg">Support signing with GnuPG.</flag>
-    <flag name="zsh-completion">Install zsh command completion for hg.</flag>
-  </use>
-</pkgmetadata>