changeset 184:54b73709801b

the ebuild works up to the install phase now. more testing has to be done on staging server
author Dirk Olmes <dirk@xanthippe.ping.de>
date Wed, 17 Feb 2010 10:16:48 +0100
parents 3cdcf4f4578c
children bf10d7d9cf43
files www-apps/redaxo/Manifest www-apps/redaxo/redaxo-4.2.1.ebuild
diffstat 2 files changed, 12 insertions(+), 14 deletions(-) [+]
line wrap: on
line diff
--- a/www-apps/redaxo/Manifest	Wed Feb 17 09:53:35 2010 +0100
+++ b/www-apps/redaxo/Manifest	Wed Feb 17 10:16:48 2010 +0100
@@ -1,2 +1,2 @@
 DIST redaxo4_2_1.zip 2143442 RMD160 18d637be99cf076bf2a9feb59a98357da0db192a SHA1 b8f8a23c2b8b97d2b2eb854fafe3001e22840043 SHA256 4d9daacc0104a47cb05c43ffe6be5445b0ed0d00bee4bea9e58e1ac46fd5d61b
-EBUILD redaxo-4.2.1.ebuild 1564 RMD160 29163d01226d7e2b826be3ad578441e42572efc0 SHA1 6076dfeff5a02ee8362c721e71b96d93c2404f10 SHA256 8ed5b0a0cd2b4169b44f0773bd49efc71dc5ee2bb1ee644509c8e545a2c17fd2
+EBUILD redaxo-4.2.1.ebuild 1421 RMD160 ce76ae6d5254e8ed43232c5675f060d543aa6a2b SHA1 ee1c1adacfc11370b1f9d183ecb213c527b384f2 SHA256 03e3f98a8bdb9b992e403a3941f5fd2c3e178a7035921b17838803b7b12cc785
--- a/www-apps/redaxo/redaxo-4.2.1.ebuild	Wed Feb 17 09:53:35 2010 +0100
+++ b/www-apps/redaxo/redaxo-4.2.1.ebuild	Wed Feb 17 10:16:48 2010 +0100
@@ -17,8 +17,6 @@
 
 need_php_httpd
 
-S="${WORKDIR}/${MY_P}"
-
 pkg_setup() {
      webapp_pkg_setup
 
@@ -33,26 +31,26 @@
     unpack ${A}
 
     # clean up some cruft that comes as part of the install package
-    cd ${S}
+    cd ${WORKDIR}/${MY_P}
     find . -name .DS_Store -exec rm {} \;
 }
 
+function remove_if_exists() {
+    if [ -f $1 ]; then
+        rm $1
+    fi
+}
+
 src_install() {
     webapp_src_preinst
 
-#    rm docs/INSTALL*
-#    local docs="docs/*"
-#    dodoc ${docs}
-#    rm -rf docs/
-
     einfo "Installing application files."
+    cd ${MY_P}
     cp -r . "${D}"${MY_HTDOCSDIR}
-    touch "${D}"${MY_HTDOCSDIR}/.htaccess
-#    touch "${D}"${MY_HTDOCSDIR}/serendipity_config_local.inc.php
 
-    # the files directory will be populated by the user
-    keepdir ${MY_HTDOCSDIR}/files/
-#    webapp_configfile ${MY_HTDOCSDIR}/serendipity_config_local.inc.php
+    # get rid of some cruft
+    remove_if_exists ${MY_HTDOCSDIR}/_lastchanges.txt
+    remove_if_exists ${MY_HTDOCSDIR}/_lizenz.txt
 
     # .htaccess, index.php and the redaxo dir are part of the distro
     local SERVEROWNED=".htaccess index.php redaxo"