changeset 361:5c773728083e

remove outdated skype ebuild
author Dirk Olmes <dirk@xanthippe.ping.de>
date Thu, 11 Sep 2014 04:13:32 +0200
parents a24a56c57078
children e147f2b69f0f
files net-im/skype/Manifest net-im/skype/skype-4.1.0.20.ebuild
diffstat 2 files changed, 0 insertions(+), 103 deletions(-) [+]
line wrap: on
line diff
--- a/net-im/skype/Manifest	Thu Sep 11 04:12:57 2014 +0200
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,2 +0,0 @@
-DIST skype-4.1.0.20.tar.bz2 30500691 SHA256 c31e47cd5dcb14eead897f36bab80ee8d49c0e6dbf469c93bf745d5addec0ce2 SHA512 81cc8426d609735b6b86307300089365f43b5b492f6f99e7794b83a2b028f1e4031c0f045ec7a6e5ea4c34d618a6e1af56b21227f4b4049fb3e3430444228818 WHIRLPOOL 894fa9c8b97b02e88c23aa7a63edf49d3059e22c273220cd8cfc26cbe5e28e14a786b311b664208de1144153a7037f122d41830aeb1300a9646869a17387b406
-EBUILD skype-4.1.0.20.ebuild 2483 SHA256 2de1209091e828cd06a58f7fad046f7daf54559d5518a1c2eb0c26e72cb89fea SHA512 cefc821e4693832e0e8d4cea44a6e8e19346a3b857c6dfc0a68c60ef925e9f484b389dba17a4f7b2d36e84e618f59578d8b98f05b3df3f1ebb649e09c31cdfec WHIRLPOOL c31857f71854fd5f5a7b8510aad6f34a5f01690e889f21610c303a586ae1b606b935a396632b10cbce4a118f677e9dca22d306656a6df71b990e7d5371899528
--- a/net-im/skype/skype-4.1.0.20.ebuild	Thu Sep 11 04:12:57 2014 +0200
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,101 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header $
-
-EAPI=4
-inherit eutils gnome2-utils pax-utils
-
-DESCRIPTION="An P2P Internet Telephony (VoiceIP) client"
-HOMEPAGE="http://www.skype.com/"
-SKYPE_URI="http://download.${PN}.com/linux"
-SRC_URI="${SKYPE_URI}/${P}.tar.bz2"
-
-LICENSE="${P}-copyright ${P}-third-party_attributions.txt"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="pax_kernel"
-
-QA_PREBUILT=opt/bin/${PN}
-RESTRICT="mirror strip" #299368
-
-EMUL_X86_VER=20120520
-
-RDEPEND="virtual/ttf-fonts
-	amd64? (
-		>=app-emulation/emul-linux-x86-baselibs-${EMUL_X86_VER}
-		>=app-emulation/emul-linux-x86-soundlibs-${EMUL_X86_VER}
-		>=app-emulation/emul-linux-x86-xlibs-${EMUL_X86_VER}
-		>=app-emulation/emul-linux-x86-qtlibs-${EMUL_X86_VER} 
-	)
-	x86? (
-		media-libs/alsa-lib
-		x11-libs/libX11
-		x11-libs/libXext
-		x11-libs/libXScrnSaver
-		x11-libs/libXv
-		x11-libs/qt-core:4
-		x11-libs/qt-dbus:4
-		x11-libs/qt-gui:4[accessibility,dbus]
-	)"
-
-src_unpack() {
-	unpack ${A}
-	[[ -d ${S} ]] || { mv skype* "${S}" || die; }
-}
-
-src_compile() {
-	type -P lrelease >/dev/null && lrelease lang/*.ts
-	rm -f lang/*.ts
-}
-
-src_install() {
-	into /opt
-	dobin ${PN}
-	fowners root:audio /opt/bin/${PN}
-
-	insinto /etc/dbus-1/system.d
-	doins ${PN}.conf
-
-	insinto /usr/share/skype
-	doins -r avatars lang sounds
-
-	dodoc README
-
-	local res
-	for res in 16 32 48; do
-		newicon -s ${res} icons/SkypeBlue_${res}x${res}.png ${PN}.png
-	done
-
-	make_desktop_entry ${PN} 'Skype VoIP' ${PN} 'Network;InstantMessaging;Telephony'
-
-	if use pax_kernel; then
-		pax-mark Cm "${ED}"/opt/bin/${PN} || die
-		eqawarn "You have set USE=pax_kernel meaning that you intend to run"
-		eqawarn "${PN} under a PaX enabled kernel.  To do so, we must modify"
-		eqawarn "the ${PN} binary itself and this *may* lead to breakage!  If"
-		eqawarn "you suspect that ${PN} is being broken by this modification,"
-		eqawarn "please open a bug."
-	fi
-}
-
-pkg_preinst() {
-	gnome2_icon_savelist
-
-	rm -rf "${EROOT}"/usr/share/${PN} #421165
-}
-
-pkg_postinst() {
-	gnome2_icon_cache_update
-
-	# http://bugs.gentoo.org/360815
-	elog "For webcam support, see \"LD_PRELOAD\" section of \"README.lib\" document provided by"
-	elog "media-libs/libv4l package and \"README\" document of this package."
-	if use amd64; then
-		elog "You can install app-emulation/emul-linux-x86-medialibs package for the 32bit"
-		elog "libraries from the media-libs/libv4l package."
-	fi
-}
-
-pkg_postrm() {
-	gnome2_icon_cache_update
-}