changeset 53:5f7d8fd4d921

revbumps for e1000/e1000e
author holger@hoho.dyndns.org
date Fri, 04 Jul 2008 14:37:06 +0200
parents 021734360017
children 9b94f3384205
files net-misc/e1000/Manifest net-misc/e1000/e1000-8.0.1.ebuild net-misc/e1000/e1000-8.0.3.1.ebuild net-misc/e1000e/Manifest net-misc/e1000e/e1000e-0.2.9.5.ebuild net-misc/e1000e/e1000e-0.4.1.7.ebuild
diffstat 6 files changed, 99 insertions(+), 100 deletions(-) [+]
line wrap: on
line diff
--- a/net-misc/e1000/Manifest	Tue Jun 24 10:00:49 2008 +0200
+++ b/net-misc/e1000/Manifest	Fri Jul 04 14:37:06 2008 +0200
@@ -1,2 +1,2 @@
-DIST e1000-8.0.1.tar.gz 197425 RMD160 1ca429ea1569aff91ab6bff8ac81c9442032c5c5 SHA1 46ea822156326445f25477cc51b2c9e81e9608dc SHA256 21d2782db2db897fefa222df05258541934d2dfdef4d577cd0dc1dd77e4bafd1
-EBUILD e1000-8.0.1.ebuild 1378 RMD160 d36ce4380b793c12c5e15b1b994e53c3aca38fb4 SHA1 0a1df1551fca9cccff44672524b012dfa472cce6 SHA256 9c8e7d27e571b2ef41b840803c46a2e3f9068874054809fee2ff3795032c1ecd
+DIST e1000-8.0.3.1.tar.gz 199029 RMD160 a07d3b52f80c8f7c6e3a0e8a20db38431822397f SHA1 6fef2b7f9636c70d003789593f8e211217264416 SHA256 0751afb6d5191eef568f44c0b57b6d39271df28b3f8ff1eecbc5d35373c00a59
+EBUILD e1000-8.0.3.1.ebuild 1378 RMD160 d36ce4380b793c12c5e15b1b994e53c3aca38fb4 SHA1 0a1df1551fca9cccff44672524b012dfa472cce6 SHA256 9c8e7d27e571b2ef41b840803c46a2e3f9068874054809fee2ff3795032c1ecd
--- a/net-misc/e1000/e1000-8.0.1.ebuild	Tue Jun 24 10:00:49 2008 +0200
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,49 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-DESCRIPTION="Kernel driver for Intel Pro/1000 ethernet adapters."
-HOMEPAGE="http://support.intel.com/support/network/adapter/1000/index.htm"
-LICENSE="GPL-2"
-DEPEND="virtual/linux-sources"
-
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-SLOT="0"
-KEYWORDS="x86"
-IUSE=""
-
-
-src_unpack() {
-    unpack ${A}
-    cd ${S}/src
-    # rem out the DEPVER line, since it would cause a sandbox violation and
-    # since it is only needed by RPM ;-)
-    sed -i "/^DEPVER :=/ d" Makefile
-}
-
-
-src_compile() {
-    check_KV
-    cd "${S}/src"
-
-    # workaround needed for some ethernet controllers to work with low end switches
-    if [[ ${USE_INCOMPATIBLE_SWITCH} ]]
-        then CFLAGS_EXTRA="CFLAGS_EXTRA=-DE_1000_MASTER_SLAVE=1"
-        else CFLAGS_EXTRA=""
-    fi
-
-    make ${CFLAGS_EXTRA} KSRC=/usr/src/linux
-}
-
-
-src_install() {
-    insinto "/lib/modules/${KV}/kernel/drivers/net/e1000"
-    doins "${S}/src/e1000.ko"
-    doman e1000.7
-    dodoc LICENSE README SUMS e1000.spec ldistrib.txt ${FILESDIR}/README.Gentoo
-    einfo ""
-    einfo "In case you have problems when loading the module, try to run depmod -A"
-    einfo ""
-    einfo "If you experience problems with low-end switches, read"
-    einfo "/usr/share/doc/${PF}/README.Gentoo.gz for a possible workaround"
-    einfo ""
-}
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-misc/e1000/e1000-8.0.3.1.ebuild	Fri Jul 04 14:37:06 2008 +0200
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="Kernel driver for Intel Pro/1000 ethernet adapters."
+HOMEPAGE="http://support.intel.com/support/network/adapter/1000/index.htm"
+LICENSE="GPL-2"
+DEPEND="virtual/linux-sources"
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+
+src_unpack() {
+    unpack ${A}
+    cd ${S}/src
+    # rem out the DEPVER line, since it would cause a sandbox violation and
+    # since it is only needed by RPM ;-)
+    sed -i "/^DEPVER :=/ d" Makefile
+}
+
+
+src_compile() {
+    check_KV
+    cd "${S}/src"
+
+    # workaround needed for some ethernet controllers to work with low end switches
+    if [[ ${USE_INCOMPATIBLE_SWITCH} ]]
+        then CFLAGS_EXTRA="CFLAGS_EXTRA=-DE_1000_MASTER_SLAVE=1"
+        else CFLAGS_EXTRA=""
+    fi
+
+    make ${CFLAGS_EXTRA} KSRC=/usr/src/linux
+}
+
+
+src_install() {
+    insinto "/lib/modules/${KV}/kernel/drivers/net/e1000"
+    doins "${S}/src/e1000.ko"
+    doman e1000.7
+    dodoc LICENSE README SUMS e1000.spec ldistrib.txt ${FILESDIR}/README.Gentoo
+    einfo ""
+    einfo "In case you have problems when loading the module, try to run depmod -A"
+    einfo ""
+    einfo "If you experience problems with low-end switches, read"
+    einfo "/usr/share/doc/${PF}/README.Gentoo.gz for a possible workaround"
+    einfo ""
+}
--- a/net-misc/e1000e/Manifest	Tue Jun 24 10:00:49 2008 +0200
+++ b/net-misc/e1000e/Manifest	Fri Jul 04 14:37:06 2008 +0200
@@ -1,3 +1,2 @@
-DIST e1000e-0.2.9.5.tar.gz 175390 RMD160 0234455b22b4cb61e2956d4729503a68a178db7c SHA1 e050692d0854b1308b9eb5042f166d34e33a75fa SHA256 051861bc49a759a519f77b10a7835059f270c280423c10f8da00a835430c62a9
-EBUILD e1000e-0.2.9.5.ebuild 1187 RMD160 39892b555fbfae0f5a921640b9f7a6672a5d269a SHA1 6c992484bb31def68606054e69fb9978f27cd220 SHA256 319fb813eef746f8263ff84df28529b67733afecfd97c5fbcac8fcf4eb713c14
-MISC e1000e-0.2.9.5.ebuild~ 1200 RMD160 e6a381ceb28719e3da28745df2330d54d5942b72 SHA1 c8fbac1d72eb1d353f3aaff189ab286857987aac SHA256 82856e774e3ec5ae3b07d6d52d82fc23bcd37a63f7d213e08e33d46901d7f598
+DIST e1000e-0.4.1.7.tar.gz 200496 RMD160 e03441ffaa7bac2d0b7b0f1b0d8c8434641af935 SHA1 b919215aa566ff00e52425447a7ec43af6170ba8 SHA256 95bd9b275166ead953ebc828597433044ea708093ede6864ed2aac4b64a62175
+EBUILD e1000e-0.4.1.7.ebuild 1187 RMD160 39892b555fbfae0f5a921640b9f7a6672a5d269a SHA1 6c992484bb31def68606054e69fb9978f27cd220 SHA256 319fb813eef746f8263ff84df28529b67733afecfd97c5fbcac8fcf4eb713c14
--- a/net-misc/e1000e/e1000e-0.2.9.5.ebuild	Tue Jun 24 10:00:49 2008 +0200
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,46 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-DESCRIPTION="Kernel driver for Intel Pro/1000 ethernet adapters."
-HOMEPAGE="http://support.intel.com/support/network/adapter/1000/index.htm"
-LICENSE="GPL-2"
-DEPEND="virtual/linux-sources"
-
-SRC_URI="mirror://sourceforge/e1000/${P}.tar.gz"
-SLOT="0"
-KEYWORDS="x86"
-IUSE=""
-
-
-src_unpack() {
-    unpack ${A}
-    cd ${S}/src
-    # rem out the DEPVER line, since it would cause a sandbox violation and
-    # since it is only needed by RPM ;-)
-    sed -i "/^DEPVER :=/ d" Makefile
-}
-
-
-src_compile() {
-    check_KV
-    cd "${S}/src"
-
-    # workaround needed for some ethernet controllers to work with low end switches
-    if [[ ${USE_INCOMPATIBLE_SWITCH} ]]
-        then CFLAGS_EXTRA="CFLAGS_EXTRA=-DE_1000_MASTER_SLAVE=1"
-        else CFLAGS_EXTRA=""
-    fi
-
-    make ${CFLAGS_EXTRA} KSRC=/usr/src/linux
-}
-
-
-src_install() {
-    insinto "/lib/modules/${KV}/kernel/drivers/net/e1000e"
-    doins "${S}/src/e1000e.ko"
-    doman e1000e.7
-    dodoc COPYING README SUMS e1000e.spec
-    einfo ""
-    einfo "In case you have problems when loading the module, try to run depmod -A"
-    einfo ""
-}
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-misc/e1000e/e1000e-0.4.1.7.ebuild	Fri Jul 04 14:37:06 2008 +0200
@@ -0,0 +1,46 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="Kernel driver for Intel Pro/1000 ethernet adapters."
+HOMEPAGE="http://support.intel.com/support/network/adapter/1000/index.htm"
+LICENSE="GPL-2"
+DEPEND="virtual/linux-sources"
+
+SRC_URI="mirror://sourceforge/e1000/${P}.tar.gz"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+
+src_unpack() {
+    unpack ${A}
+    cd ${S}/src
+    # rem out the DEPVER line, since it would cause a sandbox violation and
+    # since it is only needed by RPM ;-)
+    sed -i "/^DEPVER :=/ d" Makefile
+}
+
+
+src_compile() {
+    check_KV
+    cd "${S}/src"
+
+    # workaround needed for some ethernet controllers to work with low end switches
+    if [[ ${USE_INCOMPATIBLE_SWITCH} ]]
+        then CFLAGS_EXTRA="CFLAGS_EXTRA=-DE_1000_MASTER_SLAVE=1"
+        else CFLAGS_EXTRA=""
+    fi
+
+    make ${CFLAGS_EXTRA} KSRC=/usr/src/linux
+}
+
+
+src_install() {
+    insinto "/lib/modules/${KV}/kernel/drivers/net/e1000e"
+    doins "${S}/src/e1000e.ko"
+    doman e1000e.7
+    dodoc COPYING README SUMS e1000e.spec
+    einfo ""
+    einfo "In case you have problems when loading the module, try to run depmod -A"
+    einfo ""
+}