changeset 356:627e480843ea

add an openshot ebuild
author Dirk Olmes <dirk@xanthippe.ping.de>
date Mon, 16 Jun 2014 06:53:32 +0200
parents b5842c196f43
children cfab2dff56a9
files media-video/openshot/Manifest media-video/openshot/openshot-1.4.3.ebuild
diffstat 2 files changed, 73 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/media-video/openshot/Manifest	Mon Jun 16 06:53:32 2014 +0200
@@ -0,0 +1,2 @@
+DIST openshot-1.4.3.tar.gz 31990991 SHA256 5bebf1c59a8667b0263599544f2d23ce6be3ab79ce24a85b766e1e39cab859d0 SHA512 f3221c3e508ccf61d4fd2771de47f42ddb1a78996853011ee336e8ccf842a0fd97707a60c677e1465a89e6eb67911b6eb98b002959f8a29ac9e31924bbb6fcda WHIRLPOOL 4fd8d5b5db2923c8b7349032847087b9cf4ccdbade206c5c6cc9aac27ace6e99c6053bd1184cf14b20c80b4f666baf356798a5b6a8d6c7c737a9a986894943af
+EBUILD openshot-1.4.3.ebuild 1898 SHA256 3b2ea941bbb2e7cc7c87411a795fa09c5e2312b14558272bcddce2d79e34ddcc SHA512 8c7f12eb3378e23a71db404aa82e990f3a969a1d2aacdca3e9c8c04ae38cd1974e61acbfa1cc2e4fb49d428936eb9b62a910b5a90d4eb72cc56c58283e00e666 WHIRLPOOL 635af117dc7af49db764728bf71d7604cf09aab418b1758b18687a5058f46abe59f7bd60cf65f74f79c228995eb9d2e4fcf2614f3cf7add5336e3985678831fe
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/media-video/openshot/openshot-1.4.3.ebuild	Mon Jun 16 06:53:32 2014 +0200
@@ -0,0 +1,71 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+PYTHON_DEPEND=2:2.5
+PYTHON_USE_WITH=xml
+
+inherit versionator distutils fdo-mime
+
+DESCRIPTION="OpenShot Video Editor is a non-linear video editor"
+HOMEPAGE="http://www.openshotvideo.com"
+SRC_URI="http://launchpad.net/openshot/$(get_version_component_range 1-2)/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+	x11-libs/gtk+:2
+	dev-python/pygtk
+	dev-python/pygoocanvas
+	dev-python/pyxdg
+	dev-python/librsvg-python
+	dev-python/httplib2
+	media-libs/mlt[ffmpeg,frei0r,gtk,melt,python,sdl,xml]
+	media-sound/sox[encode,ffmpeg]
+	>=virtual/ffmpeg-0.6[encode,sdl]
+	virtual/python-imaging
+	"
+#>=virtual/ffmpeg-0.6[encode,faac?,ieee1394?,mp3?,sdl,theora?,vorbis?,vpx,x264?,xvid?]
+pkg_setup() {
+	python_set_active_version 2
+	python_pkg_setup
+}
+
+src_prepare() {
+	python_convert_shebangs -q -r 2 .
+	distutils_src_prepare
+
+	# Disable the installation of the mime.types file.
+	# The .desktop file would be used to update the mime database.
+	sed -ie '/launcher/,+1d' setup.py || die
+
+	# Avoid stuff covered by fdo-mime.eclass
+	# (update-mime-database update-desktop-database update-mime)
+	# export "FAKEROOTKEY=gentoo" does not work as this variable is filtered
+	# by portage
+	sed -ie '/FAILED = /,$d' setup.py || die
+}
+
+# TODO: check stuff installed to /usr/lib/python2.6/site-packages as there are
+# some parts installed which shouldn't (locale, themes, profiles effects,
+# etc...) Afaik only python stuff should go there and the rest probably to
+# /usr/share/openshot
+# The same goes for /usr/lib/mime/packages
+
+pkg_postinst() {
+	fdo-mime_mime_database_update
+	fdo-mime_desktop_database_update
+	distutils_pkg_postinst
+}
+
+pkg_postrm() {
+	fdo-mime_mime_database_update
+	fdo-mime_desktop_database_update
+	distutils_pkg_postrm
+}