changeset 119:64fce6b4ea9c

fixed and updated ebuild for pgpool-II
author holger@hoho.dyndns.org
date Fri, 20 Mar 2009 10:34:39 +0100
parents fc14e6182db4
children 17e88fb0f6f2
files dev-db/pgpool-II/Manifest dev-db/pgpool-II/files/pgpool-II.init dev-db/pgpool-II/pgpool-II-2.2.ebuild
diffstat 3 files changed, 58 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-db/pgpool-II/Manifest	Fri Mar 20 10:34:39 2009 +0100
@@ -0,0 +1,3 @@
+AUX pgpool-II.init 404 RMD160 67dc594fca4d8573e608127f1e2744d9bf63d8b6 SHA1 06aef9164999516c0340ac92c38595cc51ef7106 SHA256 7ad6a66d400f8f3bbdeff4d76d8fa57f71207a245ec9b5b51d7eb537afefedd5
+DIST pgpool-II-2.2.tar.gz 961675 RMD160 adfeb49ae04fc765b221b9232e1285d3f922e8d3 SHA1 877832eb777e0ab49feed24444a55fab3ff583b4 SHA256 2a404dd3965c5d869c17ab0c031395a43445d6fcf0c72df8bd78d9629b8ed25b
+EBUILD pgpool-II-2.2.ebuild 921 RMD160 b2c9a567dc786580ff7518e5f53c73ef2e7b71ce SHA1 61c0bf6b278ee5cf7055b0c863009a96b4afe87e SHA256 cadd196b00ea39e1a077d20f4f94139e8af3a967344e48683f425f9234f0ecaa
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-db/pgpool-II/files/pgpool-II.init	Fri Mar 20 10:34:39 2009 +0100
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+	need net
+}
+
+start() {
+	ebegin "Starting pgpool-II"
+	start-stop-daemon --start --quiet --exec /usr/bin/pgpool
+	result=$?
+	eend $result
+}
+
+stop() {
+	ebegin "Stopping pgpool-II"
+	start-stop-daemon --stop --quiet --pidfile /var/run/pgpool.pid
+	result=$?
+	eend $result
+}
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-db/pgpool-II/pgpool-II-2.2.ebuild	Fri Mar 20 10:34:39 2009 +0100
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="New generation connection pool server for PostgreSQL"
+HOMEPAGE="http://pgpool.projects.postgresql.org/"
+SRC_URI="http://pgfoundry.org/frs/download.php/2108/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-db/postgresql-base"
+
+src_unpack() {
+	unpack ${A}
+	cd ${S}
+	sed -i -e "/^logdir/s:/tmp:/var/run:g" pgpool.conf.sample || die
+}
+
+src_compile() {
+	econf --with-pgsql=/usr/include/postgresql || die
+	emake || die
+}
+
+src_install () {
+	einstall || die
+	mv ${D}/etc/pcp.conf.sample ${D}/etc/pcp.conf
+	mv ${D}/etc/pgpool.conf.sample ${D}/etc/pgpool.conf
+	mv ${D}/etc/pool_hba.conf.sample ${D}/etc/pool_hba.conf
+	dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README* TODO
+	newinitd "${FILESDIR}/pgpool-II.init" pgpool-II || die "Inserting init.d-file failed"
+}
+