changeset 91:6915f1f9ea05

patches to grub to boot with ext4
author holger@hoho.dyndns.org
date Sat, 27 Dec 2008 15:41:47 +0100
parents a040f798b26c
children 7f53c44576cc
files sys-boot/grub/Manifest sys-boot/grub/files/grub-0.97-ext4extents.patch sys-boot/grub/files/grub.conf.gentoo sys-boot/grub/grub-0.97-r8.ebuild sys-boot/grub/metadata.xml
diffstat 5 files changed, 552 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/sys-boot/grub/Manifest	Sat Dec 27 15:41:47 2008 +0100
@@ -0,0 +1,7 @@
+AUX grub-0.97-ext4extents.patch 8966 RMD160 fc682b978a986114cf55351beea911f3fb9b301f SHA1 26a7237290da98fa6572e411f4dfe1a4463fd0d4 SHA256 f1b703932892521e03c4c6b1331dc36b7637a7de381e49454e5ca1bc32cc41f4
+AUX grub.conf.gentoo 627 RMD160 d90fb4373bad476f98ec9c5065d6cdfd9e3b706f SHA1 004f2fc04605ec9190de0a87e7df8bbc33daff89 SHA256 914b15af252210a32776196437cd8013e10e57d5780e66877ef3fe9a2b4b9776
+DIST grub-0.97-patches-1.8.tar.bz2 48274 RMD160 99c967daca704e853e9d161a51db3d39040bab4f SHA1 3e643d8de0d77456409176ebc4b3b14d547d99dc SHA256 fcd16e6def8ace7bb5928c2d16ddb032a57a5df24a69f9cfae5ce6292785318b
+DIST grub-0.97.tar.gz 971783 RMD160 7fb5674edf0c950bd38e94f85ff1e2909aa741f0 SHA1 2580626c4579bd99336d3af4482c346c95dac4fb SHA256 4e1d15d12dbd3e9208111d6b806ad5a9857ca8850c47877d36575b904559260b
+DIST splash.xpm.gz 33856 RMD160 2fead61f91c368429e80936248bb02af2bdf15ff SHA1 98e679f9698be43426f971f89a088c053e8c804a SHA256 b95600f777331b0dd31d51c68f60f0e846e4c8b628857a41165f4e6b30e6acaf
+EBUILD grub-0.97-r8.ebuild 8922 RMD160 a66f88ba33fe567060839dac82d5157694fbb8a9 SHA1 3fce3976af5c675666c6de64ceaa9e0e86841722 SHA256 cdcdab1b4bcb906863cc80319c0ea2518fc753d7b35aff43e45dd7134fd9aaef
+MISC metadata.xml 250 RMD160 5d297cf8754c72fea2a5afa5b9e3b35c2e131f31 SHA1 37c9d016076a9869497199b1d2280437b01aa9ee SHA256 9cc0f0e1b861d82b2396fa0ea25e5ea3f41d066fbce9ef9404d651a011020be3
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/sys-boot/grub/files/grub-0.97-ext4extents.patch	Sat Dec 27 15:41:47 2008 +0100
@@ -0,0 +1,250 @@
+diff -ruNp grub-0.97/stage2/fsys_ext2fs.c grub-0.97-patch/stage2/fsys_ext2fs.c
+--- grub-0.97/stage2/fsys_ext2fs.c	2008-06-03 12:54:49.502889887 +0200
++++ grub-0.97-patch/stage2/fsys_ext2fs.c	2008-06-03 13:30:03.296031725 +0200
+@@ -50,6 +50,8 @@ typedef unsigned int __u32;
+ #define EXT2_DIND_BLOCK                 (EXT2_IND_BLOCK + 1)
+ #define EXT2_TIND_BLOCK                 (EXT2_DIND_BLOCK + 1)
+ #define EXT2_N_BLOCKS                   (EXT2_TIND_BLOCK + 1)
++/* Inode flags */
++#define EXT4_EXTENTS_FL                 0x00080000 /* Inode uses extents */
+ 
+ /* include/linux/ext2_fs.h */
+ struct ext2_super_block
+@@ -235,7 +237,42 @@ struct ext2_dir_entry
+ #define EXT2_DIR_ROUND                  (EXT2_DIR_PAD - 1)
+ #define EXT2_DIR_REC_LEN(name_len)      (((name_len) + 8 + EXT2_DIR_ROUND) & \
+                                          ~EXT2_DIR_ROUND)
++/* linux/ext4_fs_extents.h */
++/*
++ * This is the extent on-disk structure.
++ * It's used at the bottom of the tree.
++ */
++struct ext4_extent {
++    __u32 ee_block;       /* first logical block extent covers */
++    __u16 ee_len;         /* number of blocks covered by extent */
++    __u16 ee_start_hi;    /* high 16 bits of physical block */
++    __u32 ee_start;       /* low 32 bits of physical block */
++};
+ 
++/*
++ * This is index on-disk structure.
++ * It's used at all the levels except the bottom.
++ */
++struct ext4_extent_idx {
++    __u32 ei_block;       /* index covers logical blocks from 'block' */
++    __u32 ei_leaf;        /* pointer to the physical block of the next *
++                                 * level. leaf or next index could be there */
++    __u16 ei_leaf_hi;     /* high 16 bits of physical block */
++    __u16 ei_unused;
++};
++
++/*
++ * Each block (leaves and indexes), even inode-stored has header.
++ */
++struct ext4_extent_header {
++    __u16  eh_magic;       /* probably will support different formats */
++    __u16  eh_entries;     /* number of valid entries */
++    __u16  eh_max;         /* capacity of store in entries */
++    __u16  eh_depth;       /* has tree real underlying blocks? */
++    __u32  eh_generation;  /* generation of the tree */
++};
++
++#define EXT4_EXT_MAGIC          0xf30a
+ 
+ /* ext2/super.c */
+ #define log2(n) ffz(~(n))
+@@ -327,6 +364,26 @@ ext2_rdfsb (int fsblock, int buffer)
+ 		  EXT2_BLOCK_SIZE (SUPERBLOCK), (char *) buffer);
+ }
+ 
++/* Walk through extents index tree to find the good leaf */
++static struct ext4_extent_header * 
++ext4_recurse_extent_index(struct ext4_extent_header *extent_block, int logical_block)
++{
++  int i;
++  struct ext4_extent_idx *index = (struct ext4_extent_idx *) (extent_block + 1);
++  if (extent_block->eh_magic != EXT4_EXT_MAGIC)
++    return NULL;
++  if (extent_block->eh_depth == 0)
++    return extent_block;
++  for (i = 0; i < extent_block->eh_entries; i++)
++    {
++      if (logical_block < index[i].ei_block)
++        break;
++    }
++  if (i == 0 || !ext2_rdfsb(index[i-1].ei_leaf, DATABLOCK1))
++    return NULL;
++  return (ext4_recurse_extent_index((struct ext4_extent_header *) DATABLOCK1, logical_block));
++}
++
+ /* from
+   ext2/inode.c:ext2_bmap()
+ */
+@@ -355,83 +412,93 @@ ext2fs_block_map (int logical_block)
+     }
+   printf ("logical block %d\n", logical_block);
+ #endif /* E2DEBUG */
+-
+-  /* if it is directly pointed to by the inode, return that physical addr */
+-  if (logical_block < EXT2_NDIR_BLOCKS)
+-    {
+-#ifdef E2DEBUG
+-      printf ("returning %d\n", (unsigned char *) (INODE->i_block[logical_block]));
+-      printf ("returning %d\n", INODE->i_block[logical_block]);
+-#endif /* E2DEBUG */
+-      return INODE->i_block[logical_block];
+-    }
+-  /* else */
+-  logical_block -= EXT2_NDIR_BLOCKS;
+-  /* try the indirect block */
+-  if (logical_block < EXT2_ADDR_PER_BLOCK (SUPERBLOCK))
+-    {
+-      if (mapblock1 != 1
+-	  && !ext2_rdfsb (INODE->i_block[EXT2_IND_BLOCK], DATABLOCK1))
+-	{
+-	  errnum = ERR_FSYS_CORRUPT;
+-	  return -1;
+-	}
+-      mapblock1 = 1;
+-      return ((__u32 *) DATABLOCK1)[logical_block];
+-    }
+-  /* else */
+-  logical_block -= EXT2_ADDR_PER_BLOCK (SUPERBLOCK);
+-  /* now try the double indirect block */
+-  if (logical_block < (1 << (EXT2_ADDR_PER_BLOCK_BITS (SUPERBLOCK) * 2)))
+-    {
+-      int bnum;
+-      if (mapblock1 != 2
+-	  && !ext2_rdfsb (INODE->i_block[EXT2_DIND_BLOCK], DATABLOCK1))
+-	{
+-	  errnum = ERR_FSYS_CORRUPT;
+-	  return -1;
+-	}
+-      mapblock1 = 2;
+-      if ((bnum = (((__u32 *) DATABLOCK1)
+-		   [logical_block >> EXT2_ADDR_PER_BLOCK_BITS (SUPERBLOCK)]))
+-	  != mapblock2
+-	  && !ext2_rdfsb (bnum, DATABLOCK2))
+-	{
+-	  errnum = ERR_FSYS_CORRUPT;
+-	  return -1;
+-	}
+-      mapblock2 = bnum;
+-      return ((__u32 *) DATABLOCK2)
+-	[logical_block & (EXT2_ADDR_PER_BLOCK (SUPERBLOCK) - 1)];
+-    }
+-  /* else */
+-  mapblock2 = -1;
+-  logical_block -= (1 << (EXT2_ADDR_PER_BLOCK_BITS (SUPERBLOCK) * 2));
+-  if (mapblock1 != 3
+-      && !ext2_rdfsb (INODE->i_block[EXT2_TIND_BLOCK], DATABLOCK1))
+-    {
+-      errnum = ERR_FSYS_CORRUPT;
+-      return -1;
+-    }
+-  mapblock1 = 3;
+-  if (!ext2_rdfsb (((__u32 *) DATABLOCK1)
+-		   [logical_block >> (EXT2_ADDR_PER_BLOCK_BITS (SUPERBLOCK)
+-				      * 2)],
+-		   DATABLOCK2))
+-    {
+-      errnum = ERR_FSYS_CORRUPT;
+-      return -1;
+-    }
+-  if (!ext2_rdfsb (((__u32 *) DATABLOCK2)
+-		   [(logical_block >> EXT2_ADDR_PER_BLOCK_BITS (SUPERBLOCK))
+-		    & (EXT2_ADDR_PER_BLOCK (SUPERBLOCK) - 1)],
+-		   DATABLOCK2))
+-    {
++/* standard ext2 inode */
++if (!(INODE->i_flags & EXT4_EXTENTS_FL))  
++   {
++/* if it is directly pointed to by the inode, return that physical addr */
++      if (logical_block < EXT2_NDIR_BLOCKS)
++        {
++#ifdef E2DEBUG
++          printf ("returning %d\n", (unsigned char *) (INODE->i_block[logical_block]));
++          printf ("returning %d\n", INODE->i_block[logical_block]);
++#endif /* E2DEBUG */
++          return INODE->i_block[logical_block];
++        }
++      /* else */
++      logical_block -= EXT2_NDIR_BLOCKS;
++      /* try the indirect block */
++      if (logical_block < EXT2_ADDR_PER_BLOCK (SUPERBLOCK))
++        {
++          if (mapblock1 != 1 && !ext2_rdfsb (INODE->i_block[EXT2_IND_BLOCK], DATABLOCK1))
++            {
++              errnum = ERR_FSYS_CORRUPT;
++              return -1;
++            }
++          mapblock1 = 1;
++          return ((__u32 *) DATABLOCK1)[logical_block];
++        }
++      /* else */
++      logical_block -= EXT2_ADDR_PER_BLOCK (SUPERBLOCK);
++      /* now try the double indirect block */
++      if (logical_block < (1 << (EXT2_ADDR_PER_BLOCK_BITS (SUPERBLOCK) * 2)))
++        {
++          int bnum;
++          if (mapblock1 != 2 && !ext2_rdfsb (INODE->i_block[EXT2_DIND_BLOCK], DATABLOCK1))
++            {
++              errnum = ERR_FSYS_CORRUPT;
++              return -1;
++            }
++          mapblock1 = 2;
++          if ((bnum = (((__u32 *) DATABLOCK1) [logical_block >> EXT2_ADDR_PER_BLOCK_BITS (SUPERBLOCK)])) != mapblock2 && !ext2_rdfsb (bnum, DATABLOCK2))
++            {
++              errnum = ERR_FSYS_CORRUPT;
++              return -1;
++            }
++          mapblock2 = bnum;
++          return ((__u32 *) DATABLOCK2) [logical_block & (EXT2_ADDR_PER_BLOCK (SUPERBLOCK) - 1)];
++        }
++      /* else */
++      mapblock2 = -1;
++      logical_block -= (1 << (EXT2_ADDR_PER_BLOCK_BITS (SUPERBLOCK) * 2));
++      if (mapblock1 != 3 && !ext2_rdfsb (INODE->i_block[EXT2_TIND_BLOCK], DATABLOCK1))
++        {
++          errnum = ERR_FSYS_CORRUPT;
++          return -1;
++        }
++      mapblock1 = 3;
++      if (!ext2_rdfsb (((__u32 *) DATABLOCK1) [logical_block >> (EXT2_ADDR_PER_BLOCK_BITS (SUPERBLOCK) * 2)], DATABLOCK2))
++        {
++          errnum = ERR_FSYS_CORRUPT;
++          return -1;
++        }
++      if (!ext2_rdfsb (((__u32 *) DATABLOCK2) [(logical_block >> EXT2_ADDR_PER_BLOCK_BITS (SUPERBLOCK)) & (EXT2_ADDR_PER_BLOCK (SUPERBLOCK) - 1)], DATABLOCK2))
++        {
++          errnum = ERR_FSYS_CORRUPT;
++          return -1;
++        }
++        return ((__u32 *) DATABLOCK2)
++		[logical_block & (EXT2_ADDR_PER_BLOCK (SUPERBLOCK) - 1)];
++   }
++   /* inode is in extents format */
++   else
++   {
++     int i;
++     struct ext4_extent_header *extent_hdr = ext4_recurse_extent_index((struct ext4_extent_header *) INODE->i_block, logical_block);
++     struct ext4_extent *extent = (struct ext4_extent *) (extent_hdr + 1);
++     if ( extent_hdr == NULL || extent_hdr->eh_magic != EXT4_EXT_MAGIC)
++      {
++        errnum = ERR_FSYS_CORRUPT;
++        return -1;
++      }
++      for (i = 0; i<extent_hdr->eh_entries; i++)
++        {
++          if (extent[i].ee_block <= logical_block && logical_block < extent[i].ee_block + extent[i].ee_len && !(extent[i].ee_len>>15))
++            return (logical_block - extent[i].ee_block + extent[i].ee_start);
++        }
++      /* We should not arrive here */
+       errnum = ERR_FSYS_CORRUPT;
+       return -1;
+     }
+-  return ((__u32 *) DATABLOCK2)
+-    [logical_block & (EXT2_ADDR_PER_BLOCK (SUPERBLOCK) - 1)];
+ }
+ 
+ /* preconditions: all preconds of ext2fs_block_map */
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/sys-boot/grub/files/grub.conf.gentoo	Sat Dec 27 15:41:47 2008 +0100
@@ -0,0 +1,16 @@
+# This is a sample grub.conf for use with Genkernel, per the Gentoo handbook
+# http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=1&chap=10#doc_chap2
+# If you are not using Genkernel and you need help creating this file, you
+# should consult the handbook. Alternatively, consult the grub.conf.sample that
+# is included with the Grub documentation.
+
+default 0
+timeout 30
+#splashimage=(hd0,0)/boot/grub/splash.xpm.gz
+
+#title Gentoo Linux 2.6.24-r5
+#root (hd0,0)
+#kernel /boot/kernel-genkernel-x86-2.6.24-gentoo-r5 root=/dev/ram0 real_root=/dev/sda3
+#initrd /boot/initramfs-genkernel-x86-2.6.24-gentoo-r5
+
+# vim:ft=conf:
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/sys-boot/grub/grub-0.97-r8.ebuild	Sat Dec 27 15:41:47 2008 +0100
@@ -0,0 +1,271 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r8.ebuild,v 1.1 2008/11/06 01:28:56 robbat2 Exp $
+
+# XXX: we need to review menu.lst vs grub.conf handling.  We've been converting
+#      all systems to grub.conf (and symlinking menu.lst to grub.conf), but
+#      we never updated any of the source code (it still all wants menu.lst),
+#      and there is no indication that upstream is making the transition.
+
+inherit mount-boot eutils flag-o-matic toolchain-funcs autotools
+
+PATCHVER="1.8" # Should match the revision ideally
+DESCRIPTION="GNU GRUB Legacy boot loader"
+HOMEPAGE="http://www.gnu.org/software/grub/"
+SRC_URI="mirror://gentoo/${P}.tar.gz
+	ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.gz
+	mirror://gentoo/splash.xpm.gz
+	mirror://gentoo/${P}-patches-${PATCHVER}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="custom-cflags ncurses netboot static"
+
+DEPEND="ncurses? (
+		>=sys-libs/ncurses-5.2-r5
+		amd64? ( app-emulation/emul-linux-x86-baselibs )
+	)"
+PROVIDE="virtual/bootloader"
+
+src_unpack() {
+	unpack ${A}
+	cd "${S}"
+
+	# patch breaks booting for some people #111885
+	rm "${WORKDIR}"/patch/400_*
+
+	# Grub will not handle a kernel larger than EXTENDED_MEMSIZE Mb as
+	# discovered in bug 160801. We can change this, however, using larger values
+	# for this variable means that Grub needs more memory to run and boot. For a
+	# kernel of size N, Grub needs (N+1)*2.  Advanced users should set a custom
+	# value in make.conf, it is possible to make kernels ~16Mb in size, but it
+	# needs the kitchen sink built-in.
+	local t="custom"
+	if [[ -z ${GRUB_MAX_KERNEL_SIZE} ]] ; then
+		case $(tc-arch) in
+			amd64) GRUB_MAX_KERNEL_SIZE=7 ;;
+			x86)   GRUB_MAX_KERNEL_SIZE=3 ;;
+		esac
+		t="default"
+	fi
+	einfo "Grub will support the ${t} maximum kernel size of ${GRUB_MAX_KERNEL_SIZE} Mb (GRUB_MAX_KERNEL_SIZE)"
+
+	sed -i \
+		-e "/^#define.*EXTENDED_MEMSIZE/s,3,${GRUB_MAX_KERNEL_SIZE},g" \
+		"${S}"/grub/asmstub.c \
+		|| die "Failed to hack memory size"
+
+	if [[ -n ${PATCHVER} ]] ; then
+		EPATCH_SUFFIX="patch"
+		epatch "${WORKDIR}"/patch
+		epatch "${FILESDIR}/grub-0.97-ext4extents.patch"
+		eautoreconf
+	fi
+}
+
+src_compile() {
+	filter-flags -fPIE #168834
+
+	use amd64 && multilib_toolchain_setup x86
+
+	unset BLOCK_SIZE #73499
+
+	### i686-specific code in the boot loader is a bad idea; disabling to ensure
+	### at least some compatibility if the hard drive is moved to an older or
+	### incompatible system.
+
+	# grub-0.95 added -fno-stack-protector detection, to disable ssp for stage2,
+	# but the objcopy's (faulty) test fails if -fstack-protector is default.
+	# create a cache telling configure that objcopy is ok, and add -C to econf
+	# to make use of the cache.
+	#
+	# CFLAGS has to be undefined running econf, else -fno-stack-protector detection fails.
+	# STAGE2_CFLAGS is not allowed to be used on emake command-line, it overwrites
+	# -fno-stack-protector detected by configure, removed from netboot's emake.
+	use custom-cflags || unset CFLAGS
+
+	export grub_cv_prog_objcopy_absolute=yes #79734
+	use static && append-ldflags -static
+
+	# Per bug 216625, the emul packages do not provide .a libs for performing
+	# suitable static linking
+	if use amd64 && use static ; then
+		if [ -z "${GRUB_STATIC_PACKAGE_BUILDING}" ]; then
+			die "You must use the grub-static package if you want a static Grub on amd64!"
+		else
+			eerror "You have set GRUB_STATIC_PACKAGE_BUILDING. This"
+			eerror "is specifically intended for building the tarballs for the"
+			eerror "grub-static package via USE='static -ncurses'."
+			eerror "All bets are now off."
+			ebeep 10
+		fi
+	fi
+
+	# build the net-bootable grub first, but only if "netboot" is set
+	if use netboot ; then
+		econf \
+		--libdir=/lib \
+		--datadir=/usr/lib/grub \
+		--exec-prefix=/ \
+		--disable-auto-linux-mem-opt \
+		--enable-diskless \
+		--enable-{3c{5{03,07,09,29,95},90x},cs89x0,davicom,depca,eepro{,100}} \
+		--enable-{epic100,exos205,ni5210,lance,ne2100,ni{50,65}10,natsemi} \
+		--enable-{ne,ns8390,wd,otulip,rtl8139,sis900,sk-g16,smc9000,tiara} \
+		--enable-{tulip,via-rhine,w89c840} || die "netboot econf failed"
+
+		emake w89c840_o_CFLAGS="-O" || die "making netboot stuff"
+
+		mv -f stage2/{nbgrub,pxegrub} "${S}"/
+		mv -f stage2/stage2 stage2/stage2.netboot
+
+		make clean || die "make clean failed"
+	fi
+
+	# Now build the regular grub
+	# Note that FFS and UFS2 support are broken for now - stage1_5 files too big
+	econf \
+		--libdir=/lib \
+		--datadir=/usr/lib/grub \
+		--exec-prefix=/ \
+		--disable-auto-linux-mem-opt \
+		$(use_with ncurses curses) \
+		|| die "econf failed"
+
+	# sanity check due to common failure
+	use ncurses && ! grep -qs "HAVE_LIBCURSES.*1" config.h && die "USE=ncurses but curses not found"
+
+	emake || die "making regular stuff"
+}
+
+src_test() {
+	# non-default block size also give false pass/fails.
+	unset BLOCK_SIZE
+	make check || die "make check failed"
+}
+
+src_install() {
+	emake DESTDIR="${D}" install || die
+	if use netboot ; then
+		exeinto /usr/lib/grub/${CHOST}
+		doexe nbgrub pxegrub stage2/stage2.netboot || die "netboot install"
+	fi
+
+	dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
+	newdoc docs/menu.lst grub.conf.sample
+	dodoc "${FILESDIR}"/grub.conf.gentoo
+	prepalldocs
+
+	[ -n "${GRUB_STATIC_PACKAGE_BUILDING}" ] && \
+		mv \
+		"${D}"/usr/share/doc/${PF} \
+		"${D}"/usr/share/doc/grub-static-${PF/grub-}
+
+	insinto /usr/share/grub
+	doins "${DISTDIR}"/splash.xpm.gz
+}
+
+setup_boot_dir() {
+	local boot_dir=$1
+	local dir=${boot_dir}
+
+	[[ ! -e ${dir} ]] && die "${dir} does not exist!"
+	[[ ! -L ${dir}/boot ]] && ln -s . "${dir}/boot"
+	dir="${dir}/grub"
+	if [[ ! -e ${dir} ]] ; then
+		mkdir "${dir}" || die "${dir} does not exist!"
+	fi
+
+	# change menu.lst to grub.conf
+	if [[ ! -e ${dir}/grub.conf ]] && [[ -e ${dir}/menu.lst ]] ; then
+		mv -f "${dir}"/menu.lst "${dir}"/grub.conf
+		ewarn
+		ewarn "*** IMPORTANT NOTE: menu.lst has been renamed to grub.conf"
+		ewarn
+	fi
+
+	if [[ ! -e ${dir}/menu.lst ]]; then
+		einfo "Linking from new grub.conf name to menu.lst"
+		ln -snf grub.conf "${dir}"/menu.lst
+	fi
+
+	if [[ -e ${dir}/stage2 ]] ; then
+		mv "${dir}"/stage2{,.old}
+		ewarn "*** IMPORTANT NOTE: you must run grub and install"
+		ewarn "the new version's stage1 to your MBR.  Until you do,"
+		ewarn "stage1 and stage2 will still be the old version, but"
+		ewarn "later stages will be the new version, which could"
+		ewarn "cause problems such as an unbootable system."
+		ewarn "This means you must use either grub-install or perform"
+		ewarn "root/setup manually! For more help, see the handbook:"
+		ewarn "http://www.gentoo.org/doc/en/handbook/handbook-${ARCH}.xml?part=1&chap=10#grub-install-auto"
+		ebeep
+	fi
+
+	einfo "Copying files from /lib/grub, /usr/lib/grub and /usr/share/grub to ${dir}"
+	for x in \
+		"${ROOT}"/lib*/grub/*/* \
+		"${ROOT}"/usr/lib*/grub/*/* \
+		"${ROOT}"/usr/share/grub/* ; do
+		[[ -f ${x} ]] && cp -p "${x}" "${dir}"/
+	done
+
+	if [[ ! -e ${dir}/grub.conf ]] ; then
+		s="${ROOT}/usr/share/doc/${PF}/grub.conf.gentoo"
+		[[ -e "${s}" ]] && cat "${s}" >${dir}/grub.conf
+		[[ -e "${s}.gz" ]] && zcat "${s}.gz" >${dir}/grub.conf
+		[[ -e "${s}.bz2" ]] && bzcat "${s}.bz2" >${dir}/grub.conf
+	fi
+
+	# Per bug 218599, we support grub.conf.install for users that want to run a
+	# specific set of Grub setup commands rather than the default ones.
+	grub_config=${dir}/grub.conf.install
+	[[ -e ${grub_config} ]] || grub_config=${dir}/grub.conf
+	if [[ -e ${grub_config} ]] ; then
+		egrep \
+			-v '^[[:space:]]*(#|$|default|fallback|initrd|password|splashimage|timeout|title)' \
+			"${grub_config}" | \
+		/sbin/grub --batch \
+			--device-map="${dir}"/device.map \
+			> /dev/null
+	fi
+
+	# the grub default commands silently piss themselves if
+	# the default file does not exist ahead of time
+	if [[ ! -e ${dir}/default ]] ; then
+		grub-set-default --root-directory="${boot_dir}" default
+	fi
+	einfo "Grub has been installed to ${boot_dir} successfully."
+}
+
+pkg_postinst() {
+	if [[ -n ${DONT_MOUNT_BOOT} ]]; then
+		elog "WARNING: you have DONT_MOUNT_BOOT in effect, so you must apply"
+		elog "the following instructions for your /boot!"
+		elog "Neglecting to do so may cause your system to fail to boot!"
+		elog
+	else
+		setup_boot_dir "${ROOT}"/boot
+		# Trailing output because if this is run from pkg_postinst, it gets mixed into
+		# the other output.
+		einfo ""
+	fi
+	elog "To interactively install grub files to another device such as a USB"
+	elog "stick, just run the following and specify the directory as prompted:"
+	elog "   emerge --config =${PF}"
+	elog "Alternately, you can export GRUB_ALT_INSTALLDIR=/path/to/use to tell"
+	elog "grub where to install in a non-interactive way."
+
+}
+
+pkg_config() {
+	local dir
+	if [ ! -d "${GRUB_ALT_INSTALLDIR}" ]; then
+		einfo "Enter the directory where you want to setup grub:"
+		read dir
+	else
+		dir="${GRUB_ALT_INSTALLDIR}"
+	fi
+	setup_boot_dir "${dir}"
+}
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/sys-boot/grub/metadata.xml	Sat Dec 27 15:41:47 2008 +0100
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+<use>
+  <flag name='custom-cflags'>Enable custom CFLAGS (not supported)</flag>
+</use>
+</pkgmetadata>