changeset 134:73a8ea80bb30

imapproxy 1.2.6 is in portage
author holger
date Mon, 01 Jun 2009 15:06:13 +0200
parents e3983612de33
children d836e68caf96
files net-mail/up-imapproxy/Manifest net-mail/up-imapproxy/files/imapproxy.rc6 net-mail/up-imapproxy/files/up-imapproxy-1.2.6-overflow.patch net-mail/up-imapproxy/up-imapproxy-1.2.6.ebuild
diffstat 4 files changed, 0 insertions(+), 94 deletions(-) [+]
line wrap: on
line diff
--- a/net-mail/up-imapproxy/Manifest	Sat May 30 13:26:15 2009 +0200
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,4 +0,0 @@
-AUX imapproxy.rc6 505 RMD160 f217612eb25c3dab81ce6d206f2a0681169db18d SHA1 deaa2f55e90fe57a97ac1032eba542ec72e5840d SHA256 b0d2369d4f311d37834145887e358c98e65451505985e2457dae9609f72579dd
-AUX up-imapproxy-1.2.6-overflow.patch 857 RMD160 650b5400ff32ba285d5114c3f528832999ec88cb SHA1 1fab96af48850e3270fee87db9de835fff062caa SHA256 7b3b4471974f8fc9ceb3cbb0e421d52092fd25ea691495a88596a7abf1e9e5ac
-DIST up-imapproxy-1.2.6.tar.gz 134745 RMD160 4613acd3fcacdc40905ec8692afd3a4e9563258c SHA1 75f497e3fda44ff1526c46ac93e5c863bf6e0963 SHA256 2f5e841bc6c84799f890d24b984726efb7cce26c2ad95923864ddf0353fa3b01
-EBUILD up-imapproxy-1.2.6.ebuild 1303 RMD160 ca956d561ca28f872add66adaa286f82fe3a1a22 SHA1 e0f6b41d0997f2408ff7057e64afcdac245f9789 SHA256 de376f8049faa604742cff0016fe43453f7c5fcd0913383c2c41a12acd52f796
--- a/net-mail/up-imapproxy/files/imapproxy.rc6	Sat May 30 13:26:15 2009 +0200
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,21 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/up-imapproxy/files/imapproxy.rc6,v 1.2 2004/07/14 23:52:37 agriffis Exp $
-
-depend() {
-	use logger
-	need net
-}
-
-start() {
-	ebegin "Starting imapproxy"
-	start-stop-daemon --start --quiet --exec /usr/sbin/imapproxyd
-	eend $?
-}
-
-stop() {
-	ebegin "Stopping imapproxy"
-	start-stop-daemon --stop --quiet --exec /usr/sbin/imapproxyd
-	eend $?
-}
--- a/net-mail/up-imapproxy/files/up-imapproxy-1.2.6-overflow.patch	Sat May 30 13:26:15 2009 +0200
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,21 +0,0 @@
-diff -urP up-imapproxy-1.2.6-dist/src/request.c up-imapproxy-1.2.6/src/request.c
---- up-imapproxy-1.2.6-dist/src/request.c	2008-01-28 07:15:08.000000000 -0600
-+++ up-imapproxy-1.2.6/src/request.c	2008-10-06 13:51:50.000000000 -0500
-@@ -714,7 +714,7 @@
-      * avoid allocating additional buffers.  Keep this in mind for future
-      * code modification...
-      */
--    snprintf( Username, BufLen, "Username:" );
-+    snprintf( Username, MAXUSERNAMELEN - 1, "Username:" );
-     
-     EVP_EncodeBlock( EncodedUsername, Username, strlen( Username ) );
-     
-@@ -770,7 +770,7 @@
-     /*
-      * Same drill all over again, except this time it's for the password.
-      */
--    snprintf( Password, BufLen, "Password:" );
-+    snprintf( Password, MAXPASSWDLEN - 1, "Password:" );
-     
-     EVP_EncodeBlock( EncodedPassword, Password, strlen( Password ) );
-     
--- a/net-mail/up-imapproxy/up-imapproxy-1.2.6.ebuild	Sat May 30 13:26:15 2009 +0200
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,48 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/up-imapproxy/up-imapproxy-1.2.5_rc2.ebuild,v 1.3 2007/02/06 13:08:54 blubb Exp $
-
-inherit eutils
-
-DESCRIPTION="Proxy IMAP transactions between an IMAP client and an IMAP server."
-HOMEPAGE="http://www.imapproxy.org/"
-SRC_URI="http://www.imapproxy.org/downloads/${P/_/}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE="kerberos ssl tcpd"
-
-DEPEND=">=sys-libs/ncurses-5.1
-	kerberos? ( virtual/krb5 )
-	ssl? ( >=dev-libs/openssl-0.9.6 )
-	tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
-
-S="${WORKDIR}/${P/_/}"
-src_unpack() {
-	unpack ${A} && cd "${S}"
-	sed -i -e 's:in\.imapproxyd:imapproxyd:g'  \
-		README Makefile.in include/imapproxy.h || die "sed failed"
-	epatch "${FILESDIR}/${PN}-${PV}-overflow.patch"
-}
-
-src_compile() {
-	econf \
-		$(use_with kerberos krb5) \
-		$(use_with ssl openssl) \
-		$(use_with tcpd libwrap) \
-		|| die "econf failed"
-
-	emake || die "emake failed"
-}
-
-src_install() {
-	dosbin bin/imapproxyd bin/pimpstat || die "dosbin failed"
-
-	insinto /etc
-	doins scripts/imapproxy.conf || die "doins failed"
-
-	newinitd "${FILESDIR}"/imapproxy.rc6 imapproxy || die "initd failed"
-
-	dodoc ChangeLog README README.known_issues README.ssl
-}