changeset 182:75231bb27b1c

work on the ebuild
author Dirk Olmes <dirk@xanthippe.ping.de>
date Wed, 17 Feb 2010 04:12:16 +0100
parents 75e5b218d321
children 3cdcf4f4578c
files www-apps/redaxo/Manifest www-apps/redaxo/redaxo-4.2.1.ebuild
diffstat 2 files changed, 7 insertions(+), 6 deletions(-) [+]
line wrap: on
line diff
--- a/www-apps/redaxo/Manifest	Wed Feb 17 03:45:07 2010 +0100
+++ b/www-apps/redaxo/Manifest	Wed Feb 17 04:12:16 2010 +0100
@@ -1,2 +1,2 @@
 DIST redaxo4_2_1.zip 2143442 RMD160 18d637be99cf076bf2a9feb59a98357da0db192a SHA1 b8f8a23c2b8b97d2b2eb854fafe3001e22840043 SHA256 4d9daacc0104a47cb05c43ffe6be5445b0ed0d00bee4bea9e58e1ac46fd5d61b
-EBUILD redaxo-4.2.1.ebuild 1539 RMD160 2c7717a4c2f2bf66d99220b2d7a69b0b7842a0e9 SHA1 d8fc527aecf4d79366b6d7a5cfa334cf15c85a8d SHA256 c54b88cf84be7a803e74ac2f69e262ff4ff1b28ffd46fd80dec5b7daaf441d6b
+EBUILD redaxo-4.2.1.ebuild 1519 RMD160 8065b5b7f1133f358e160dbe826025cccc5fbb36 SHA1 ff7ba9929fa792b283f589690f44dab675eb0484 SHA256 99d4d70f0d8dc667f45dd2aef7280bcde2012bd2f7fec944808f01c6adb2e83c
--- a/www-apps/redaxo/redaxo-4.2.1.ebuild	Wed Feb 17 03:45:07 2010 +0100
+++ b/www-apps/redaxo/redaxo-4.2.1.ebuild	Wed Feb 17 04:12:16 2010 +0100
@@ -30,6 +30,7 @@
 src_install() {
     webapp_src_preinst
 
+    find . -name .DS_Store -exec rm {} \;
 #    rm docs/INSTALL*
 #    local docs="docs/*"
 #    dodoc ${docs}
@@ -37,7 +38,7 @@
 
     einfo "Installing application files."
     cp -r . "${D}"${MY_HTDOCSDIR}
-#    touch "${D}"${MY_HTDOCSDIR}/.htaccess
+    touch "${D}"${MY_HTDOCSDIR}/.htaccess
 #    touch "${D}"${MY_HTDOCSDIR}/serendipity_config_local.inc.php
 
 #    keepdir ${MY_HTDOCSDIR}/archives/
@@ -46,10 +47,10 @@
     # archives, templates_c and uploads need to be writable to PHP
     # .htaccess and serendipity_config_local.inc.php need to be too
     # plugins and templates need to be writable for spartacus support.
-#    local SERVEROWNED="serendipity_config_local.inc.php .htaccess archives plugins templates templates_c uploads"
-#    for SFILES in ${SERVEROWNED}; do
-#        webapp_serverowned ${MY_HTDOCSDIR}/${SFILES}
-#    done
+    local SERVEROWNED=".htaccess files index.php redaxo"
+    for SFILES in ${SERVEROWNED}; do
+        webapp_serverowned ${MY_HTDOCSDIR}/${SFILES}
+    done
 
     webapp_src_install
 }