changeset 181:75e5b218d321

add ebulid for redaxo
author Dirk Olmes <dirk@xanthippe.ping.de>
date Wed, 17 Feb 2010 03:45:07 +0100
parents c84e2869d46b
children 75231bb27b1c
files www-apps/redaxo/Manifest www-apps/redaxo/redaxo-4.2.1.ebuild
diffstat 2 files changed, 57 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/www-apps/redaxo/Manifest	Wed Feb 17 03:45:07 2010 +0100
@@ -0,0 +1,2 @@
+DIST redaxo4_2_1.zip 2143442 RMD160 18d637be99cf076bf2a9feb59a98357da0db192a SHA1 b8f8a23c2b8b97d2b2eb854fafe3001e22840043 SHA256 4d9daacc0104a47cb05c43ffe6be5445b0ed0d00bee4bea9e58e1ac46fd5d61b
+EBUILD redaxo-4.2.1.ebuild 1539 RMD160 2c7717a4c2f2bf66d99220b2d7a69b0b7842a0e9 SHA1 d8fc527aecf4d79366b6d7a5cfa334cf15c85a8d SHA256 c54b88cf84be7a803e74ac2f69e262ff4ff1b28ffd46fd80dec5b7daaf441d6b
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/www-apps/redaxo/redaxo-4.2.1.ebuild	Wed Feb 17 03:45:07 2010 +0100
@@ -0,0 +1,55 @@
+
+inherit webapp depend.php
+
+DESCRIPTION="PHP-powered CMS application."
+HOMEPAGE="http://www.redaxo.de/"
+
+DOWNLOAD_NAME=`echo ${P} | tr '.' '_'`
+DOWNLOAD_NAME=`echo ${DOWNLOAD_NAME} | sed -e 's/-//'`
+SRC_URI="http://www.redaxo.de/files/${DOWNLOAD_NAME}.zip"
+
+LICENSE="GPL"
+KEYWORDS="~amd64 ~x86"
+DEPEND=""
+RDEPEND="virtual/httpd-cgi"
+
+need_php_httpd
+
+S="${WORKDIR}/${PN}"
+
+pkg_setup() {
+     webapp_pkg_setup
+
+    if  ! PHPCHECKNODIE="yes" require_php_with_any_use mysql ; then
+            eerror
+            eerror "${PHP_PKG} needs to be reinstalled with the mysql USE flag enabled."
+            die "Reinstall ${PHP_PKG} with the above-stated USE flags."
+    fi
+}
+
+src_install() {
+    webapp_src_preinst
+
+#    rm docs/INSTALL*
+#    local docs="docs/*"
+#    dodoc ${docs}
+#    rm -rf docs/
+
+    einfo "Installing application files."
+    cp -r . "${D}"${MY_HTDOCSDIR}
+#    touch "${D}"${MY_HTDOCSDIR}/.htaccess
+#    touch "${D}"${MY_HTDOCSDIR}/serendipity_config_local.inc.php
+
+#    keepdir ${MY_HTDOCSDIR}/archives/
+#    webapp_configfile ${MY_HTDOCSDIR}/serendipity_config_local.inc.php
+
+    # archives, templates_c and uploads need to be writable to PHP
+    # .htaccess and serendipity_config_local.inc.php need to be too
+    # plugins and templates need to be writable for spartacus support.
+#    local SERVEROWNED="serendipity_config_local.inc.php .htaccess archives plugins templates templates_c uploads"
+#    for SFILES in ${SERVEROWNED}; do
+#        webapp_serverowned ${MY_HTDOCSDIR}/${SFILES}
+#    done
+
+    webapp_src_install
+}