changeset 27:82875ae00907

pgadmin3 1.8.2 is in official portage now
author Dirk Olmes <dirk@xanthippe.ping.de>
date Tue, 27 May 2008 13:04:44 +0200
parents 31f34c64d33d
children 442a7e018127
files dev-db/pgadmin3/pgadmin3-1.8.2.ebuild
diffstat 1 files changed, 0 insertions(+), 66 deletions(-) [+]
line wrap: on
line diff
--- a/dev-db/pgadmin3/pgadmin3-1.8.2.ebuild	Tue May 27 10:39:55 2008 +0200
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,66 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# 
-
-inherit wxwidgets eutils autotools
-
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
-
-DESCRIPTION="wxWidgets GUI for PostgreSQL."
-HOMEPAGE="http://www.pgadmin.org/"
-SRC_URI="mirror://postgresql/pgadmin3/release/v${PV/_/-}/src/${P/_/-}.tar.gz"
-LICENSE="Artistic"
-SLOT="0"
-IUSE="debug"
-S="${WORKDIR}/${P/_/-}"
-
-DEPEND="=x11-libs/wxGTK-2.8*
-		>=dev-db/postgresql-base-8
-		>=dev-libs/libxml2-2.6.18
-		>=dev-libs/libxslt-1.1"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
-	export WX_GTK_VER=2.8
-	export WX_HOME=/usr
-	need-wxwidgets unicode
-}
-
-src_unpack() {
-	unpack ${A}
-	cd "${S}"
-
-	# --debug=yes/no for wx_config is only needed if wxGTK debug and
-	# release versions are installed aside. Which is not possible
-	# on Gentoo at the moment.
-	sed -i \
-		-e 's/--debug=[yesno]* //g' \
-		acinclude.m4 || die "sed failed"
-	eautoreconf
-}
-
-src_compile() {
-	cd "${S}"
-	patch -p0 < ${FILESDIR}/patch.p0
-	# pgadmin3 inserts WX_HOME before the WX_CONFIG path below, so we have to strip "/usr" from it
-	econf \
-		--with-wx-config=/${WX_CONFIG/\ /usr} \
-                --with-wx-version=2.8  \
-		|| die "econf failed"
-	emake || die "emake failed"
-}
-
-src_install() {
-	cd "${S}"
-
-	einstall || die "einstall failed"
-
-	insinto /usr/share/pixmaps
-	newins "${S}/src/include/images/elephant48.xpm" pgadmin3.xpm
-
-	insinto /usr/share/pgadmin3
-	newins "${S}/src/include/images/elephant48.xpm" pgadmin3.xpm
-
-	insinto /usr/share/applications
-	doins "${S}/pkg/pgadmin3.desktop"
-}