changeset 176:850bb6467b62

sync graphicsmagick with portage
author holger
date Tue, 24 Nov 2009 07:52:37 +0100
parents 9839e927aee2
children 11adf80154c3
files media-gfx/graphicsmagick/Manifest media-gfx/graphicsmagick/graphicsmagick-1.3.7.ebuild
diffstat 2 files changed, 60 insertions(+), 45 deletions(-) [+]
line wrap: on
line diff
--- a/media-gfx/graphicsmagick/Manifest	Sat Nov 14 20:06:57 2009 +0100
+++ b/media-gfx/graphicsmagick/Manifest	Tue Nov 24 07:52:37 2009 +0100
@@ -1,2 +1,2 @@
 DIST GraphicsMagick-1.3.7.tar.bz2 6581207 RMD160 56a7408d2f3fc15be2859a0d5b3c42e0549faf0c SHA1 e65c4d799704245216821374f66de5796795c263 SHA256 0d2e8f81574efc7e16c05b72fc9a62a2ba333d6fa196bdb72f8fda8ce7a585fc
-EBUILD graphicsmagick-1.3.7.ebuild 2557 RMD160 134523d4abe69b21c2a0d63030d8dd67a742ee0b SHA1 ef9c110c5b645fe477bf7649f47095b5e37c36e6 SHA256 d05786fc02ff248cb5eff30edd5f3e3c20c6d5b8d50706d9c70694e612db259a
+EBUILD graphicsmagick-1.3.7.ebuild 3000 RMD160 e1e5427162790a7061ca7cdda4a7f76a6a7b60b1 SHA1 4caa266b188ac6e6a393771c6c6eb6097ad074d6 SHA256 95dd7987620ab2b264326e45f810dfdb5144aa6a79ea77f2ab0ccb39a518ede4
--- a/media-gfx/graphicsmagick/graphicsmagick-1.3.7.ebuild	Sat Nov 14 20:06:57 2009 +0100
+++ b/media-gfx/graphicsmagick/graphicsmagick-1.3.7.ebuild	Tue Nov 24 07:52:37 2009 +0100
@@ -1,32 +1,30 @@
 # Copyright 1999-2009 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphicsmagick/graphicsmagick-1.3.7.ebuild,v 1.1 2009/11/24 00:20:48 bicatali Exp $
 
 EAPI="2"
 
-inherit flag-o-matic perl-app
+inherit toolchain-funcs flag-o-matic perl-app
 
 MY_P=${P/graphicsm/GraphicsM}
 
-DESCRIPTION="A collection of tools and libraries for many image formats"
+DESCRIPTION="Collection of tools and libraries for many image formats"
 HOMEPAGE="http://www.graphicsmagick.org/"
 SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
 
-LICENSE="as-is"
+LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="bzip2 cxx debug fpx imagemagick jbig +jpeg +jpeg2k lcms openmp
+IUSE="bzip2 cxx debug fpx -gs imagemagick jbig +jpeg +jpeg2k lcms openmp
 	perl +png q16 q32 +svg +threads tiff +truetype X wmf zlib"
 
-DEPEND="bzip2? ( app-arch/bzip2 )
+RDEPEND="bzip2? ( app-arch/bzip2 )
 	fpx? ( media-libs/libfpx )
-	virtual/ghostscript
+	gs? ( virtual/ghostscript )
 	jbig? ( media-libs/jbigkit )
 	jpeg? ( media-libs/jpeg )
 	jpeg2k? ( >=media-libs/jasper-1.701.0 )
 	lcms? ( media-libs/lcms )
-	media-video/mpeg2vidcodec
-	openmp? ( sys-devel/gcc[openmp] )
 	perl? ( dev-lang/perl )
 	png? ( media-libs/libpng )
 	svg? ( dev-libs/libxml2 )
@@ -38,58 +36,74 @@
 		x11-libs/libX11
 		x11-libs/libICE )
 	imagemagick? ( !media-gfx/imagemagick )"
-RDEPEND=${DEPEND}
-S=${WORKDIR}/${MY_P}
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+	if use openmp &&
+		[[ $(tc-getCC)$ == *gcc* ]] &&
+		( [[ $(gcc-major-version)$(gcc-minor-version) -lt 42 ]] ||
+			! built_with_use sys-devel/gcc openmp )
+	then
+		ewarn "You are using gcc and OpenMP is only available with gcc >= 4.2 "
+		ewarn "If you want to build fftw with OpenMP, abort now,"
+		ewarn "and switch CC to an OpenMP capable compiler"
+		epause 5
+	fi
+}
 
 src_configure() {
-	local quantumDepth="--with-quantum-depth="
+	local quantumDepth
 	if use q16 ; then
-		quantumDepth="${quantumDepth}16"
+		quantumDepth="16"
 	elif use q32 ; then
-		quantumDepth="${quantumDepth}32"
+		quantumDepth="32"
 	else
-		quantumDepth="${quantumDepth}8"
+		quantumDepth="8"
 	fi
 
 	use debug && filter-flags -fomit-frame-pointer
 
 	econf \
-		${quantumDepth} \
-		$( use_enable imagemagick magick-compat ) \
-		$( use_enable openmp ) \
-		$( use_with bzip2 bzlib ) \
-		$( use_with fpx ) \
-		$( use_with jbig ) \
-		$( use_with jpeg ) \
-		$( use_with jpeg2k jp2 ) \
-		$( use_with lcms ) \
-		$( use_with cxx magick-plus-plus ) \
-		$( use_with perl ) \
-		$( use_with png ) \
-		$( use_with tiff ) \
-		$( use_with truetype ttf ) \
-		$( use_with X x ) \
-		$( use_with svg xml ) \
-		$( use_with wmf ) \
-		$( use_with zlib ) \
-		$( use_with threads ) \
-		$( use_enable debug ccmalloc ) \
-		$( use_enable debug prof ) \
-		$( use_enable debug gcov ) \
-		--disable-gprof \
+		--enable-shared \
 		--enable-largefile \
 		--without-included-ltdl \
-		--without-gslib \
-		--without-dps \
-		--without-umem \
-		--without-trio \
+		--without-frozenpaths \
 		--with-modules \
-		--enable-shared
+		--with-quantum-depth=${quantumDepth} \
+		$(use_enable debug ccmalloc) \
+		$(use_enable debug prof) \
+		$(use_enable debug gcov) \
+		$(use_enable imagemagick magick-compat) \
+		$(use_enable openmp) \
+		$(use_with bzip2 bzlib) \
+		$(use_with cxx magick-plus-plus) \
+		$(use_with fpx) \
+		$(use_with gs gslib) \
+		$(use_with jbig) \
+		$(use_with jpeg) \
+		$(use_with jpeg2k jp2) \
+		$(use_with lcms) \
+		$(use_with perl) \
+		$(use_with png) \
+		$(use_with svg xml) \
+		$(use_with threads) \
+		$(use_with tiff) \
+		$(use_with truetype ttf) \
+		$(use_with wmf) \
+		$(use_with X x) \
+		$(use_with zlib)
+}
+
+src_test() {
+	emake check || die "tests failed"
 }
 
 src_install() {
 	emake DESTDIR="${D}" install || die "Installation failed"
-	dodoc README.txt ChangeLog* || die "dodoc failed."
+	dodoc README.txt ChangeLog* NEWS.txt TODO.txt
 
 	# Fix perllocal.pod file collision
 	use perl && fixlocalpod
@@ -97,5 +111,6 @@
 
 pkg_postinst() {
 	elog "For RAW image suport please install media-gfx/dcraw."
+	elog "For mpeg suport please install media-video/mpeg2vidcodec."
 	elog "To read gnuplot files please install sci-visualization/gnuplot."
 }