changeset 338:90ae974540be

mantis has a new version upstream
author Dirk Olmes <dirk@xanthippe.ping.de>
date Thu, 28 Jun 2012 12:14:48 +0000
parents e9bee0cb5018
children 60459a8f4bd6
files www-apps/mantisbt/Manifest www-apps/mantisbt/files/postinstall-en-1.0.0.txt www-apps/mantisbt/mantisbt-1.2.11.ebuild
diffstat 3 files changed, 65 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/www-apps/mantisbt/Manifest	Thu Jun 28 12:14:48 2012 +0000
@@ -0,0 +1,3 @@
+AUX postinstall-en-1.0.0.txt 640 RMD160 1e0a077db936ab8c2a6bf06c9091d4b5194b0b9c SHA1 1fb4a3c4e32b7ddca4b37017e8c8101d8d0c83c7 SHA256 af60f6f6be915164f420f5e9ae04fa18d8bf85e73a9a59668ba4a6b7ba41900d
+DIST mantisbt-1.2.11.tar.gz 3524181 RMD160 cf2a5c5b1da604155ce0e657459ce34bb5525d2d SHA1 ccf6fd2ac427c579ab41b6b43c492bb38521f935 SHA256 1b18e604b00a646aeddfb47fece7ab5c879cdf34d2f2de01353ed12b12f105f3
+EBUILD mantisbt-1.2.11.ebuild 1379 RMD160 602ed8ee41daede598c0fa4d9f4d304d6a527e57 SHA1 389f609ad74826c75cd7f3d634c38230ddd7b403 SHA256 8e96dc2fa4da4960a2bb78a0698514d76929ba583bd8f6db29bdefba127ebabd
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/www-apps/mantisbt/files/postinstall-en-1.0.0.txt	Thu Jun 28 12:14:48 2012 +0000
@@ -0,0 +1,13 @@
+If you are UPGRADING from an earlier version, you can use the upgrade scripts
+at admin/ to execute the pending database updates. For more information,
+please, see http://manual.mantisbt.org/manual.installation.upgrading.php .
+
+To INSTALL, visit: http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/admin/install.php
+Then log in: Username - administrator, Password - root. You can load up
+admin/check.php to CHECK if everything is working correctly.
+
+Then edit ${MY_INSTALLDIR}/config_inc.php as necessary.
+
+After you've finished these steps, please delete the admin/ directory.
+
+Don't forget to read the online manual (http://manual.mantisbt.org/)!!!
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/www-apps/mantisbt/mantisbt-1.2.11.ebuild	Thu Jun 28 12:14:48 2012 +0000
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/mantisbt-1.2.8.ebuild,v 1.3 2011/12/14 22:53:05 mabi Exp $
+
+EAPI="2"
+
+inherit eutils webapp depend.php
+
+DESCRIPTION="PHP/MySQL/Web based bugtracking system"
+HOMEPAGE="http://www.mantisbt.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+	virtual/httpd-php
+	virtual/httpd-cgi
+	|| ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )
+	>=dev-php/ezc-Base-1.8
+	>=dev-php/ezc-Graph-1.5
+	>=dev-php/adodb-5.10"
+
+src_prepare() {
+	# Drop external libraries
+	rm -r "${S}/library/adodb/"
+	rm -r "${S}/library/ezc/"{Base,Graph}
+	sed -e 's:ezc/Base/src/base.php:ezc/Base/base.php:' \
+		-i "${S}"/plugins/MantisGraph/{core/graph_api.php,pages/summary_graph_cumulative_bydate2.php} \
+			|| die
+	# Fix incorrect filename
+	sed -e 's:config_default_inc.php:config_defaults_inc.php:' \
+		-i "${S}/lang/strings_russian.txt" || die
+}
+
+src_install() {
+	webapp_src_preinst
+	rm doc/{LICENSE,INSTALL}
+	dodoc doc/{CREDITS,CUSTOMIZATION,RELEASE} doc/en/*
+
+	rm -rf doc packages
+	mv config_inc.php.sample config_inc.php
+	cp -R . "${D}/${MY_HTDOCSDIR}"
+
+	webapp_configfile "${MY_HTDOCSDIR}/config_inc.php"
+	webapp_postinst_txt en "${FILESDIR}/postinstall-en-1.0.0.txt"
+	webapp_src_install
+}