changeset 58:92f35dfbf2b8

cleanup template comments
author holger@hoho.dyndns.org
date Wed, 13 Aug 2008 20:56:04 +0200
parents baac049cd305
children 6a65c52cb465
files net-misc/rabbitmq-server/Manifest net-misc/rabbitmq-server/rabbitmq-server-1.4.0.ebuild
diffstat 2 files changed, 10 insertions(+), 95 deletions(-) [+]
line wrap: on
line diff
--- a/net-misc/rabbitmq-server/Manifest	Sat Aug 09 14:16:03 2008 +0200
+++ b/net-misc/rabbitmq-server/Manifest	Wed Aug 13 20:56:04 2008 +0200
@@ -1,2 +1,3 @@
 DIST rabbitmq-server-generic-unix-1.4.0.tar.gz 394991 RMD160 f3ced06ec6f8ced09a9e0f5c60f0b73954ea8634 SHA1 bea27fa2255324f13e343ed82c50e69c6983628a SHA256 642ffe9cdca8ac5bd030647d24d60cca388df20f1d6a5913c3a2ae036f75018e
-EBUILD rabbitmq-server-1.4.0.ebuild 7680 RMD160 d66d21153bdef80641510d118ae3948c088e67e0 SHA1 4888a5cad90ee282817dd0e134b4dc4d4e858ef7 SHA256 db327700e6d7d348cfa19c1f595822bc19b694f1416bb9144661cd23d87c79ba
+EBUILD rabbitmq-server-1.4.0.ebuild 3289 RMD160 ac06f3146a1912fe81a26de5659b85be64695a4c SHA1 f0077722a4f1756e72a0e52daf90a11338bea8e1 SHA256 6f19a6c168c7acfde824506e303ca5423352b08117be3d0acd61ccf106ac5bc4
+MISC rabbitmq-server-1.4.0.ebuild~ 7680 RMD160 d66d21153bdef80641510d118ae3948c088e67e0 SHA1 4888a5cad90ee282817dd0e134b4dc4d4e858ef7 SHA256 db327700e6d7d348cfa19c1f595822bc19b694f1416bb9144661cd23d87c79ba
--- a/net-misc/rabbitmq-server/rabbitmq-server-1.4.0.ebuild	Sat Aug 09 14:16:03 2008 +0200
+++ b/net-misc/rabbitmq-server/rabbitmq-server-1.4.0.ebuild	Wed Aug 13 20:56:04 2008 +0200
@@ -2,104 +2,18 @@
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
-# NOTE: The comments in this file are for instruction and documentation.
-# They're not meant to appear with your final, production ebuild.  Please
-# remember to remove them before submitting or committing your ebuild.  That
-# doesn't mean you can't add your own comments though.
-
-# The 'Header' on the third line should just be left alone.  When your ebuild
-# will be committed to cvs, the details on that line will be automatically
-# generated to contain the correct data.
-
-# The EAPI variable tells the ebuild format in use.
-# Defaults to 0 if not specified. The current PMS draft contains details on
-# a proposed EAPI=0 definition but is not finalized yet.
-# Eclasses will test for this variable if they need to use EAPI > 0 features.
-# Ebuilds should not define EAPI > 0 unless they absolutely need to use
-# features added in that version.
-#EAPI=0
-
-# inherit lists eclasses to inherit functions from. Almost all ebuilds should
-# inherit eutils, as a large amount of important functionality has been
-# moved there. For example, the $(get_libdir) mentioned below wont work
-# without the following line:
 inherit eutils
-# A well-used example of an eclass function that needs eutils is epatch. If
-# your source needs patches applied, it's suggested to put your patch in the
-# 'files' directory and use:
-#
-#   epatch ${FILESDIR}/patch-name-here
-#
-# eclasses tend to list descriptions of how to use their functions properly.
-# take a look at /usr/portage/eclasses/ for more examples.
-
-# Short one-line description of this package.
-DESCRIPTION="RabbitMQ is a high-performance AMQP-compliant message broker written in Erlang."
-
-# Homepage, not used by Portage directly but handy for developer reference
-HOMEPAGE="http://www.rabbitmq.com/"
-
-# Point to any required sources; these will be automatically downloaded by
-# Portage.
-SRC_URI="http://www.rabbitmq.com/releases/rabbitmq-server/v${PV}/rabbitmq-server-generic-unix-${PV}.tar.gz"
-
-# License of the package.  This must match the name of file(s) in
-# /usr/portage/licenses/.  For complex license combination see the developer
-# docs on gentoo.org for details.
-LICENSE="MPL"
 
-# The SLOT variable is used to tell Portage if it's OK to keep multiple
-# versions of the same package installed at the same time.  For example,
-# if we have a libfoo-1.2.2 and libfoo-1.3.2 (which is not compatible
-# with 1.2.2), it would be optimal to instruct Portage to not remove
-# libfoo-1.2.2 if we decide to upgrade to libfoo-1.3.2.  To do this,
-# we specify SLOT="1.2" in libfoo-1.2.2 and SLOT="1.3" in libfoo-1.3.2.
-# emerge clean understands SLOTs, and will keep the most recent version
-# of each SLOT and remove everything else.
-# Note that normal applications should use SLOT="0" if possible, since
-# there should only be exactly one version installed at a time.
-# DO NOT USE SLOT=""! This tells Portage to disable SLOTs for this package.
-SLOT="0"
-
-# Using KEYWORDS, we can record masking information *inside* an ebuild
-# instead of relying on an external package.mask file.  Right now, you should
-# set the KEYWORDS variable for every ebuild so that it contains the names of
-# all the architectures with which the ebuild works.  All of the official
-# architectures can be found in the keywords.desc file which is in
-# /usr/portage/profiles/.  Usually you should just set this to "~x86".  The ~
-# in front of the architecture indicates that the package is new and should be
-# considered unstable until testing proves its stability.  So, if you've
-# confirmed that your ebuild works on x86 and ppc, you'd specify:
-# KEYWORDS="~x86 ~ppc"
-# Once packages go stable, the ~ prefix is removed.
-# For binary packages, use -* and then list the archs the bin package
-# exists for.  If the package was for an x86 binary package, then
-# KEYWORDS would be set like this: KEYWORDS="-* x86"
-# DO NOT USE KEYWORDS="*".  This is deprecated and only for backward
-# compatibility reasons.
-KEYWORDS="~x86"
-
-# Comprehensive list of any and all USE flags leveraged in the ebuild,
-# with the exception of any ARCH specific flags, i.e. "ppc", "sparc",
-# "x86" and "alpha".  This is a required variable.  If the ebuild doesn't
-# use any USE flags, set to "".
+DESCRIPTION="RabbitMQ is a high-performance AMQP-compliant message broker written in Erlang."
+HOMEPAGE="http://www.rabbitmq.com/" 
+SRC_URI="http://www.rabbitmq.com/releases/rabbitmq-server/v${PV}/rabbitmq-server-generic-unix-${PV}.tar.gz"
+LICENSE="MPL"
+SLOT="0" 
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
 IUSE=""
-
-# A space delimited list of portage features to restrict. man 5 ebuild
-# for details.  Usually not needed.
-#RESTRICT="strip"
-
-# Build-time dependencies, such as
-#    ssl? ( >=dev-libs/openssl-0.9.6b )
-#    >=dev-lang/perl-5.6.1-r1
-# It is advisable to use the >= syntax show above, to reflect what you
-# had installed on your system when you tested the package.  Then
-# other users hopefully won't be caught without the right version of
-# a dependency.
+ 
+# HH: is RDEPEND-only sufficient for a binary package?
 DEPEND="dev-lang/erlang"
-
-# Run-time dependencies. Must be defined to whatever this depends on to run.
-# The below is valid if the same run-time depends are required to compile.
 RDEPEND="${DEPEND}"
 
 # Source directory; the dir where the sources can be found (automatically