changeset 12:a9058d20d58e

update to 12.2.2
author holger@hoho.dyndns.org
date Wed, 09 Apr 2008 18:03:44 +0200
parents b1d2c5ed0d7b
children 85e343e4f152
files dev-lang/erlang/Manifest dev-lang/erlang/erlang-12.2.2.ebuild dev-lang/erlang/files/50erlang-gentoo.el
diffstat 3 files changed, 173 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-lang/erlang/Manifest	Wed Apr 09 18:03:44 2008 +0200
@@ -0,0 +1,5 @@
+AUX 50erlang-gentoo.el 134 RMD160 a453ad18f47d20e5ea5ecd1f4e4054d00eab5c35 SHA1 7c17979f533654ef05bbfcc8ae30554e7843923b SHA256 97e1da82cae31a554134d7370739520e4c67b2544e5a13f887651a62e710b4d4
+DIST otp_doc_html_R12B-2.tar.gz 5616891 RMD160 ddceb9b20aa485d8aab9c4f43e0f33fc8ba7eb8d SHA1 9fbb1f8e514ab340fff437e794243b4d530ed682 SHA256 f169acca450eb84d58377b1fabee18268ea9cf1a59393c0b970fefdb894b771e
+DIST otp_doc_man_R12B-2.tar.gz 777982 RMD160 963eb8247ae2df39ce4f998d72893e9ff2d646a0 SHA1 c32be18cc121412af97d948e1262a185206cadcb SHA256 712140af4b49cf696f6968244e13a753cb6f53c09e46fedb8d93407bf21c95c4
+DIST otp_src_R12B-2.tar.gz 41190987 RMD160 14702b907c1a2cce2403e2c24db8187904039697 SHA1 a38adf0498a6d0f5038899d9f4a8accc935e7ffd SHA256 ba84af52b5ff10029a9f68c03d53c350d359ca1ed9247ac609765746692a89c1
+EBUILD erlang-12.2.2.ebuild 4874 RMD160 8f26e56652375d60e469ebee8a890c15e0c635f1 SHA1 3e8b1d9bb0b8e15d8930102af44cb13a3685a7a7 SHA256 d76beb048e1e76cf34c4dd8d01b2c5f96f86683922143387f6ee0fbd1775e67e
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-lang/erlang/erlang-12.2.2.ebuild	Wed Apr 09 18:03:44 2008 +0200
@@ -0,0 +1,163 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-12.2.1.ebuild,v 1.9 2008/04/01 18:16:44 opfer Exp $
+
+inherit elisp-common eutils flag-o-matic multilib versionator
+
+# NOTE: You need to adjust the version number in the last comment.  If you need symlinks for
+# binaries please tell maintainers or open up a bug to let it be created.
+
+# erlang uses a really weird versioning scheme which caused quite a few problems
+# already. Thus we do a slight modification converting all letters to digits to
+# make it more sane (see e.g. #26420)
+
+# the next line selects the right source.
+MY_PV="R$(get_major_version)B-$(get_version_component_range 3)"
+
+# ATTN!! Take care when processing the C, etc version!
+MY_P=otp_src_${MY_PV}
+
+DESCRIPTION="Erlang programming language, runtime environment, and large collection of libraries"
+HOMEPAGE="http://www.erlang.org/"
+SRC_URI="http://www.erlang.org/download/${MY_P}.tar.gz
+	doc? ( http://erlang.org/download/otp_doc_man_${MY_PV}.tar.gz
+		http://erlang.org/download/otp_doc_html_${MY_PV}.tar.gz )"
+
+LICENSE="EPL"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="doc emacs hipe java kpoll odbc smp ssl tk"
+
+RDEPEND=">=dev-lang/perl-5.6.1
+	ssl? ( >=dev-libs/openssl-0.9.7d )
+	emacs? ( virtual/emacs )
+	java? ( >=virtual/jdk-1.2 )
+	odbc? ( dev-db/unixODBC )"
+DEPEND="${RDEPEND}
+	tk? ( dev-lang/tk )"
+
+S="${WORKDIR}/${MY_P}"
+
+SITEFILE=50erlang-gentoo.el
+
+pkg_setup() {
+	if use ssl; then
+		if is-ldflag --as-needed || is-flag --as-needed; then
+			eerror "Don't use --as-needed in your LDFLAGS or CFLAGS for SSL support, this will fail."
+			die
+		fi
+	fi
+}
+
+src_unpack() {
+
+	unpack ${A}
+	cd "${S}"
+
+	use odbc || sed -i 's: odbc : :' lib/Makefile
+
+	# make sure we only link ssl dynamically
+	# will not be integrated by upstream for various reasons
+	sed -i '/SSL_DYNAMIC_ONLY=/s:no:yes:' erts/configure #184419
+
+	if use hipe; then
+		ewarn
+		ewarn "You enabled High performance Erlang. Be aware that this extension"
+		ewarn "can break the compilation in many ways, especially on hardened systems."
+		ewarn "Don't cry, don't file bugs, just disable it! If you have fix, tell us."
+		ewarn
+	fi
+}
+
+src_compile() {
+	use java || export JAVAC=false
+
+	econf \
+		--enable-threads \
+		$(use_enable hipe) \
+		$(use_with ssl) \
+		$(use_enable kpoll kernel-poll) \
+		$(use_enable smp smp-support) \
+		|| die "econf failed"
+	emake -j1 || die "emake failed"
+
+	if use emacs ; then
+		pushd lib/tools/emacs
+		elisp-compile *.el
+		popd
+	fi
+}
+
+extract_version() {
+	sed -n -e "/^$2 = \(.*\)$/s::\1:p" "${S}/$1/vsn.mk"
+}
+
+src_install() {
+	local ERL_LIBDIR=/usr/$(get_libdir)/erlang
+	local ERL_INTERFACE_VER=$(extract_version lib/erl_interface EI_VSN)
+	local ERL_ERTS_VER=$(extract_version erts VSN)
+
+	emake -j1 INSTALL_PREFIX="${D}" install || die "install failed"
+	dodoc AUTHORS README
+
+	dosym "${ERL_LIBDIR}/bin/erl" /usr/bin/erl
+	dosym "${ERL_LIBDIR}/bin/erlc" /usr/bin/erlc
+	dosym "${ERL_LIBDIR}/bin/ear" /usr/bin/ear
+	dosym "${ERL_LIBDIR}/bin/escript" /usr/bin/escript
+	dosym \
+		"${ERL_LIBDIR}/lib/erl_interface-${ERL_INTERFACE_VER}/bin/erl_call" \
+		/usr/bin/erl_call
+	dosym "${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam" /usr/bin/beam
+
+	## Remove ${D} from the following files
+	dosed "${ERL_LIBDIR}/bin/erl"
+	dosed "${ERL_LIBDIR}/bin/start"
+	grep -rle "${D}" "${D}/${ERL_LIBDIR}/erts-${ERL_ERTS_VER}" | xargs sed -i -e "s:${D}::g"
+
+	## Clean up the no longer needed files
+	rm "${D}/${ERL_LIBDIR}/Install"
+
+	if use doc ; then
+		for i in "${WORKDIR}"/man/man* ; do
+			dodir "${ERL_LIBDIR}/${i##${WORKDIR}}"
+		done
+		for file in "${WORKDIR}"/man/man*/*.[1-9]; do
+			# Man page processing tools expect a capitalized "SEE ALSO" section
+			# header, has been reported upstream, should be fixed in R12
+			sed -i -e 's,\.SH See Also,\.SH SEE ALSO,g' ${file}
+			# doman sucks so we can't use it
+			cp ${file} "${D}/${ERL_LIBDIR}"/man/man${file##*.}/
+		done
+		# extend MANPATH, so the normal man command can find it
+		# see bug 189639
+		dodir /etc/env.d/
+		echo "MANPATH=\"${ERL_LIBDIR}/man\"" > "${D}/etc/env.d/90erlang"
+		dohtml -A README,erl,hrl,c,h,kwc,info -r \
+			"${WORKDIR}"/doc "${WORKDIR}"/lib "${WORKDIR}"/erts-*
+	fi
+
+	if use emacs ; then
+		pushd "${S}"
+		elisp-install erlang lib/tools/emacs/*.{el,elc}
+		elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+		popd
+	fi
+
+	# prepare erl for SMP, fixes bug #188112
+	use smp && sed -i -e 's:\(exec.*erlexec\):\1 -smp:' \
+		"${D}/${ERL_LIBDIR}/bin/erl"
+}
+
+pkg_postinst() {
+	use emacs && elisp-site-regen
+	elog
+	elog "If you need a symlink to one of Erlang's binaries,"
+	elog "please open a bug on http://bugs.gentoo.org/"
+	elog
+	elog "Gentoo's versioning scheme differs from the author's, so please refer to this version as R12B-1"
+	elog
+}
+
+pkg_postrm() {
+	use emacs && elisp-site-regen
+}
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-lang/erlang/files/50erlang-gentoo.el	Wed Apr 09 18:03:44 2008 +0200
@@ -0,0 +1,5 @@
+;;; erlang site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(require 'erlang-start)
+(setq erlang-root-dir "/usr/share")