changeset 284:a96ea427e9a0

ebuild for the latest egroupware including dependencies
author Dirk Olmes <dirk@xanthippe.ping.de>
date Sat, 05 Nov 2011 03:27:42 +0100
parents 18e9c4ed5f1f
children 90e704dfb755
files dev-php/PEAR-XML_Feed_Parser/Manifest dev-php/PEAR-XML_Feed_Parser/PEAR-XML_Feed_Parser-1.0.3.ebuild www-apps/egroupware/Manifest www-apps/egroupware/egroupware-1.8.002.20111011.ebuild www-apps/egroupware/files/postinstall-en-1.2.txt
diffstat 5 files changed, 116 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-php/PEAR-XML_Feed_Parser/Manifest	Sat Nov 05 03:27:42 2011 +0100
@@ -0,0 +1,2 @@
+DIST XML_Feed_Parser-1.0.3.tgz 77650 RMD160 0e69dca8b4ef5ef7a9776cd63718356f29a4837a SHA1 9d460879e3ca4ec1bba12de093729a44db6ffb4b SHA256 e077bf6e25cc3af102159f3d00848294c8ff7ee27deadca1cf239e1ac1a87463
+EBUILD PEAR-XML_Feed_Parser-1.0.3.ebuild 313 RMD160 910fc685b32de07a9b05879518ea2d881c48bd9e SHA1 f5edecfef8e3f5cbca5e0e4ee6ebc90299cde4f5 SHA256 04d3a1e1ed870cd71149b2db422b8bd34b93d069ca7525a29c946a5f4048181f
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-php/PEAR-XML_Feed_Parser/PEAR-XML_Feed_Parser-1.0.3.ebuild	Sat Nov 05 03:27:42 2011 +0100
@@ -0,0 +1,12 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit php-pear-r1
+
+DESCRIPTION="Provides an unified API for handling Atom/RSS"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/www-apps/egroupware/Manifest	Sat Nov 05 03:27:42 2011 +0100
@@ -0,0 +1,6 @@
+AUX postinstall-en-1.2.txt 402 RMD160 aefff6af227f9d007afd1b753d97786d66fa7a80 SHA1 72ebcf1a6af140c5b47a9b567f791224d3fbdab8 SHA256 6063f422525dcb597b07a29a54f354452b8962f5487a222c82c75301697a42ba
+DIST eGroupware-1.8.002.20111011.tar.bz2 10382653 RMD160 4d7e27540debebcce5ad30d59ab4e3bc5eb2ed17 SHA1 ab9dd75a066599caa895c0665a65918dfe3da832 SHA256 ea2213257661bda34b36f97942fec54456da7bdad1587d97972d5045e15e548b
+DIST eGroupware-egw-pear-1.8.002.20111011.tar.bz2 73174 RMD160 2c9694c897f31f6f952d5fbb4c1a166d4f0fbf6a SHA1 7eb480e833e030ac7661c95ca5e9686ceaa632e2 SHA256 dc6d0d6dacedc8cd155ca1628d3efd1b55f2bc24c119bc066b725bcb3363ce85
+DIST eGroupware-gallery-1.8.002.20111011.tar.bz2 10509942 RMD160 129341407ff2c8edca987d0d8b29c2bea56379b6 SHA1 a2859c6d6cbfe71980127fbbdff9a23c80629709 SHA256 49fc81c2b5f89cba592c4ceef50e0ec4fb53052f523d1f2517f6e5222f98b784
+DIST eGroupware-phpfreechat-1.8.002.20111011.tar.bz2 953584 RMD160 436cbe5444fca9c0db96d0d2320b7f0228d1d4ad SHA1 97a990e91fadd2ca582c6bbf15d3c1df3b1b0bb4 SHA256 82c7b73f26137bee438a0734d05d9a57612ef669a8ee7009345914cdd6b4498e
+EBUILD egroupware-1.8.002.20111011.ebuild 2694 RMD160 c2ffc3b38c9c2ff1ba4a1470affa3a9beba32c8f SHA1 81194a87931f4ab11dc5beaa7b7381f2b8292145 SHA256 ee461e8818ab7e26923cdf9617da3c7096e2604f4f4d3c7f9ae4b4c93d37e564
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/www-apps/egroupware/egroupware-1.8.002.20111011.ebuild	Sat Nov 05 03:27:42 2011 +0100
@@ -0,0 +1,84 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+##
+# based on ebuild from bug #284536, depending on dev-php/PEAR-XML_Feed_Parser from #258604
+##
+
+EAPI="2"
+
+inherit eutils versionator webapp depend.php
+
+MY_PN=eGroupware
+MY_PV=$(get_version_component_range 1-3)
+MY_P=$(get_version_component_range 4-)
+#MY_P="${MY_P/p/}"
+
+DESCRIPTION="Web-based GroupWare suite"
+HOMEPAGE="http://www.egroupware.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${MY_PV}.${MY_P}.tar.bz2
+	mirror://sourceforge/${PN}/${MY_PN}-egw-pear-${MY_PV}.${MY_P}.tar.bz2
+	phpfreechat? ( mirror://sourceforge/${PN}/${MY_PN}-phpfreechat-${MY_PV}.${MY_P}.tar.bz2 )
+	gallery? ( mirror://sourceforge/${PN}/${MY_PN}-gallery-${MY_PV}.${MY_P}.tar.bz2 )"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="ldap mssql mysql postgres gallery phpfreechat jpgraph"
+
+#hint: sqlite needed for calendar
+RDEPEND="
+	dev-lang/php[ctype,imap,ldap?,mssql?,mysql?,pdo,postgres?,session,sqlite3,unicode]
+	|| (
+		dev-lang/php[gd]
+		dev-lang/php[gd-external]
+	)
+	dev-php/PEAR-Auth_SASL
+	dev-php/PEAR-PEAR
+	dev-php/PEAR-XML_Feed_Parser
+	virtual/cron
+   jpgraph? ( dev-php/jpgraph )
+"
+#	>dev-php5/jpgraph-1.13
+
+
+need_httpd_cgi
+need_php_httpd
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+	esvn_clean
+
+   if use jpgraph; then
+   	einfo "Fixing jpgraph location"
+   	MY_JPGRAPH_VERSION="$(best_version dev-php5/jpgraph)"
+   	MY_JPGRAPH_VERSION="${MY_JPGRAPH_VERSION/'dev-php5/jpgraph-'/}"
+   	sed -i "s|EGW_SERVER_ROOT . '/../jpgraph/src/jpgraph.php'|'/usr/share/php5/jpgraph/jpgraph.php'|" \
+   		projectmanager/inc/class.projectmanager_ganttchart.inc.php || die
+   	sed -i "s|EGW_SERVER_ROOT . '/../jpgraph/src/jpgraph_gantt.php'|'/usr/share/php5/jpgraph/jpgraph_gantt.php'|" \
+   		projectmanager/inc/class.projectmanager_ganttchart.inc.php || die
+   	sed -i "s|$jpgraph_path .= SEP.'jpgraph';|$jpgraph_path = dirname('/usr/share/php5/jpgraph/jpgraph.php');|" \
+   		setup/check_install.php || die
+   	sed -i "s|'unknown';|'${MY_JPGRAPH_VERSION}';\n         \$available = version_compare(\$version,\$min_version,'>=');|" \
+   		setup/check_install.php || die
+   fi
+}
+
+src_install() {
+	webapp_src_preinst
+	insinto "${MY_HTDOCSDIR}"
+	doins -r .
+	webapp_serverowned "${MY_HTDOCSDIR}/phpgwapi/images"
+	webapp_postinst_txt en "${FILESDIR}/postinstall-en-1.2.txt"
+	webapp_src_install
+}
+
+pkg_postinst() {
+	if use ldap; then
+		elog "If you are using LDAP contacts/addressbook, please read the upgrade instructions at"
+		elog "http://www.egroupware.org/index.php?page_name=wiki&wikipage=ManualSetupUpdate"
+		elog "before running the egroupware setup"
+	fi
+	webapp_pkg_postinst
+}
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/www-apps/egroupware/files/postinstall-en-1.2.txt	Sat Nov 05 03:27:42 2011 +0100
@@ -0,0 +1,12 @@
+You are almost done!
+
+0. Restart your webserver and your database daemon.
+
+1. Point your browser to the URL http://${VHOST_HOSTNAME}/egroupware/setup
+and follow the install/upgrade script.
+
+Don't forget to read the installation manual, available from
+http://egroupware.org/specialpages/index.php?page_name=wiki&wikipage=ManualSetup
+It describes the rest of the installation process.
+
+Enjoy eGroupWare!