changeset 67:b31e97231708

adding truecrypt ebuild
author Dirk Olmes <dirk.olmes@googlemail.com>
date Thu, 08 Jan 2009 10:07:25 +0100
parents fff28f00bd2c
children f7bbde77ac6e
files app-crypt/truecrypt/Manifest app-crypt/truecrypt/files/truecrypt-6.1-64bit.patch app-crypt/truecrypt/files/truecrypt-6.1-bool.patch app-crypt/truecrypt/files/truecrypt-6.1-external-wx.patch app-crypt/truecrypt/truecrypt-6.1a.ebuild
diffstat 5 files changed, 164 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/app-crypt/truecrypt/Manifest	Thu Jan 08 10:07:25 2009 +0100
@@ -0,0 +1,8 @@
+AUX truecrypt-6.1-64bit.patch 664 RMD160 0f6b1ef68746290670a805b9483de5625041e3b6 SHA1 a9290da440cdc9c42caec10c4fc9eeedb8b2a3a1 SHA256 f41bc0c1cbd9a7c64b4142f839e362e787de31abd5623fce75c2d734189e82f5
+AUX truecrypt-6.1-bool.patch 883 RMD160 1b9b91f239bd504371f73a96d04fea5a33ca2f62 SHA1 87c470f2f338ef6234846b3ed3606d37416a9ace SHA256 58f364a135d124210bb4f65a5d38a7b59efa3db4afaaf6159d4344ca798c881a
+AUX truecrypt-6.1-external-wx.patch 391 RMD160 742f8d7a239211738d30b0da6efdd790e88e34f2 SHA1 8d3cf5bcbc7d55ef74c3b52d34dbd370584b69fe SHA256 668e4460f0daeb1e896b7b6d6673b741db12d82e04eb503a1e2c7924ed819331
+DIST pkcs11.h 9578 RMD160 038002de5e6ed90174051bc5f96a12c51e5f87f0 SHA1 4a87fd021aed6304bccf3987107812b9d701dfe9 SHA256 1563d877b6f8868b8eb8687358162bfb7f868104ed694beb35ae1c5cf1a58b9b
+DIST pkcs11f.h 29258 RMD160 c47b5818f84e42aa9d11dfe250a6da2cca14cb77 SHA1 853ad63da8961ac309bac902d270d3497a8e3356 SHA256 5ae6a4f32ca737e02def3bf314c9842fb89be82bf00b6f4022a97d8d565522b8
+DIST pkcs11t.h 70934 RMD160 da30e5792b7b56b4f3651f65f548c23e1ac96eac SHA1 1909623adf647589c7d7e8f49672936c8e03d500 SHA256 8ce68616304684f92a7e267bcc8f486441e92a5cbdfcfd97e69ac9a0b436fb7b
+DIST truecrypt-6.1a.tar.gz 1773482 RMD160 d3753af8fee062e4d4c554145cddc9590b1d9ccf SHA1 f2fb1c8cd18b4452529edb53479418a5c1460a58 SHA256 a2bb8273edcb3c3d10d9819daac853f940033deb1f9726986311356bd5b88c4a
+EBUILD truecrypt-6.1a.ebuild 2724 RMD160 478e4476ea376050310d8a0d8b32502550f402cb SHA1 d0898cd36a0d45247c6347b8881ee34f6024aeb5 SHA256 5951a886dc2237cdf30b76aadc4adf2b17454bd6b8b48d26d2cc33e953aed422
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/app-crypt/truecrypt/files/truecrypt-6.1-64bit.patch	Thu Jan 08 10:07:25 2009 +0100
@@ -0,0 +1,15 @@
+diff -urNp truecrypt-6.1-source.orig/Makefile truecrypt-6.1-source/Makefile
+--- truecrypt-6.1-source.orig/Makefile	2008-11-11 12:43:29.000000000 +0300
++++ truecrypt-6.1-source/Makefile	2008-11-11 13:34:37.000000000 +0300
+@@ -50,7 +50,11 @@ C_CXX_FLAGS += -I$(PKCS11_INC)
+ endif
+ 
+ C_CXX_FLAGS += -DBOOL=int -DFALSE=0 -DTRUE=1
++ifeq "$(origin USE64BIT)" "command line"
++C_CXX_FLAGS += -D__int8=char -D__int16=short -D__int32=int '-D__int64=long'  # Tested in PlatformTest
++else
+ C_CXX_FLAGS += -D__int8=char -D__int16=short -D__int32=int '-D__int64=long long'  # Tested in PlatformTest
++endif
+ 
+ export LFLAGS :=
+ export PKG_CONFIG_PATH ?= /usr/local/lib/pkgconfig
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/app-crypt/truecrypt/files/truecrypt-6.1-bool.patch	Thu Jan 08 10:07:25 2009 +0100
@@ -0,0 +1,25 @@
+diff -urNp truecrypt-6.1-source.orig/Common/Crypto.h truecrypt-6.1-source/Common/Crypto.h
+--- truecrypt-6.1-source.orig/Common/Crypto.h	2008-11-11 23:12:53.000000000 +0300
++++ truecrypt-6.1-source/Common/Crypto.h	2008-11-11 23:14:33.000000000 +0300
+@@ -29,6 +29,10 @@
+ 
+ #include "Tcdefs.h"
+ 
++#ifndef BOOL
++#define BOOL BOOL1
++#endif
++
+ #ifdef __cplusplus
+ extern "C" {
+ #endif
+diff -urNp truecrypt-6.1-source.orig/Makefile truecrypt-6.1-source/Makefile
+--- truecrypt-6.1-source.orig/Makefile	2008-11-11 23:12:53.000000000 +0300
++++ truecrypt-6.1-source/Makefile	2008-11-11 23:13:32.000000000 +0300
+@@ -50,6 +50,7 @@ C_CXX_FLAGS += -I$(PKCS11_INC)
+ endif
+ 
+ C_CXX_FLAGS += -DBOOL=int -DFALSE=0 -DTRUE=1
++C_CXX_FLAGS += -DBOOL1=int
+ ifeq "$(origin USE64BIT)" "command line"
+ C_CXX_FLAGS += -D__int8=char -D__int16=short -D__int32=int '-D__int64=long'  # Tested in PlatformTest
+ else
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/app-crypt/truecrypt/files/truecrypt-6.1-external-wx.patch	Thu Jan 08 10:07:25 2009 +0100
@@ -0,0 +1,11 @@
+diff -urNp truecrypt-6.1-source.orig/Main/Main.make truecrypt-6.1-source/Main/Main.make
+--- truecrypt-6.1-source.orig/Main/Main.make	2008-11-11 14:05:16.000000000 +0300
++++ truecrypt-6.1-source/Main/Main.make	2008-11-11 15:53:16.000000000 +0300
+@@ -76,6 +76,7 @@ WX_CONFIG_LIBS := base
+ else
+ WX_CONFIG_LIBS := adv,core,base
+ endif
++WX_CONFIG_LIBS =
+ 
+ ifeq "$(TC_BUILD_CONFIG)" "Release"
+ 
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/app-crypt/truecrypt/truecrypt-6.1a.ebuild	Thu Jan 08 10:07:25 2009 +0100
@@ -0,0 +1,105 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils toolchain-funcs multilib wxwidgets
+
+MY_P="${P}.tar.gz"
+
+DESCRIPTION="Free open-source disk encryption software"
+HOMEPAGE="http://www.truecrypt.org/"
+#SRC_URI="TrueCrypt ${PV} Source.tar.gz"
+SRC_URI="${P}.tar.gz
+	pkcs11.h
+	pkcs11f.h
+	pkcs11t.h"
+
+LICENSE="truecrypt-collective-1.4"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+RESTRICT="mirror fetch bindist"
+
+RDEPEND="sys-fs/fuse
+	=x11-libs/wxGTK-2.8*"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}-source"
+
+pkg_nofetch() {
+	einfo "Please download tar.gz source from:"
+	einfo "http://www.truecrypt.org/downloads2.php"
+	einfo "Then put the file in ${DISTDIR}/${MY_P}"
+	einfo "Please download RSA Security Inc. PKCS #11 Cryptographic Token Interface (Cryptoki) 2.20"
+	einfo "header files:"
+	einfo "ftp://ftp.rsasecurity.com/pub/pkcs/pkcs-11/v2-20/pkcs11.h"
+	einfo "ftp://ftp.rsasecurity.com/pub/pkcs/pkcs-11/v2-20/pkcs11f.h"
+	einfo "ftp://ftp.rsasecurity.com/pub/pkcs/pkcs-11/v2-20/pkcs11t.h"
+	einfo "Then put files in ${DISTDIR}"
+}
+
+pkg_setup() {
+	WX_GTK_VER="2.8"
+	if use X; then
+		need-wxwidgets unicode
+	else
+		need-wxwidgets base-unicode
+	fi
+}
+
+src_unpack() {
+	unpack ${MY_P}
+	cd "${S}"
+
+	epatch "${FILESDIR}/${PN}-6.1-64bit.patch"
+	epatch "${FILESDIR}/${PN}-6.1-bool.patch"
+	epatch "${FILESDIR}/${PN}-6.1-external-wx.patch"
+}
+
+src_compile() {
+	local EXTRA
+	use amd64 && EXTRA="${EXTRA} USE64BIT=1"
+	use X || EXTRA="${EXTRA} NOGUI=1"
+	if has_version '<sys-libs/glibc-2.7'; then
+		if [ "$(gcc-version)" = "4.3" ]; then
+			elog "You are trying to compile ${P} using >=sys-devel/gcc-4.3 and <sys-libs/glibc-2.7"
+			elog "In this case compiling will failed if not -O0 optimization flag used."
+			elog "Therefore ${P} will compliling with -O0 flag."
+			elog "Otherwise you could install >=sys-libs/glibc-2.7 or use <sys-devel/gcc-4.3"
+			CFLAGS="${CFLAGS} -O0"
+			CXXFLAGS="${CXXFLAGS} -O0"
+		fi
+	fi
+	emake \
+		${EXTRA} \
+		PKCS11_INC="${DISTDIR}" \
+		NOSTRIP=1 \
+		VERBOSE=1 \
+		NOTEST=1 \
+		CC="$(tc-getCC)" \
+		AR="$(tc-getAR)" \
+		CXX="$(tc-getCXX)" \
+		RANLIB="$(tc-getRANLIB)" \
+		EXTRA_CFLAGS="${CFLAGS}" \
+		EXTRA_CXXFLAGS="${CXXFLAGS}" \
+		EXTRA_LDFLAGS="${LDFLAGS}" \
+		WX_CONFIG="${WX_CONFIG}" \
+		WX_CONFIG_EXTRA="" \
+		|| die
+}
+
+src_test() {
+	"${S}/Main/truecrypt" --text --test
+}
+
+src_install() {
+	dobin Main/truecrypt
+	dodoc Readme.txt 'Release/Setup Files/TrueCrypt User Guide.pdf'
+	insinto "/$(get_libdir)/rcscripts/addons"
+	newins "${FILESDIR}/${PN}-stop.sh" "${PN}-stop.sh"
+}
+
+pkg_postinst() {
+	elog "potential legal problems - use at own risk"
+	elog "http://lists.freedesktop.org/archives/distributions/2008-October/000276.html"
+}