changeset 185:bf10d7d9cf43

redaxo ebuild is merge-able and can be installed via webapp-install
author Dirk Olmes <dirk@xanthippe.ping.de>
date Wed, 17 Feb 2010 13:50:56 +0100
parents 54b73709801b
children 0696f0fa8ee4
files www-apps/redaxo/Manifest www-apps/redaxo/redaxo-4.2.1.ebuild
diffstat 2 files changed, 28 insertions(+), 14 deletions(-) [+]
line wrap: on
line diff
--- a/www-apps/redaxo/Manifest	Wed Feb 17 10:16:48 2010 +0100
+++ b/www-apps/redaxo/Manifest	Wed Feb 17 13:50:56 2010 +0100
@@ -1,2 +1,2 @@
 DIST redaxo4_2_1.zip 2143442 RMD160 18d637be99cf076bf2a9feb59a98357da0db192a SHA1 b8f8a23c2b8b97d2b2eb854fafe3001e22840043 SHA256 4d9daacc0104a47cb05c43ffe6be5445b0ed0d00bee4bea9e58e1ac46fd5d61b
-EBUILD redaxo-4.2.1.ebuild 1421 RMD160 ce76ae6d5254e8ed43232c5675f060d543aa6a2b SHA1 ee1c1adacfc11370b1f9d183ecb213c527b384f2 SHA256 03e3f98a8bdb9b992e403a3941f5fd2c3e178a7035921b17838803b7b12cc785
+EBUILD redaxo-4.2.1.ebuild 2217 RMD160 e262ccffdc971f1d6c7068545748217a84ceb31c SHA1 5719b9d39e625e4548870cfd109203907f2530c8 SHA256 283de192e8f748716db017e3ac6e2bf892796d3085b2fb8965c21e3fdf539938
--- a/www-apps/redaxo/redaxo-4.2.1.ebuild	Wed Feb 17 10:16:48 2010 +0100
+++ b/www-apps/redaxo/redaxo-4.2.1.ebuild	Wed Feb 17 13:50:56 2010 +0100
@@ -12,13 +12,13 @@
 
 LICENSE="GPL"
 KEYWORDS="~amd64 ~x86"
-DEPEND=""
+DEPEND="app-arch/unzip"
 RDEPEND="virtual/httpd-cgi"
 
 need_php_httpd
 
 pkg_setup() {
-     webapp_pkg_setup
+    webapp_pkg_setup
 
     if  ! PHPCHECKNODIE="yes" require_php_with_any_use mysql ; then
             eerror
@@ -33,12 +33,7 @@
     # clean up some cruft that comes as part of the install package
     cd ${WORKDIR}/${MY_P}
     find . -name .DS_Store -exec rm {} \;
-}
-
-function remove_if_exists() {
-    if [ -f $1 ]; then
-        rm $1
-    fi
+    remove_if_exists _lastchanges.txt
 }
 
 src_install() {
@@ -48,15 +43,34 @@
     cd ${MY_P}
     cp -r . "${D}"${MY_HTDOCSDIR}
 
-    # get rid of some cruft
-    remove_if_exists ${MY_HTDOCSDIR}/_lastchanges.txt
-    remove_if_exists ${MY_HTDOCSDIR}/_lizenz.txt
-
     # .htaccess, index.php and the redaxo dir are part of the distro
-    local SERVEROWNED=".htaccess index.php redaxo"
+    local SERVEROWNED="index.php files files/_readme.txt files/addons \
+        redaxo redaxo/include/clang.inc.php redaxo/include/plugins.inc.php \
+        redaxo/include/addons.inc.php redaxo/include/master.inc.php \
+        redaxo/include/generated redaxo/include/generated/articles \
+        redaxo/include/generated/templates redaxo/include/generated/files \
+        redaxo/include/addons/import_export/backup redaxo/include/addons/import_export \
+        redaxo/include/addons/metainfo redaxo/include/addons/be_search \
+        redaxo/include/addons/image_resize  \
+        redaxo/include/addons/image_resize/config.inc.php"
     for SFILES in ${SERVEROWNED}; do
         webapp_serverowned ${MY_HTDOCSDIR}/${SFILES}
     done
 
     webapp_src_install
 }
+
+webapp_pkg_postinst() {
+    einfo "This ebuild does not perform any autoinstall of the package"
+    einfo ""
+    einfo "This allows you to install redaxo directly into the top of"
+    einfo "your document root using:"
+    einfo "webapp-config -I -h localhost -u root redaxo ${PV}"
+    einfo ""
+}
+
+function remove_if_exists() {
+    if [ -f $1 ]; then
+        rm $1
+    fi
+}