changeset 375:d130eab1967f

add mcabber build
author Dirk Olmes <dirk@xanthippe.ping.de>
date Sun, 04 Jan 2015 05:28:32 +0100
parents 3f197242b810
children da8488c002f2
files net-im/mcabber/Manifest net-im/mcabber/mcabber-0.10.3.ebuild
diffstat 2 files changed, 117 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-im/mcabber/Manifest	Sun Jan 04 05:28:32 2015 +0100
@@ -0,0 +1,2 @@
+DIST mcabber-0.10.3.tar.bz2 612153 SHA256 77466138496cc26db125145cc28dc4fc0df79827143b922dfb9f02eb0dc7fa6d SHA512 3f4c83dbe99f1e1981a89d2a9cdfbaf96b265aaabe133e41d562491557e0acc2d780ae88aa3e45eca9088318ef7d7b284f1df445d2b5afb139d5a247e111bc10 WHIRLPOOL 7139d7b44837026276b269f5d911486bc898ef4c72d0cec2ada066636f284c00205b207241024d4311a82f7eb6a83590dbf402167dec4441e477f6166a7595b5
+EBUILD mcabber-0.10.3.ebuild 3326 SHA256 13e16a45837af16bd20e5b746711dc31c742b43b9e65a3442180b68588d92c2b SHA512 afd4bd93599b71d69817122480e8a8019855d5f4f7150f535b62dcb443486632125ba6dfbb26cb596cc40d7016308dd7ea4f4dcb9c2ed1066aa972fdf5e99346 WHIRLPOOL fe8f7b0e9d62d9105b5a6efaa7ecd908e7d1b49317f69a4c21a34948c55da19cd153e0d46a2a7240ccc6bdd657145925ccf9954f5839d6dd30740e17be4c461b
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-im/mcabber/mcabber-0.10.3.ebuild	Sun Jan 04 05:28:32 2015 +0100
@@ -0,0 +1,115 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/mcabber-0.10.2_p20131025-r1.ebuild,v 1.1 2014/03/30 12:49:40 wschlich Exp $
+
+EAPI=5
+
+inherit flag-o-matic autotools-utils
+
+DESCRIPTION="A small Jabber console client with various features, like MUC, SSL, PGP"
+HOMEPAGE="http://mcabber.com/"
+SRC_URI="http://mcabber.com/files/mcabber-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+IUSE="aspell crypt idn modules otr spell ssl vim-syntax"
+
+LANGS="cs de fr it nl pl ru uk"
+# localized help versions are installed only, when LINGUAS var is set
+for i in ${LANGS}; do
+	IUSE="${IUSE} linguas_${i}"
+done;
+
+RDEPEND="crypt? ( >=app-crypt/gpgme-1.0.0 )
+	otr? ( >=net-libs/libotr-3.1.0 )
+	aspell? ( app-text/aspell )
+	vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
+	idn? ( net-dns/libidn  )
+	spell? ( app-text/enchant )
+	dev-libs/glib:2
+	sys-libs/ncurses
+	>=net-libs/loudmouth-1.4.3-r1[ssl?]"
+DEPEND="${RDEPEND}
+	virtual/pkgconfig"
+
+## autotools-utils.eclass settings
+AUTOTOOLS_AUTORECONF="1"
+AUTOTOOLS_IN_SOURCE_BUILD="1"
+DOCS=( AUTHORS ChangeLog NEWS README TODO mcabberrc.example doc/README_PGP.txt )
+#PATCHES=(
+#	"${FILESDIR}/${P}-vim-ftdetect.patch"
+#)
+
+pkg_setup() {
+	if use aspell && use spell; then
+		ewarn "NOTE: You have both USE flags 'aspell' and 'spell' enabled, enchant (USE flag 'spell') will be preferred."
+	fi
+}
+
+src_configure() {
+	local myeconfargs=(
+		$(use_enable crypt gpgme) \
+		$(use_enable otr) \
+		$(use_enable aspell) \
+		$(use_enable spell enchant) \
+		$(use_enable modules) \
+		$(use_with idn libidn)
+	)
+	autotools-utils_src_configure
+}
+
+src_install() {
+	autotools-utils_src_install
+
+	# clean unneeded language documentation
+	for i in ${LANGS}; do
+		use linguas_${i} || rm -rf "${ED}"/usr/share/${PN}/help/${i}
+	done
+
+	# contrib themes
+	insinto /usr/share/${PN}/themes
+	doins "${S}"/contrib/themes/*
+
+	# contrib generic scripts
+	exeinto /usr/share/${PN}/scripts
+	doexe "${S}"/contrib/*.{pl,py}
+
+	# contrib event scripts
+	exeinto /usr/share/${PN}/scripts/events
+	doexe "${S}"/contrib/events/*
+
+	if use vim-syntax; then
+		cd contrib/vim/ || die
+
+		insinto /usr/share/vim/vimfiles/syntax
+		doins mcabber_log-syntax.vim
+
+		insinto /usr/share/vim/vimfiles/ftdetect
+		doins mcabber_log-ftdetect.vim
+	fi
+}
+
+pkg_postinst() {
+	elog
+	elog "MCabber requires you to create a subdirectory .mcabber in your home"
+	elog "directory and to place a configuration file there."
+	elog "An example mcabberrc was installed as part of the documentation."
+	elog "To create a new mcabberrc based on the example mcabberrc, execute the"
+	elog "following commands:"
+	elog
+	elog "  mkdir -p ~/.mcabber"
+	elog "  bzcat ${EROOT}usr/share/doc/${PF}/mcabberrc.example.bz2 >~/.mcabber/mcabberrc"
+	elog
+	elog "Then edit ~/.mcabber/mcabberrc with your favorite editor."
+	elog
+	elog "See the CONFIGURATION FILE and FILES sections of the mcabber"
+	elog "manual page (section 1) for more information."
+	elog
+	elog "From version 0.9.0 on, MCabber supports PGP encryption of messages."
+	elog "See README_PGP.txt for details."
+	echo
+	einfo "Check out ${EROOT}usr/share/${PN} for contributed themes and event scripts."
+	echo
+}