changeset 333:d546b5c5e59e

bump to r15b1
author holger
date Wed, 04 Apr 2012 17:49:11 +0200
parents 22195299ef59
children 4253ac575ea5
files dev-lang/erlang/Manifest dev-lang/erlang/erlang-15.2.1.ebuild dev-lang/erlang/erlang-15.2.ebuild
diffstat 3 files changed, 184 insertions(+), 184 deletions(-) [+]
line wrap: on
line diff
--- a/dev-lang/erlang/Manifest	Wed Apr 04 16:38:41 2012 +0200
+++ b/dev-lang/erlang/Manifest	Wed Apr 04 17:49:11 2012 +0200
@@ -1,7 +1,7 @@
 AUX 50erlang-gentoo.el 134 RMD160 a453ad18f47d20e5ea5ecd1f4e4054d00eab5c35 SHA1 7c17979f533654ef05bbfcc8ae30554e7843923b SHA256 97e1da82cae31a554134d7370739520e4c67b2544e5a13f887651a62e710b4d4
 AUX epmd.init 515 RMD160 7f5927b020809ec9013a6f0e997fc0232489162a SHA1 dd32584a9e4971fac65881ce2e215afb570a5292 SHA256 d60df142ee0e47e9d55f543effe99b057dbf763586cadffb05a82ce74edeb494
-DIST otp_doc_html_R15B.tar.gz 28996680 RMD160 79606286c3708a56dbc9e54efb60f184fe36c809 SHA1 a163b940fa6e4c60f4c9cfe47d993977660e7ed1 SHA256 40504ad983b450a2c6f7611b3be88ebd6349079764520cca050e9c8f6e79dc93
-DIST otp_doc_man_R15B.tar.gz 1122044 RMD160 ba9352d78462a3ec3461ea955ae46b96cad95400 SHA1 4fb7b64ce06a5209a420914962784ca4a38d2113 SHA256 1839cc4cab3120401989e0e1d7ad6872a59e2fd9d3cd82f05ca8c4ebef18eb6b
-DIST otp_src_R15B.tar.gz 74100507 RMD160 022ed91978e85f5a446a90825aa686dd608061a9 SHA1 8177a5d40e4a3d7eb8dc7f7898241a034f35ea72 SHA256 5bc34fc34fc890f84bae7ff1f7c81fbec2c9aa28a0ef51a57d7a8192204d8aa2
-EBUILD erlang-15.2.ebuild 5422 RMD160 eea88e6100b5ce8a50b712a3c85ef262fc59db0e SHA1 2abf97a887f383f0e57c2f73f78a53f632a75e8c SHA256 267a87783467f922b87acf5d55ff7f3fc50b77422d929f700fb85f8b725f3042
+DIST otp_doc_html_R15B01.tar.gz 30235738 RMD160 bf5eb7b1e3259f752196e563ba7500b7cee35b65 SHA1 dfbad0ffd99be2ae219615f7a354ee9d1442e1a7 SHA256 0b6eb18855b451882ff5be07d3c25b497b256ead14d6be98791bf056b958a8e7
+DIST otp_doc_man_R15B01.tar.gz 1287293 RMD160 57e25006fc250d364bb7e7fe0e607b703bea8202 SHA1 ec303c8e2957570b3b1ad56af8a5b29a6618d09a SHA256 5032bcb992369543139136896ba67b4f8fa58fd3d223941a01a39063b221212c
+DIST otp_src_R15B01.tar.gz 75592537 RMD160 98eeceb24ebc5f805d79ac0075b3eec7d537e823 SHA1 c6e1f2fad965deb3696184c1ee16472bcea2bf22 SHA256 f94f7de7328af3c0cdc42089c1a4ecd03bf98ec680f47eb5e6cddc50261cabde
+EBUILD erlang-15.2.1.ebuild 5423 RMD160 3901359b18658cec5366c6cdf978958ad5568737 SHA1 7338235ca60f8022d8298fc35c10ad67cc58add6 SHA256 90f1cbf7efff54a0d3fb5e2d83b1c7a7632fe89ba39a3a5abae567a6ac614e1f
 MISC metadata.xml 744 RMD160 47d7adeeeb67a91bb6d124522946f4075021a2f3 SHA1 1bc2d0cd3e1c8f4f10290087ab7e1ace28d3002b SHA256 81b659111fcfcd664dc7c096a52fd295b6010663eb4de875d863ed6e40dbae82
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-lang/erlang/erlang-15.2.1.ebuild	Wed Apr 04 17:49:11 2012 +0200
@@ -0,0 +1,180 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-14.2.4.ebuild,v 1.2 2011/12/07 17:44:39 ulm Exp $
+
+EAPI=3
+WX_GTK_VER="2.8"
+
+inherit elisp-common eutils java-pkg-opt-2 multilib versionator wxwidgets
+
+# NOTE: If you need symlinks for binaries please tell maintainers or
+# open up a bug to let it be created.
+
+# erlang uses a really weird versioning scheme which caused quite a few problems
+# already. Thus we do a slight modification converting all letters to digits to
+# make it more sane (see e.g. #26420)
+
+# the next line selects the right source.
+ERL_VER=($(get_version_components))
+MY_PV="R$(get_major_version)B0${ERL_VER[2]}"
+
+# ATTN!! Take care when processing the C, etc version!
+MY_P=otp_src_${MY_PV}
+
+DESCRIPTION="Erlang programming language, runtime environment, and large collection of libraries"
+HOMEPAGE="http://www.erlang.org/"
+SRC_URI="http://www.erlang.org/download/${MY_P}.tar.gz
+	http://erlang.org/download/otp_doc_man_${MY_PV}.tar.gz
+	doc? ( http://erlang.org/download/otp_doc_html_${MY_PV}.tar.gz )"
+
+LICENSE="ErlPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris"
+IUSE="doc emacs halfword hipe java kpoll odbc smp sctp ssl tk wxwidgets"
+
+RDEPEND=">=dev-lang/perl-5.6.1
+	ssl? ( >=dev-libs/openssl-0.9.7d )
+	emacs? ( virtual/emacs )
+	java? ( >=virtual/jdk-1.2 )
+	odbc? ( dev-db/unixODBC )"
+DEPEND="${RDEPEND}
+	wxwidgets? ( x11-libs/wxGTK:2.8[opengl] )
+	sctp? ( net-misc/lksctp-tools )
+	tk? ( dev-lang/tk )"
+
+S="${WORKDIR}/${MY_P}"
+
+SITEFILE=50${PN}-gentoo.el
+
+pkg_setup() {
+	use wxwidgets && wxwidgets_pkg_setup
+	if use halfword ; then
+		use amd64 || die "halfword support is limited to amd64"
+	fi
+}
+
+src_prepare() {
+	use odbc || sed -i 's: odbc : :' lib/Makefile
+
+	# bug 263129, don't ignore LDFLAGS, reported upstream
+	sed -e 's:LDFLAGS = \$(DED_LDFLAGS):LDFLAGS += \$(DED_LDFLAGS):' -i "${S}"/lib/megaco/src/flex/Makefile.in || die
+
+	if ! use wxwidgets; then
+		sed -i 's: wx : :' lib/Makefile
+		rm -rf lib/wx
+	fi
+
+	# Nasty workaround, reported upstream
+	cp "${S}"/lib/configure.in.src "${S}"/lib/configure.in || die
+
+	# prevent configure from injecting -m32 by default on Darwin, bug #334155
+	# Nasty hack
+	sed -i -e 's/Darwin-i386/Darwin-NO/' configure.in || die
+	sed -i -e '/\<\(LD\|C\)FLAGS="-m32/s/-m32//' erts/configure.in || die
+
+	# bug 383697
+	sed -i '1i#define OF(x) x' erts/emulator/drivers/common/gzio.c || die
+}
+
+src_configure() {
+	use java || export JAVAC=false
+
+	econf \
+		--enable-threads \
+		--enable-shared-zlib \ \
+		$(use_enable sctp) \
+		$(use_enable halfword halfword-emulator) \
+		$(use_enable hipe) \
+		$(use_with ssl ssl "${EPREFIX}"/usr) \
+		$(use_enable ssl dynamic-ssl-lib) \
+		$(use_enable kpoll kernel-poll) \
+		$(use_enable smp smp-support) \
+		|| die
+}
+
+src_compile() {
+	use java || export JAVAC=false
+	emake -j1 || die
+
+	if use emacs ; then
+		pushd lib/tools/emacs
+		elisp-compile *.el || die
+		popd
+	fi
+}
+
+extract_version() {
+	sed -n -e "/^$2 = \(.*\)$/s::\1:p" "${S}/$1/vsn.mk"
+}
+
+src_install() {
+	local ERL_LIBDIR=/usr/$(get_libdir)/erlang
+	local ERL_INTERFACE_VER=$(extract_version lib/erl_interface EI_VSN)
+	local ERL_ERTS_VER=$(extract_version erts VSN)
+
+	emake -j1 INSTALL_PREFIX="${D}" install || die
+	dodoc AUTHORS README.md
+
+	dosym "${ERL_LIBDIR}/bin/erl" /usr/bin/erl
+	dosym "${ERL_LIBDIR}/bin/erlc" /usr/bin/erlc
+	dosym "${ERL_LIBDIR}/bin/escript" /usr/bin/escript
+	dosym \
+		"${ERL_LIBDIR}/lib/erl_interface-${ERL_INTERFACE_VER}/bin/erl_call" \
+		/usr/bin/erl_call
+	dosym "${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam" /usr/bin/beam
+	use smp && dosym "${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam.smp" /usr/bin/beam.smp
+
+	## Remove ${D} from the following files
+	sed -e "s:${D}::g" -i "${ED}${ERL_LIBDIR}/bin/erl" || die
+	sed -e "s:${D}::g" -i "${ED}${ERL_LIBDIR}/bin/start" || die
+	grep -rle "${D}" "${ED}/${ERL_LIBDIR}/erts-${ERL_ERTS_VER}" | xargs sed -i -e "s:${D}::g"
+
+	## Clean up the no longer needed files
+	rm "${ED}/${ERL_LIBDIR}/Install"||die
+
+	for i in "${WORKDIR}"/man/man* ; do
+		dodir "${ERL_LIBDIR}/${i##${WORKDIR}}"
+	done
+	for file in "${WORKDIR}"/man/man*/*.[1-9]; do
+			# doman sucks so we can't use it
+		cp ${file} "${ED}/${ERL_LIBDIR}"/man/man${file##*.}/
+	done
+	# extend MANPATH, so the normal man command can find it
+	# see bug 189639
+	dodir /etc/env.d/
+	echo "MANPATH=\"${EPREFIX}${ERL_LIBDIR}/man\"" > "${ED}/etc/env.d/90erlang"
+
+	if use doc ; then
+		dohtml -A README,erl,hrl,c,h,kwc,info -r \
+			"${WORKDIR}"/doc "${WORKDIR}"/lib "${WORKDIR}"/erts-*
+	fi
+
+	if use emacs ; then
+		pushd "${S}"
+		elisp-install erlang lib/tools/emacs/*.{el,elc}
+		sed -e "s:/usr/share:${EPREFIX}/usr/share:g" \
+			"${FILESDIR}"/${SITEFILE} > "${T}"/${SITEFILE}
+		elisp-site-file-install "${T}"/${SITEFILE}
+		popd
+	fi
+
+	# prepare erl for SMP, fixes bug #188112
+	use smp && sed -i -e 's:\(exec.*erlexec\):\1 -smp:' \
+		"${ED}/${ERL_LIBDIR}/bin/erl"
+
+	newinitd "${FILESDIR}"/epmd.init epmd || die
+}
+
+pkg_postinst() {
+	use emacs && elisp-site-regen
+	elog
+	elog "If you need a symlink to one of Erlang's binaries,"
+	elog "please open a bug on http://bugs.gentoo.org/"
+	elog
+	elog "Gentoo's versioning scheme differs from the author's, so please refer to this version as ${MY_PV}"
+	elog
+}
+
+pkg_postrm() {
+	use emacs && elisp-site-regen
+}
--- a/dev-lang/erlang/erlang-15.2.ebuild	Wed Apr 04 16:38:41 2012 +0200
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,180 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-14.2.4.ebuild,v 1.2 2011/12/07 17:44:39 ulm Exp $
-
-EAPI=3
-WX_GTK_VER="2.8"
-
-inherit elisp-common eutils java-pkg-opt-2 multilib versionator wxwidgets
-
-# NOTE: If you need symlinks for binaries please tell maintainers or
-# open up a bug to let it be created.
-
-# erlang uses a really weird versioning scheme which caused quite a few problems
-# already. Thus we do a slight modification converting all letters to digits to
-# make it more sane (see e.g. #26420)
-
-# the next line selects the right source.
-ERL_VER=($(get_version_components))
-MY_PV="R$(get_major_version)B${ERL_VER[2]}"
-
-# ATTN!! Take care when processing the C, etc version!
-MY_P=otp_src_${MY_PV}
-
-DESCRIPTION="Erlang programming language, runtime environment, and large collection of libraries"
-HOMEPAGE="http://www.erlang.org/"
-SRC_URI="http://www.erlang.org/download/${MY_P}.tar.gz
-	http://erlang.org/download/otp_doc_man_${MY_PV}.tar.gz
-	doc? ( http://erlang.org/download/otp_doc_html_${MY_PV}.tar.gz )"
-
-LICENSE="ErlPL-1.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris"
-IUSE="doc emacs halfword hipe java kpoll odbc smp sctp ssl tk wxwidgets"
-
-RDEPEND=">=dev-lang/perl-5.6.1
-	ssl? ( >=dev-libs/openssl-0.9.7d )
-	emacs? ( virtual/emacs )
-	java? ( >=virtual/jdk-1.2 )
-	odbc? ( dev-db/unixODBC )"
-DEPEND="${RDEPEND}
-	wxwidgets? ( x11-libs/wxGTK:2.8[opengl] )
-	sctp? ( net-misc/lksctp-tools )
-	tk? ( dev-lang/tk )"
-
-S="${WORKDIR}/${MY_P}"
-
-SITEFILE=50${PN}-gentoo.el
-
-pkg_setup() {
-	use wxwidgets && wxwidgets_pkg_setup
-	if use halfword ; then
-		use amd64 || die "halfword support is limited to amd64"
-	fi
-}
-
-src_prepare() {
-	use odbc || sed -i 's: odbc : :' lib/Makefile
-
-	# bug 263129, don't ignore LDFLAGS, reported upstream
-	sed -e 's:LDFLAGS = \$(DED_LDFLAGS):LDFLAGS += \$(DED_LDFLAGS):' -i "${S}"/lib/megaco/src/flex/Makefile.in || die
-
-	if ! use wxwidgets; then
-		sed -i 's: wx : :' lib/Makefile
-		rm -rf lib/wx
-	fi
-
-	# Nasty workaround, reported upstream
-	cp "${S}"/lib/configure.in.src "${S}"/lib/configure.in || die
-
-	# prevent configure from injecting -m32 by default on Darwin, bug #334155
-	# Nasty hack
-	sed -i -e 's/Darwin-i386/Darwin-NO/' configure.in || die
-	sed -i -e '/\<\(LD\|C\)FLAGS="-m32/s/-m32//' erts/configure.in || die
-
-	# bug 383697
-	sed -i '1i#define OF(x) x' erts/emulator/drivers/common/gzio.c || die
-}
-
-src_configure() {
-	use java || export JAVAC=false
-
-	econf \
-		--enable-threads \
-		--enable-shared-zlib \ \
-		$(use_enable sctp) \
-		$(use_enable halfword halfword-emulator) \
-		$(use_enable hipe) \
-		$(use_with ssl ssl "${EPREFIX}"/usr) \
-		$(use_enable ssl dynamic-ssl-lib) \
-		$(use_enable kpoll kernel-poll) \
-		$(use_enable smp smp-support) \
-		|| die
-}
-
-src_compile() {
-	use java || export JAVAC=false
-	emake -j1 || die
-
-	if use emacs ; then
-		pushd lib/tools/emacs
-		elisp-compile *.el || die
-		popd
-	fi
-}
-
-extract_version() {
-	sed -n -e "/^$2 = \(.*\)$/s::\1:p" "${S}/$1/vsn.mk"
-}
-
-src_install() {
-	local ERL_LIBDIR=/usr/$(get_libdir)/erlang
-	local ERL_INTERFACE_VER=$(extract_version lib/erl_interface EI_VSN)
-	local ERL_ERTS_VER=$(extract_version erts VSN)
-
-	emake -j1 INSTALL_PREFIX="${D}" install || die
-	dodoc AUTHORS README.md
-
-	dosym "${ERL_LIBDIR}/bin/erl" /usr/bin/erl
-	dosym "${ERL_LIBDIR}/bin/erlc" /usr/bin/erlc
-	dosym "${ERL_LIBDIR}/bin/escript" /usr/bin/escript
-	dosym \
-		"${ERL_LIBDIR}/lib/erl_interface-${ERL_INTERFACE_VER}/bin/erl_call" \
-		/usr/bin/erl_call
-	dosym "${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam" /usr/bin/beam
-	use smp && dosym "${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam.smp" /usr/bin/beam.smp
-
-	## Remove ${D} from the following files
-	sed -e "s:${D}::g" -i "${ED}${ERL_LIBDIR}/bin/erl" || die
-	sed -e "s:${D}::g" -i "${ED}${ERL_LIBDIR}/bin/start" || die
-	grep -rle "${D}" "${ED}/${ERL_LIBDIR}/erts-${ERL_ERTS_VER}" | xargs sed -i -e "s:${D}::g"
-
-	## Clean up the no longer needed files
-	rm "${ED}/${ERL_LIBDIR}/Install"||die
-
-	for i in "${WORKDIR}"/man/man* ; do
-		dodir "${ERL_LIBDIR}/${i##${WORKDIR}}"
-	done
-	for file in "${WORKDIR}"/man/man*/*.[1-9]; do
-			# doman sucks so we can't use it
-		cp ${file} "${ED}/${ERL_LIBDIR}"/man/man${file##*.}/
-	done
-	# extend MANPATH, so the normal man command can find it
-	# see bug 189639
-	dodir /etc/env.d/
-	echo "MANPATH=\"${EPREFIX}${ERL_LIBDIR}/man\"" > "${ED}/etc/env.d/90erlang"
-
-	if use doc ; then
-		dohtml -A README,erl,hrl,c,h,kwc,info -r \
-			"${WORKDIR}"/doc "${WORKDIR}"/lib "${WORKDIR}"/erts-*
-	fi
-
-	if use emacs ; then
-		pushd "${S}"
-		elisp-install erlang lib/tools/emacs/*.{el,elc}
-		sed -e "s:/usr/share:${EPREFIX}/usr/share:g" \
-			"${FILESDIR}"/${SITEFILE} > "${T}"/${SITEFILE}
-		elisp-site-file-install "${T}"/${SITEFILE}
-		popd
-	fi
-
-	# prepare erl for SMP, fixes bug #188112
-	use smp && sed -i -e 's:\(exec.*erlexec\):\1 -smp:' \
-		"${ED}/${ERL_LIBDIR}/bin/erl"
-
-	newinitd "${FILESDIR}"/epmd.init epmd || die
-}
-
-pkg_postinst() {
-	use emacs && elisp-site-regen
-	elog
-	elog "If you need a symlink to one of Erlang's binaries,"
-	elog "please open a bug on http://bugs.gentoo.org/"
-	elog
-	elog "Gentoo's versioning scheme differs from the author's, so please refer to this version as ${MY_PV}"
-	elog
-}
-
-pkg_postrm() {
-	use emacs && elisp-site-regen
-}