changeset 561:d8cdda1e208e

most recent version of lazarus IDE
author Dirk Olmes <dirk.olmes@codedo.de>
date Sat, 01 Oct 2022 17:08:33 +0200
parents 85f9a2fbc16e
children 6af40b737a1c
files dev-lang/lazarus/Manifest dev-lang/lazarus/files/lazarus-0.9.26-fpcsrc.patch dev-lang/lazarus/lazarus-2.2.4.ebuild
diffstat 3 files changed, 94 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-lang/lazarus/Manifest	Sat Oct 01 17:08:33 2022 +0200
@@ -0,0 +1,3 @@
+AUX lazarus-0.9.26-fpcsrc.patch 407 BLAKE2B c3b006fd7bb58fb7037aae3d8d35ac146ab971fc6063652e3185b320e4cb05ccedb6c26c7d64b2f2998a901608ee251762b723f62bd9c239a51ab6a6d6f2b39d SHA512 823d9ba2041f97c39d8ea5f49cb02f68d8c98da95d0a479cc65a638365e2adafd1c5645fa6846720af18198834958f37b0cc0d92f38023ccdaf40ec8dc848f64
+DIST lazarus-2.2.4-0.tar.gz 77272959 BLAKE2B 2d7b2872a7399eb1a3a7d9fb20fed209900603ae433db75ac2c4244edf5e5981314ed3d8e39143ff30764e7ccbf1286edace9c38505df1cd28b44250bdd07224 SHA512 1a2fbc8451f1954df1d0071c586662ebc3cd0e9a7db5d910e0af86a3095252a5796d4c7abcf3861ad723af26974ac416c5bf919cd77ad5f406295ad7cdf47eb1
+EBUILD lazarus-2.2.4.ebuild 2413 BLAKE2B f09dee3695b75dd6c59ff54b3358c7674a445d0476cce66ca0efb30331a66eaaa5596184913a798d9ceb6b95df1f428f206c6d886dd3fd0900df3de43a2494ba SHA512 5e2090fad65e9ad74679010c704643ec290a63f022711b5b454f6c564ae38758d501aaa3045e4a794e9fdb6a5afa1b694bcbc932ca3d0174fcaa22b628924a2f
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-lang/lazarus/files/lazarus-0.9.26-fpcsrc.patch	Sat Oct 01 17:08:33 2022 +0200
@@ -0,0 +1,13 @@
+--- lazarus/ide/include/unix/lazbaseconf.inc
++++ lazarus/ide/include/unix/lazbaseconf.inc
+@@ -24,8 +24,9 @@
+ }
+ 
+ const
+-  DefaultFPCSrcDirs: array[1..15] of string = (
++  DefaultFPCSrcDirs: array[1..16] of string = (
+     // search first for sources with right version
++    '/usr/lib/fpc/$(FPCVer)/source',
+     '/usr/share/fpcsrc/$(FPCVer)',
+     // then search for global paths
+     '/usr/share/fpcsrc',
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-lang/lazarus/lazarus-2.2.4.ebuild	Sat Oct 01 17:08:33 2022 +0200
@@ -0,0 +1,78 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+
+# See https://wiki.freepascal.org/Lazarus_2.0_fixes_branch for notes and
+# changes in FPCVER. It *does* change between minor versions of lazarus.
+FPCVER="3.2.2"
+
+DESCRIPTION="Lazarus IDE is a feature rich visual programming environment emulating Delphi"
+HOMEPAGE="https://www.lazarus-ide.org/"
+SRC_URI="https://sourceforge.net/projects/${PN}/files/Lazarus%20Zip%20_%20GZip/Lazarus%20${PV}/${P}-0.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1-with-linking-exception"
+SLOT="0" # Note: Slotting Lazarus needs slotting fpc, see DEPEND.
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal"
+
+DEPEND=">=dev-lang/fpc-${FPCVER}[source]
+	net-misc/rsync
+	x11-libs/gtk+:2
+	>=sys-devel/binutils-2.19.1-r1:="
+RDEPEND="${DEPEND}"
+
+RESTRICT="strip" #269221
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.9.26-fpcsrc.patch )
+
+src_prepare() {
+	default
+	# Use default configuration (minus stripping) unless specifically requested otherwise
+	if ! test ${PPC_CONFIG_PATH+set} ; then
+		local FPCVER=$(fpc -iV)
+		export PPC_CONFIG_PATH="${WORKDIR}"
+		sed -e 's/^FPBIN=/#&/' /usr/lib/fpc/${FPCVER}/samplecfg |
+			sh -s /usr/lib/fpc/${FPCVER} "${PPC_CONFIG_PATH}" || die
+	fi
+}
+
+src_compile() {
+	# TODO: Change to LCL_PLATFORM=qt5?
+	# bug #732758
+	LCL_PLATFORM=gtk2 emake \
+		$(usex minimal "" "bigide") \
+		-j1
+}
+
+src_install() {
+	diropts -m0755
+	dodir /usr/share
+	# Using rsync to avoid unnecessary copies and cleaning...
+	# Note: *.o and *.ppu are needed
+	rsync -a \
+		--exclude="CVS"     --exclude=".cvsignore" \
+		--exclude="*.ppw"   --exclude="*.ppl" \
+		--exclude="*.ow"    --exclude="*.a"\
+		--exclude="*.rst"   --exclude=".#*" \
+		--exclude="*.~*"    --exclude="*.bak" \
+		--exclude="*.orig"  --exclude="*.rej" \
+		--exclude=".xvpics" --exclude="*.compiled" \
+		--exclude="killme*" --exclude=".gdb_hist*" \
+		--exclude="debian"  --exclude="COPYING*" \
+		--exclude="*.app" \
+		"${S}" "${ED}"/usr/share \
+		|| die "Unable to copy files!"
+
+	dosym ../share/lazarus/startlazarus /usr/bin/startlazarus
+	dosym ../share/lazarus/startlazarus /usr/bin/lazarus
+	dosym ../share/lazarus/lazbuild /usr/bin/lazbuild
+	use minimal || dosym ../share/lazarus/components/chmhelp/lhelp/lhelp /usr/bin/lhelp
+	dosym ../lazarus/images/ide_icon48x48.png /usr/share/pixmaps/lazarus.png
+
+	make_desktop_entry startlazarus "Lazarus IDE" "lazarus"
+}