changeset 3:e15b399580ab

mercurial 1.0 is in portage
author holger@hoho.dyndns.org
date Tue, 25 Mar 2008 20:51:38 +0100
parents 0ea7846e04f1
children 6e30efce1771
files dev-util/mercurial/Manifest dev-util/mercurial/files/70mercurial-gentoo.el dev-util/mercurial/mercurial-1.0.ebuild
diffstat 3 files changed, 0 insertions(+), 86 deletions(-) [+]
line wrap: on
line diff
--- a/dev-util/mercurial/Manifest	Tue Mar 25 20:50:34 2008 +0100
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,3 +0,0 @@
-AUX 70mercurial-gentoo.el 76 RMD160 1891ab510adb464211b4cc35c5b6e4b149da79fa SHA1 72eb35d2bf86fa8f806acfbc823b88fc5188741b SHA256 c215746e4a5375569808c6aa6ddabe08e82d33d744128179be3142d9cd53a5ab
-DIST mercurial-1.0.tar.gz 803187 RMD160 21b5603e033898420f4fbf1b851ede4f69a7657c SHA1 11689e85a91874417cb110ded6c3a4d7b30429cb SHA256 c4d3e1eb0bbc1e77de587ecd452750bb1a09564ec056e2b4c8e2a6db4a863e0f
-EBUILD mercurial-1.0.ebuild 2003 RMD160 1048ba5b2a9249014523fc5780a17839d40e5d84 SHA1 e9c610bf49c57926fcd2d03823307e5d4d2c5745 SHA256 7489ff2e5fdc1204f1281899127ed42fde2dc4692f20221a7db3dea7711d3851
--- a/dev-util/mercurial/files/70mercurial-gentoo.el	Tue Mar 25 20:50:34 2008 +0100
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,3 +0,0 @@
-;;; mercurial site-lisp configuration
-
-(add-to-list 'load-path "@SITELISP@")
\ No newline at end of file
--- a/dev-util/mercurial/mercurial-1.0.ebuild	Tue Mar 25 20:50:34 2008 +0100
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,80 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mercurial/mercurial-0.9.5-r1.ebuild,v 1.5 2008/01/21 09:36:03 nelchael Exp $
-
-inherit bash-completion distutils elisp-common flag-o-matic eutils
-
-DESCRIPTION="Scalable distributed SCM"
-HOMEPAGE="http://www.selenic.com/mercurial/"
-SRC_URI="http://www.selenic.com/mercurial/release/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="bugzilla cvs darcs emacs git gpg subversion test zsh-completion"
-
-CDEPEND=">=dev-lang/python-2.3"
-RDEPEND="${CDEPEND}
-	bugzilla? ( dev-python/mysql-python )
-	cvs? ( dev-util/cvs )
-	darcs? ( || ( dev-python/celementtree dev-python/elementtree ) )
-	git? ( dev-util/git )
-	gpg? ( app-crypt/gnupg )
-	subversion? ( dev-util/subversion )
-	zsh-completion? ( app-shells/zsh )"
-DEPEND="${CDEPEND}
-	emacs? ( virtual/emacs )
-	test? ( app-arch/unzip )"
-
-PYTHON_MODNAME="${PN} hgext"
-SITEFILE="70${PN}-gentoo.el"
-
-src_unpack() {
-	distutils_src_unpack
-}
-
-src_compile() {
-	filter-flags -ftracer -ftree-vectorize
-
-	distutils_src_compile
-
-	if use emacs; then
-		cd "${S}"/contrib
-		elisp-compile mercurial.el || die "elisp-compile failed!"
-	fi
-
-	rm -rf contrib/{win32,macosx}
-}
-
-src_install() {
-	distutils_src_install
-
-	dobashcompletion contrib/bash_completion ${PN}
-
-	if use zsh-completion ; then
-		insinto /usr/share/zsh/site-functions
-		newins contrib/zsh_completion _hg
-	fi
-
-	dodoc CONTRIBUTORS PKG-INFO README doc/*.txt
-	cp hgweb*.cgi "${D}"/usr/share/doc/${PF}/
-	rm -f contrib/bash_completion
-	cp -r contrib "${D}"/usr/share/doc/${PF}/
-	doman doc/*.?
-
-	if use emacs; then
-		elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
-		elisp-site-file-install "${FILESDIR}"/${SITEFILE}
-	fi
-}
-
-pkg_postinst() {
-	distutils_pkg_postinst
-	use emacs && elisp-site-regen
-	bash-completion_pkg_postinst
-}
-
-pkg_postrm() {
-	distutils_pkg_postrm
-	use emacs && elisp-site-regen
-}