changeset 106:ee276ccfcc7b

bump subversion to 1.5.6
author holger@hoho.dyndns.org
date Sat, 28 Feb 2009 20:20:36 +0100
parents e20430b8f81b
children 72f3700549ac
files dev-util/subversion/Manifest dev-util/subversion/subversion-1.5.5.ebuild dev-util/subversion/subversion-1.5.6.ebuild
diffstat 3 files changed, 414 insertions(+), 414 deletions(-) [+]
line wrap: on
line diff
--- a/dev-util/subversion/Manifest	Tue Feb 24 20:19:18 2009 +0100
+++ b/dev-util/subversion/Manifest	Sat Feb 28 20:20:36 2009 +0100
@@ -7,6 +7,6 @@
 AUX svnserve.initd 817 RMD160 59f4e8e983d4595b7c27615889a9c0809d015a18 SHA1 483b47512fb444c0f752ad4eb6c3252f659a967e SHA256 6b483e211b5c311079605e246fca9228c7e5762d27a023fa4c4529fdaa766b08
 AUX svnserve.xinetd 332 RMD160 c2fc4eb02da7e7405756fce650b8897f0a9da7f7 SHA1 d7d478fc257a40626888f9b12ee218df55dac570 SHA256 267f30c78ef6428aeeb97d3c64c06b9acfba4bc624766fc3c6a6d2c4133799a2
 AUX vc-svn.el 16847 RMD160 8665b9a34c8fd9acae40e18aac33026aff3a39d7 SHA1 4d1a5a9331ff96e943244a6d5538e4f0abeac9e7 SHA256 b4979d5df9fba02dbc8ad71d813229222e95ee1e8e89dec3060611d2d6be87aa
-DIST subversion-1.5.5.tar.bz2 4940482 RMD160 6400e387b3505180206b61729cb0b11baeae70d3 SHA1 61c9a7209ccef8eff3c0499629d62ed4d3c89988 SHA256 88cf24ba5d589351791709ff7556ababc019ec59f3240ac2087dacabb9ad77be
-EBUILD subversion-1.5.5.ebuild 13393 RMD160 0ef259d6fc6440536d9fb74c1fc24ad08b8c1997 SHA1 13bb283d304eedc5e1e9937be804e41e4db48015 SHA256 17e47cc89d09b11c79a924b8765a90d2bb0944506e54ab434c4a2016aca95a66
+DIST subversion-1.5.6.tar.bz2 4946600 RMD160 5883f925e19e719c8656b5488ed9b00c0f7c3a79 SHA1 774b6dbd4245c36e86289393e651e36dedf17018 SHA256 f701fe75fecc43d9aecf717260ca18661469128a2f28a57c7e6672f3f64f46c2
+EBUILD subversion-1.5.6.ebuild 13393 RMD160 0ef259d6fc6440536d9fb74c1fc24ad08b8c1997 SHA1 13bb283d304eedc5e1e9937be804e41e4db48015 SHA256 17e47cc89d09b11c79a924b8765a90d2bb0944506e54ab434c4a2016aca95a66
 MISC metadata.xml 958 RMD160 9e4aa5a4dfeef1a81c20121e8e75baf45d0962ca SHA1 c8844225273473a569cefae106533215961c287f SHA256 396a72dd2fddb8fb146ce87fa05692ab9f7d183057c0940d9365f88602a03dc7
--- a/dev-util/subversion/subversion-1.5.5.ebuild	Tue Feb 24 20:19:18 2009 +0100
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,412 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/subversion-1.5.4.ebuild,v 1.11 2008/12/07 12:13:48 vapier Exp $
-
-EAPI="1"
-WANT_AUTOMAKE="none"
-
-inherit autotools bash-completion confutils depend.apache elisp-common eutils flag-o-matic java-pkg-opt-2 libtool multilib perl-module python
-
-DESCRIPTION="Advanced version control system"
-HOMEPAGE="http://subversion.tigris.org/"
-SRC_URI="http://subversion.tigris.org/downloads/${P/_/-}.tar.bz2"
-
-LICENSE="Subversion"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="apache2 berkdb debug doc +dso emacs extras java nls perl python ruby sasl vim-syntax +webdav-neon webdav-serf"
-RESTRICT="test"
-
-CDEPEND=">=dev-libs/apr-1.2.8
-	>=dev-libs/apr-util-1.2.8
-	dev-libs/expat
-	sys-libs/zlib
-	berkdb? ( =sys-libs/db-4* )
-	emacs? ( virtual/emacs )
-	ruby? ( >=dev-lang/ruby-1.8.2 )
-	sasl? ( dev-libs/cyrus-sasl )
-	webdav-neon? ( >=net-misc/neon-0.28 )
-	webdav-serf? ( net-libs/serf )"
-
-RDEPEND="${CDEPEND}
-	java? ( >=virtual/jre-1.5 )
-	nls? ( virtual/libintl )
-	perl? ( dev-perl/URI )"
-
-DEPEND="${CDEPEND}
-	doc? ( app-doc/doxygen )
-	java? ( >=virtual/jdk-1.5 )
-	nls? ( sys-devel/gettext )"
-
-want_apache
-
-S="${WORKDIR}"/${P/_/-}
-
-# Allow for custom repository locations.
-# This can't be in pkg_setup because the variable needs to be available to
-# pkg_config.
-: ${SVN_REPOS_LOC:=/var/svn}
-
-pkg_setup() {
-	confutils_use_depend_built_with_all berkdb dev-libs/apr-util berkdb
-	java-pkg-opt-2_pkg_setup
-
-	if ! use webdav-neon && ! use webdav-serf; then
-		ewarn
-		ewarn "WebDAV support is disabled. You need WebDAV to"
-		ewarn "access repositories through the HTTP protocol."
-		ewarn
-		ewarn "WebDAV support needs one of the following USE flags enabled:"
-		ewarn "  webdav-neon webdav-serf"
-		ewarn
-		ewarn "You can do this by enabling one of these flags in /etc/portage/package.use:"
-		ewarn "    =${CATEGORY}/${PF} webdav-neon webdav-serf"
-		ewarn
-		ebeep
-	fi
-}
-
-src_unpack() {
-	unpack ${A}
-	cd "${S}"
-
-	epatch "${FILESDIR}"/1.5.0/disable-unneeded-linking.patch
-
-	sed -i \
-		-e "s/\(BUILD_RULES=.*\) bdb-test\(.*\)/\1\2/g" \
-		-e "s/\(BUILD_RULES=.*\) test\(.*\)/\1\2/g" configure.ac
-
-	sed -e 's:@bindir@/svn-contrib:@libdir@/subversion/bin:' \
-		-e 's:@bindir@/svn-tools:@libdir@/subversion/bin:' \
-		-i Makefile.in
-
-	eautoconf
-	elibtoolize
-}
-
-src_compile() {
-	local myconf
-
-	if use python || use perl || use ruby; then
-		myconf="${myconf} --with-swig"
-	else
-		myconf="${myconf} --without-swig"
-	fi
-
-	if use debug; then
-		append-cppflags -DSVN_DEBUG -DAP_DEBUG
-	fi
-
-	append-flags -fno-strict-aliasing
-
-	econf ${myconf} \
-		$(use_with apache2 apxs "${APXS}") \
-		$(use_with berkdb berkeley-db) \
-		$(use_enable dso runtime-module-search) \
-		$(use_enable java javahl) \
-		$(use_with java jdk "${JAVA_HOME}") \
-		$(use_enable nls) \
-		$(use_with sasl) \
-		$(use_with webdav-neon neon /usr) \
-		$(use_with webdav-serf serf /usr) \
-		--with-apr=/usr/bin/apr-1-config \
-		--with-apr-util=/usr/bin/apu-1-config \
-		--disable-experimental-libtool \
-		--without-jikes \
-		--without-junit \
-		--disable-mod-activation
-
-	emake local-all || die "Building of core Subversion failed"
-
-	if use python; then
-		emake swig-py || die "Building of Subversion Python bindings failed"
-	fi
-
-	if use perl; then
-		emake -j1 swig-pl || die "Building of Subversion Perl bindings failed"
-	fi
-
-	if use ruby; then
-		emake swig-rb || die "Building of Subversion Ruby bindings failed"
-	fi
-
-	if use java; then
-		make JAVAC_FLAGS="$(java-pkg_javac-args) -encoding iso8859-1" javahl \
-			|| die "Building of Subversion JavaHL library failed"
-	fi
-
-	if use emacs; then
-		elisp-compile contrib/client-side/emacs/{dsvn,psvn,vc-svn}.el \
-			doc/svn-doc.el doc/tools/svnbook.el \
-			|| die "Compilation of Emacs modules failed"
-	fi
-
-	if use extras; then
-		emake contrib || die "Building of contrib failed"
-		emake tools || die "Building of tools failed"
-	fi
-
-	if use doc; then
-		doxygen doc/doxygen.conf || die "Building of Subversion HTML documentation failed"
-
-		if use java; then
-			emake doc-javahl || die "Building of Subversion JavaHL library HTML documentation failed"
-		fi
-	fi
-}
-
-src_install() {
-	python_version
-	PYTHON_DIR=/usr/$(get_libdir)/python${PYVER}
-
-	emake -j1 DESTDIR="${D}" local-install || die "Installation of core of Subversion failed"
-
-	if use python; then
-		emake -j1 DESTDIR="${D}" DISTUTIL_PARAM="--prefix=${D}" LD_LIBRARY_PATH="-L${D}/usr/$(get_libdir)" install-swig-py \
-			|| die "Installation of Subversion Python bindings failed"
-
-		# Move Python bindings.
-		dodir "${PYTHON_DIR}/site-packages"
-		mv "${D}"/usr/$(get_libdir)/svn-python/svn "${D}${PYTHON_DIR}/site-packages"
-		mv "${D}"/usr/$(get_libdir)/svn-python/libsvn "${D}${PYTHON_DIR}/site-packages"
-		rm -Rf "${D}"/usr/$(get_libdir)/svn-python
-	fi
-
-	if use perl; then
-		emake -j1 DESTDIR="${D}" INSTALLDIRS="vendor" install-swig-pl || die "Installation of Subversion Perl bindings failed"
-		fixlocalpod
-	fi
-
-	if use ruby; then
-		emake -j1 DESTDIR="${D}" install-swig-rb || die "Installation of Subversion Ruby bindings failed"
-	fi
-
-	if use java; then
-		emake -j1 DESTDIR="${D}" install-javahl || die "Installation of Subversion JavaHL library failed"
-		java-pkg_regso "${D}"/usr/$(get_libdir)/libsvnjavahl*.so
-		java-pkg_dojar "${D}"/usr/$(get_libdir)/svn-javahl/svn-javahl.jar
-		rm -Rf "${D}"/usr/$(get_libdir)/svn-javahl/*.jar
-	fi
-
-	# Install Apache module configuration.
-	if use apache2; then
-		dodir "${APACHE_MODULES_CONFDIR}"
-		cat <<EOF >"${D}/${APACHE_MODULES_CONFDIR}"/47_mod_dav_svn.conf
-<IfDefine SVN>
-LoadModule dav_svn_module modules/mod_dav_svn.so
-<IfDefine SVN_AUTHZ>
-LoadModule authz_svn_module modules/mod_authz_svn.so
-</IfDefine>
-
-# Example configuration:
-#<Location /svn/repos>
-#	DAV svn
-#	SVNPath ${SVN_REPOS_LOC}/repos
-#	AuthType Basic
-#	AuthName "Subversion repository"
-#	AuthUserFile ${SVN_REPOS_LOC}/conf/svnusers
-#	Require valid-user
-#</Location>
-</IfDefine>
-EOF
-	fi
-
-	# Install Bash Completion, bug 43179.
-	dobashcompletion tools/client-side/bash_completion subversion
-	rm -f tools/client-side/bash_completion
-
-	# Install hot backup script, bug 54304.
-	newbin tools/backup/hot-backup.py svn-hot-backup
-	rm -fr tools/backup
-
-	# Install svn_load_dirs.pl.
-	if use perl; then
-		newbin contrib/client-side/svn_load_dirs/svn_load_dirs.pl svn-load-dirs
-	fi
-	rm -f contrib/client-side/svn_load_dirs/svn_load_dirs.pl
-
-	# Install svnserve init-script and xinet.d snippet, bug 43245.
-	newinitd "${FILESDIR}"/svnserve.initd svnserve
-	if use apache2; then
-		newconfd "${FILESDIR}"/svnserve.confd svnserve
-	else
-		newconfd "${FILESDIR}"/svnserve.confd2 svnserve
-	fi
-	insinto /etc/xinetd.d
-	newins "${FILESDIR}"/svnserve.xinetd svnserve
-
-	# Install documentation.
-	dodoc CHANGES COMMITTERS README
-	dohtml www/hacking.html
-	dodoc tools/xslt/svnindex.{css,xsl}
-	rm -fr tools/xslt
-
-	# Install Vim syntax files.
-	if use vim-syntax; then
-		insinto /usr/share/vim/vimfiles/syntax
-		doins contrib/client-side/vim/svn.vim
-	fi
-	rm -f contrib/client-side/vim/svn.vim
-
-	# Install Emacs Lisps.
-	if use emacs; then
-		elisp-install ${PN} contrib/client-side/emacs/{dsvn,psvn}.{el,elc} \
-			doc/svn-doc.{el,elc} doc/tools/svnbook.{el,elc} \
-			|| die "Installation of Emacs modules failed"
-		elisp-install ${PN}/compat contrib/client-side/emacs/vc-svn.{el,elc} \
-			|| die "Installation of Emacs modules failed"
-		touch "${D}${SITELISP}/${PN}/compat/.nosearch"
-		elisp-site-file-install "${FILESDIR}"/1.5.0/70svn-gentoo.el \
-			|| die "Installation of Emacs site-init file failed"
-	fi
-	rm -fr contrib/client-side/emacs
-
-	# Install extra files.
-	if use extras; then
-		doenvd "${FILESDIR}"/1.5.0/80subversion-extras
-
-		emake DESTDIR="${D}" install-contrib || die "Installation of contrib failed"
-		emake DESTDIR="${D}" install-tools || die "Installation of tools failed"
-
-		find contrib tools '(' -name "*.bat" -o -name "*.in" -o -name ".libs" ')' -print0 | xargs -0 rm -fr
-		rm -fr contrib/client-side/{svn-push,svnmucc}
-		rm -fr tools/server-side/{svn-populate-node-origins-index,svnauthz-validate}*
-		rm -fr tools/{buildbot,dev,diff,po}
-
-		insinto /usr/share/${PN}
-		doins -r contrib tools
-	fi
-
-	if use doc; then
-		dohtml doc/doxygen/html/*
-
-		insinto /usr/share/doc/${PF}
-		doins -r notes
-		ecompressdir /usr/share/doc/${PF}/notes
-
-		if use java; then
-			java-pkg_dojavadoc doc/javadoc
-		fi
-	fi
-}
-
-pkg_preinst() {
-	# Compare versions of Berkeley DB, bug 122877.
-	if use berkdb && [[ -f "${ROOT}usr/bin/svn" ]] ; then
-		OLD_BDB_VERSION="$(scanelf -nq "${ROOT}usr/$(get_libdir)/libsvn_subr-1.so.0" | grep -Eo "libdb-[[:digit:]]+\.[[:digit:]]+" | sed -e "s/libdb-\(.*\)/\1/")"
-		NEW_BDB_VERSION="$(scanelf -nq "${D}usr/$(get_libdir)/libsvn_subr-1.so.0" | grep -Eo "libdb-[[:digit:]]+\.[[:digit:]]+" | sed -e "s/libdb-\(.*\)/\1/")"
-		if [[ "${OLD_BDB_VERSION}" != "${NEW_BDB_VERSION}" ]] ; then
-			CHANGED_BDB_VERSION=1
-		fi
-	fi
-}
-
-pkg_postinst() {
-	use emacs && elisp-site-regen
-	use perl && perl-module_pkg_postinst
-
-	elog "Subversion Server Notes"
-	elog "-----------------------"
-	elog
-	elog "If you intend to run a server, a repository needs to be created using"
-	elog "svnadmin (see man svnadmin) or the following command to create it in"
-	elog "${SVN_REPOS_LOC}:"
-	elog
-	elog "    emerge --config =${CATEGORY}/${PF}"
-	elog
-	elog "Subversion has multiple server types, take your pick:"
-	elog
-	elog " - svnserve daemon: "
-	elog "   1. Edit /etc/conf.d/svnserve"
-	elog "   2. Fix the repository permissions (see \"Fixing the repository permissions\")"
-	elog "   3. Start daemon: /etc/init.d/svnserve start"
-	elog "   4. Make persistent: rc-update add svnserve default"
-	elog
-	elog " - svnserve via xinetd:"
-	elog "   1. Edit /etc/xinetd.d/svnserve (remove disable line)"
-	elog "   2. Fix the repository permissions (see \"Fixing the repository permissions\")"
-	elog "   3. Restart xinetd.d: /etc/init.d/xinetd restart"
-	elog
-	elog " - svn over ssh:"
-	elog "   1. Fix the repository permissions (see \"Fixing the repository permissions\")"
-	elog "      Additionally run:"
-	elog "        groupadd svnusers"
-	elog "        chown -R root:svnusers ${SVN_REPOS_LOC}/repos"
-	elog "   2. Create an svnserve wrapper in /usr/local/bin to set the umask you"
-	elog "      want, for example:"
-	elog "         #!/bin/bash"
-	elog "         . /etc/conf.d/svnserve"
-	elog "         umask 007"
-	elog "         exec /usr/bin/svnserve \${SVNSERVE_OPTS} \"\$@\""
-	elog
-
-	if use apache2; then
-		elog " - http-based server:"
-		elog "   1. Edit /etc/conf.d/apache2 to include both \"-D DAV\" and \"-D SVN\""
-		elog "   2. Create an htpasswd file:"
-		elog "      htpasswd2 -m -c ${SVN_REPOS_LOC}/conf/svnusers USERNAME"
-		elog "   3. Fix the repository permissions (see \"Fixing the repository permissions\")"
-		elog "   4. Restart Apache: /etc/init.d/apache2 restart"
-		elog
-	fi
-
-	elog "   Fixing the repository permissions:"
-	elog "        chmod -Rf go-rwx ${SVN_REPOS_LOC}/conf"
-	elog "        chmod -Rf g-w,o-rwx ${SVN_REPOS_LOC}/repos"
-	elog "        chmod -Rf g+rw ${SVN_REPOS_LOC}/repos/db"
-	elog "        chmod -Rf g+rw ${SVN_REPOS_LOC}/repos/locks"
-	elog
-
-	elog "If you intend to use svn-hot-backup, you can specify the number of"
-	elog "backups to keep per repository by specifying an environment variable."
-	elog "If you want to keep e.g. 2 backups, do the following:"
-	elog "echo '# hot-backup: Keep that many repository backups around' > /etc/env.d/80subversion"
-	elog "echo 'SVN_HOTBACKUP_BACKUPS_NUMBER=2' >> /etc/env.d/80subversion"
-	elog
-
-	if [[ -n "${CHANGED_BDB_VERSION}" ]] ; then
-		ewarn "You upgraded from an older version of Berkeley DB and may experience"
-		ewarn "problems with your repository. Run the following commands as root to fix it:"
-		ewarn "    db4_recover -h ${SVN_REPOS_LOC}/repos"
-		ewarn "    chown -Rf apache:apache ${SVN_REPOS_LOC}/repos"
-	fi
-}
-
-pkg_postrm() {
-	use emacs && elisp-site-regen
-	use perl && perl-module_pkg_postrm
-}
-
-pkg_config() {
-	if [[ ! -x "${ROOT}usr/bin/svnadmin" ]] ; then
-		die "You seem to only have built the Subversion client"
-	fi
-
-	einfo ">>> Initializing the database in ${ROOT}${SVN_REPOS_LOC} ..."
-	if [[ -e "${ROOT}${SVN_REPOS_LOC}/repos" ]] ; then
-		echo "A Subversion repository already exists and I will not overwrite it."
-		echo "Delete \"${ROOT}${SVN_REPOS_LOC}/repos\" first if you're sure you want to have a clean version."
-	else
-		mkdir -p "${ROOT}${SVN_REPOS_LOC}/conf"
-
-		einfo ">>> Populating repository directory ..."
-		# Create initial repository.
-		"${ROOT}usr/bin/svnadmin" create "${ROOT}${SVN_REPOS_LOC}/repos"
-
-		einfo ">>> Setting repository permissions ..."
-		SVNSERVE_USER="$(. "${ROOT}etc/conf.d/svnserve" ; echo "${SVNSERVE_USER}")"
-		SVNSERVE_GROUP="$(. "${ROOT}etc/conf.d/svnserve" ; echo "${SVNSERVE_GROUP}")"
-		if use apache2 ; then
-			[[ -z "${SVNSERVE_USER}" ]] && SVNSERVE_USER="apache"
-			[[ -z "${SVNSERVE_GROUP}" ]] && SVNSERVE_GROUP="apache"
-		else
-			[[ -z "${SVNSERVE_USER}" ]] && SVNSERVE_USER="svn"
-			[[ -z "${SVNSERVE_GROUP}" ]] && SVNSERVE_GROUP="svnusers"
-			enewgroup "${SVNSERVE_GROUP}"
-			enewuser "${SVNSERVE_USER}" -1 -1 "${SVN_REPOS_LOC}" "${SVNSERVE_GROUP}"
-		fi
-		chown -Rf "${SVNSERVE_USER}:${SVNSERVE_GROUP}" "${ROOT}${SVN_REPOS_LOC}/repos"
-		chmod -Rf go-rwx "${ROOT}${SVN_REPOS_LOC}/conf"
-		chmod -Rf o-rwx "${ROOT}${SVN_REPOS_LOC}/repos"
-	fi
-}
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-util/subversion/subversion-1.5.6.ebuild	Sat Feb 28 20:20:36 2009 +0100
@@ -0,0 +1,412 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/subversion-1.5.4.ebuild,v 1.11 2008/12/07 12:13:48 vapier Exp $
+
+EAPI="1"
+WANT_AUTOMAKE="none"
+
+inherit autotools bash-completion confutils depend.apache elisp-common eutils flag-o-matic java-pkg-opt-2 libtool multilib perl-module python
+
+DESCRIPTION="Advanced version control system"
+HOMEPAGE="http://subversion.tigris.org/"
+SRC_URI="http://subversion.tigris.org/downloads/${P/_/-}.tar.bz2"
+
+LICENSE="Subversion"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
+IUSE="apache2 berkdb debug doc +dso emacs extras java nls perl python ruby sasl vim-syntax +webdav-neon webdav-serf"
+RESTRICT="test"
+
+CDEPEND=">=dev-libs/apr-1.2.8
+	>=dev-libs/apr-util-1.2.8
+	dev-libs/expat
+	sys-libs/zlib
+	berkdb? ( =sys-libs/db-4* )
+	emacs? ( virtual/emacs )
+	ruby? ( >=dev-lang/ruby-1.8.2 )
+	sasl? ( dev-libs/cyrus-sasl )
+	webdav-neon? ( >=net-misc/neon-0.28 )
+	webdav-serf? ( net-libs/serf )"
+
+RDEPEND="${CDEPEND}
+	java? ( >=virtual/jre-1.5 )
+	nls? ( virtual/libintl )
+	perl? ( dev-perl/URI )"
+
+DEPEND="${CDEPEND}
+	doc? ( app-doc/doxygen )
+	java? ( >=virtual/jdk-1.5 )
+	nls? ( sys-devel/gettext )"
+
+want_apache
+
+S="${WORKDIR}"/${P/_/-}
+
+# Allow for custom repository locations.
+# This can't be in pkg_setup because the variable needs to be available to
+# pkg_config.
+: ${SVN_REPOS_LOC:=/var/svn}
+
+pkg_setup() {
+	confutils_use_depend_built_with_all berkdb dev-libs/apr-util berkdb
+	java-pkg-opt-2_pkg_setup
+
+	if ! use webdav-neon && ! use webdav-serf; then
+		ewarn
+		ewarn "WebDAV support is disabled. You need WebDAV to"
+		ewarn "access repositories through the HTTP protocol."
+		ewarn
+		ewarn "WebDAV support needs one of the following USE flags enabled:"
+		ewarn "  webdav-neon webdav-serf"
+		ewarn
+		ewarn "You can do this by enabling one of these flags in /etc/portage/package.use:"
+		ewarn "    =${CATEGORY}/${PF} webdav-neon webdav-serf"
+		ewarn
+		ebeep
+	fi
+}
+
+src_unpack() {
+	unpack ${A}
+	cd "${S}"
+
+	epatch "${FILESDIR}"/1.5.0/disable-unneeded-linking.patch
+
+	sed -i \
+		-e "s/\(BUILD_RULES=.*\) bdb-test\(.*\)/\1\2/g" \
+		-e "s/\(BUILD_RULES=.*\) test\(.*\)/\1\2/g" configure.ac
+
+	sed -e 's:@bindir@/svn-contrib:@libdir@/subversion/bin:' \
+		-e 's:@bindir@/svn-tools:@libdir@/subversion/bin:' \
+		-i Makefile.in
+
+	eautoconf
+	elibtoolize
+}
+
+src_compile() {
+	local myconf
+
+	if use python || use perl || use ruby; then
+		myconf="${myconf} --with-swig"
+	else
+		myconf="${myconf} --without-swig"
+	fi
+
+	if use debug; then
+		append-cppflags -DSVN_DEBUG -DAP_DEBUG
+	fi
+
+	append-flags -fno-strict-aliasing
+
+	econf ${myconf} \
+		$(use_with apache2 apxs "${APXS}") \
+		$(use_with berkdb berkeley-db) \
+		$(use_enable dso runtime-module-search) \
+		$(use_enable java javahl) \
+		$(use_with java jdk "${JAVA_HOME}") \
+		$(use_enable nls) \
+		$(use_with sasl) \
+		$(use_with webdav-neon neon /usr) \
+		$(use_with webdav-serf serf /usr) \
+		--with-apr=/usr/bin/apr-1-config \
+		--with-apr-util=/usr/bin/apu-1-config \
+		--disable-experimental-libtool \
+		--without-jikes \
+		--without-junit \
+		--disable-mod-activation
+
+	emake local-all || die "Building of core Subversion failed"
+
+	if use python; then
+		emake swig-py || die "Building of Subversion Python bindings failed"
+	fi
+
+	if use perl; then
+		emake -j1 swig-pl || die "Building of Subversion Perl bindings failed"
+	fi
+
+	if use ruby; then
+		emake swig-rb || die "Building of Subversion Ruby bindings failed"
+	fi
+
+	if use java; then
+		make JAVAC_FLAGS="$(java-pkg_javac-args) -encoding iso8859-1" javahl \
+			|| die "Building of Subversion JavaHL library failed"
+	fi
+
+	if use emacs; then
+		elisp-compile contrib/client-side/emacs/{dsvn,psvn,vc-svn}.el \
+			doc/svn-doc.el doc/tools/svnbook.el \
+			|| die "Compilation of Emacs modules failed"
+	fi
+
+	if use extras; then
+		emake contrib || die "Building of contrib failed"
+		emake tools || die "Building of tools failed"
+	fi
+
+	if use doc; then
+		doxygen doc/doxygen.conf || die "Building of Subversion HTML documentation failed"
+
+		if use java; then
+			emake doc-javahl || die "Building of Subversion JavaHL library HTML documentation failed"
+		fi
+	fi
+}
+
+src_install() {
+	python_version
+	PYTHON_DIR=/usr/$(get_libdir)/python${PYVER}
+
+	emake -j1 DESTDIR="${D}" local-install || die "Installation of core of Subversion failed"
+
+	if use python; then
+		emake -j1 DESTDIR="${D}" DISTUTIL_PARAM="--prefix=${D}" LD_LIBRARY_PATH="-L${D}/usr/$(get_libdir)" install-swig-py \
+			|| die "Installation of Subversion Python bindings failed"
+
+		# Move Python bindings.
+		dodir "${PYTHON_DIR}/site-packages"
+		mv "${D}"/usr/$(get_libdir)/svn-python/svn "${D}${PYTHON_DIR}/site-packages"
+		mv "${D}"/usr/$(get_libdir)/svn-python/libsvn "${D}${PYTHON_DIR}/site-packages"
+		rm -Rf "${D}"/usr/$(get_libdir)/svn-python
+	fi
+
+	if use perl; then
+		emake -j1 DESTDIR="${D}" INSTALLDIRS="vendor" install-swig-pl || die "Installation of Subversion Perl bindings failed"
+		fixlocalpod
+	fi
+
+	if use ruby; then
+		emake -j1 DESTDIR="${D}" install-swig-rb || die "Installation of Subversion Ruby bindings failed"
+	fi
+
+	if use java; then
+		emake -j1 DESTDIR="${D}" install-javahl || die "Installation of Subversion JavaHL library failed"
+		java-pkg_regso "${D}"/usr/$(get_libdir)/libsvnjavahl*.so
+		java-pkg_dojar "${D}"/usr/$(get_libdir)/svn-javahl/svn-javahl.jar
+		rm -Rf "${D}"/usr/$(get_libdir)/svn-javahl/*.jar
+	fi
+
+	# Install Apache module configuration.
+	if use apache2; then
+		dodir "${APACHE_MODULES_CONFDIR}"
+		cat <<EOF >"${D}/${APACHE_MODULES_CONFDIR}"/47_mod_dav_svn.conf
+<IfDefine SVN>
+LoadModule dav_svn_module modules/mod_dav_svn.so
+<IfDefine SVN_AUTHZ>
+LoadModule authz_svn_module modules/mod_authz_svn.so
+</IfDefine>
+
+# Example configuration:
+#<Location /svn/repos>
+#	DAV svn
+#	SVNPath ${SVN_REPOS_LOC}/repos
+#	AuthType Basic
+#	AuthName "Subversion repository"
+#	AuthUserFile ${SVN_REPOS_LOC}/conf/svnusers
+#	Require valid-user
+#</Location>
+</IfDefine>
+EOF
+	fi
+
+	# Install Bash Completion, bug 43179.
+	dobashcompletion tools/client-side/bash_completion subversion
+	rm -f tools/client-side/bash_completion
+
+	# Install hot backup script, bug 54304.
+	newbin tools/backup/hot-backup.py svn-hot-backup
+	rm -fr tools/backup
+
+	# Install svn_load_dirs.pl.
+	if use perl; then
+		newbin contrib/client-side/svn_load_dirs/svn_load_dirs.pl svn-load-dirs
+	fi
+	rm -f contrib/client-side/svn_load_dirs/svn_load_dirs.pl
+
+	# Install svnserve init-script and xinet.d snippet, bug 43245.
+	newinitd "${FILESDIR}"/svnserve.initd svnserve
+	if use apache2; then
+		newconfd "${FILESDIR}"/svnserve.confd svnserve
+	else
+		newconfd "${FILESDIR}"/svnserve.confd2 svnserve
+	fi
+	insinto /etc/xinetd.d
+	newins "${FILESDIR}"/svnserve.xinetd svnserve
+
+	# Install documentation.
+	dodoc CHANGES COMMITTERS README
+	dohtml www/hacking.html
+	dodoc tools/xslt/svnindex.{css,xsl}
+	rm -fr tools/xslt
+
+	# Install Vim syntax files.
+	if use vim-syntax; then
+		insinto /usr/share/vim/vimfiles/syntax
+		doins contrib/client-side/vim/svn.vim
+	fi
+	rm -f contrib/client-side/vim/svn.vim
+
+	# Install Emacs Lisps.
+	if use emacs; then
+		elisp-install ${PN} contrib/client-side/emacs/{dsvn,psvn}.{el,elc} \
+			doc/svn-doc.{el,elc} doc/tools/svnbook.{el,elc} \
+			|| die "Installation of Emacs modules failed"
+		elisp-install ${PN}/compat contrib/client-side/emacs/vc-svn.{el,elc} \
+			|| die "Installation of Emacs modules failed"
+		touch "${D}${SITELISP}/${PN}/compat/.nosearch"
+		elisp-site-file-install "${FILESDIR}"/1.5.0/70svn-gentoo.el \
+			|| die "Installation of Emacs site-init file failed"
+	fi
+	rm -fr contrib/client-side/emacs
+
+	# Install extra files.
+	if use extras; then
+		doenvd "${FILESDIR}"/1.5.0/80subversion-extras
+
+		emake DESTDIR="${D}" install-contrib || die "Installation of contrib failed"
+		emake DESTDIR="${D}" install-tools || die "Installation of tools failed"
+
+		find contrib tools '(' -name "*.bat" -o -name "*.in" -o -name ".libs" ')' -print0 | xargs -0 rm -fr
+		rm -fr contrib/client-side/{svn-push,svnmucc}
+		rm -fr tools/server-side/{svn-populate-node-origins-index,svnauthz-validate}*
+		rm -fr tools/{buildbot,dev,diff,po}
+
+		insinto /usr/share/${PN}
+		doins -r contrib tools
+	fi
+
+	if use doc; then
+		dohtml doc/doxygen/html/*
+
+		insinto /usr/share/doc/${PF}
+		doins -r notes
+		ecompressdir /usr/share/doc/${PF}/notes
+
+		if use java; then
+			java-pkg_dojavadoc doc/javadoc
+		fi
+	fi
+}
+
+pkg_preinst() {
+	# Compare versions of Berkeley DB, bug 122877.
+	if use berkdb && [[ -f "${ROOT}usr/bin/svn" ]] ; then
+		OLD_BDB_VERSION="$(scanelf -nq "${ROOT}usr/$(get_libdir)/libsvn_subr-1.so.0" | grep -Eo "libdb-[[:digit:]]+\.[[:digit:]]+" | sed -e "s/libdb-\(.*\)/\1/")"
+		NEW_BDB_VERSION="$(scanelf -nq "${D}usr/$(get_libdir)/libsvn_subr-1.so.0" | grep -Eo "libdb-[[:digit:]]+\.[[:digit:]]+" | sed -e "s/libdb-\(.*\)/\1/")"
+		if [[ "${OLD_BDB_VERSION}" != "${NEW_BDB_VERSION}" ]] ; then
+			CHANGED_BDB_VERSION=1
+		fi
+	fi
+}
+
+pkg_postinst() {
+	use emacs && elisp-site-regen
+	use perl && perl-module_pkg_postinst
+
+	elog "Subversion Server Notes"
+	elog "-----------------------"
+	elog
+	elog "If you intend to run a server, a repository needs to be created using"
+	elog "svnadmin (see man svnadmin) or the following command to create it in"
+	elog "${SVN_REPOS_LOC}:"
+	elog
+	elog "    emerge --config =${CATEGORY}/${PF}"
+	elog
+	elog "Subversion has multiple server types, take your pick:"
+	elog
+	elog " - svnserve daemon: "
+	elog "   1. Edit /etc/conf.d/svnserve"
+	elog "   2. Fix the repository permissions (see \"Fixing the repository permissions\")"
+	elog "   3. Start daemon: /etc/init.d/svnserve start"
+	elog "   4. Make persistent: rc-update add svnserve default"
+	elog
+	elog " - svnserve via xinetd:"
+	elog "   1. Edit /etc/xinetd.d/svnserve (remove disable line)"
+	elog "   2. Fix the repository permissions (see \"Fixing the repository permissions\")"
+	elog "   3. Restart xinetd.d: /etc/init.d/xinetd restart"
+	elog
+	elog " - svn over ssh:"
+	elog "   1. Fix the repository permissions (see \"Fixing the repository permissions\")"
+	elog "      Additionally run:"
+	elog "        groupadd svnusers"
+	elog "        chown -R root:svnusers ${SVN_REPOS_LOC}/repos"
+	elog "   2. Create an svnserve wrapper in /usr/local/bin to set the umask you"
+	elog "      want, for example:"
+	elog "         #!/bin/bash"
+	elog "         . /etc/conf.d/svnserve"
+	elog "         umask 007"
+	elog "         exec /usr/bin/svnserve \${SVNSERVE_OPTS} \"\$@\""
+	elog
+
+	if use apache2; then
+		elog " - http-based server:"
+		elog "   1. Edit /etc/conf.d/apache2 to include both \"-D DAV\" and \"-D SVN\""
+		elog "   2. Create an htpasswd file:"
+		elog "      htpasswd2 -m -c ${SVN_REPOS_LOC}/conf/svnusers USERNAME"
+		elog "   3. Fix the repository permissions (see \"Fixing the repository permissions\")"
+		elog "   4. Restart Apache: /etc/init.d/apache2 restart"
+		elog
+	fi
+
+	elog "   Fixing the repository permissions:"
+	elog "        chmod -Rf go-rwx ${SVN_REPOS_LOC}/conf"
+	elog "        chmod -Rf g-w,o-rwx ${SVN_REPOS_LOC}/repos"
+	elog "        chmod -Rf g+rw ${SVN_REPOS_LOC}/repos/db"
+	elog "        chmod -Rf g+rw ${SVN_REPOS_LOC}/repos/locks"
+	elog
+
+	elog "If you intend to use svn-hot-backup, you can specify the number of"
+	elog "backups to keep per repository by specifying an environment variable."
+	elog "If you want to keep e.g. 2 backups, do the following:"
+	elog "echo '# hot-backup: Keep that many repository backups around' > /etc/env.d/80subversion"
+	elog "echo 'SVN_HOTBACKUP_BACKUPS_NUMBER=2' >> /etc/env.d/80subversion"
+	elog
+
+	if [[ -n "${CHANGED_BDB_VERSION}" ]] ; then
+		ewarn "You upgraded from an older version of Berkeley DB and may experience"
+		ewarn "problems with your repository. Run the following commands as root to fix it:"
+		ewarn "    db4_recover -h ${SVN_REPOS_LOC}/repos"
+		ewarn "    chown -Rf apache:apache ${SVN_REPOS_LOC}/repos"
+	fi
+}
+
+pkg_postrm() {
+	use emacs && elisp-site-regen
+	use perl && perl-module_pkg_postrm
+}
+
+pkg_config() {
+	if [[ ! -x "${ROOT}usr/bin/svnadmin" ]] ; then
+		die "You seem to only have built the Subversion client"
+	fi
+
+	einfo ">>> Initializing the database in ${ROOT}${SVN_REPOS_LOC} ..."
+	if [[ -e "${ROOT}${SVN_REPOS_LOC}/repos" ]] ; then
+		echo "A Subversion repository already exists and I will not overwrite it."
+		echo "Delete \"${ROOT}${SVN_REPOS_LOC}/repos\" first if you're sure you want to have a clean version."
+	else
+		mkdir -p "${ROOT}${SVN_REPOS_LOC}/conf"
+
+		einfo ">>> Populating repository directory ..."
+		# Create initial repository.
+		"${ROOT}usr/bin/svnadmin" create "${ROOT}${SVN_REPOS_LOC}/repos"
+
+		einfo ">>> Setting repository permissions ..."
+		SVNSERVE_USER="$(. "${ROOT}etc/conf.d/svnserve" ; echo "${SVNSERVE_USER}")"
+		SVNSERVE_GROUP="$(. "${ROOT}etc/conf.d/svnserve" ; echo "${SVNSERVE_GROUP}")"
+		if use apache2 ; then
+			[[ -z "${SVNSERVE_USER}" ]] && SVNSERVE_USER="apache"
+			[[ -z "${SVNSERVE_GROUP}" ]] && SVNSERVE_GROUP="apache"
+		else
+			[[ -z "${SVNSERVE_USER}" ]] && SVNSERVE_USER="svn"
+			[[ -z "${SVNSERVE_GROUP}" ]] && SVNSERVE_GROUP="svnusers"
+			enewgroup "${SVNSERVE_GROUP}"
+			enewuser "${SVNSERVE_USER}" -1 -1 "${SVN_REPOS_LOC}" "${SVNSERVE_GROUP}"
+		fi
+		chown -Rf "${SVNSERVE_USER}:${SVNSERVE_GROUP}" "${ROOT}${SVN_REPOS_LOC}/repos"
+		chmod -Rf go-rwx "${ROOT}${SVN_REPOS_LOC}/conf"
+		chmod -Rf o-rwx "${ROOT}${SVN_REPOS_LOC}/repos"
+	fi
+}