changeset 61:efdeddd494e9

pull changes from holgi
author Dirk Olmes <dirk@xanthippe.ping.de>
date Fri, 15 Aug 2008 17:26:54 +0200
parents 4cd1ebbb3297 (current diff) acd741f300f7 (diff)
children c23727376abb
files
diffstat 2 files changed, 25 insertions(+), 154 deletions(-) [+]
line wrap: on
line diff
--- a/net-misc/rabbitmq-server/Manifest	Sun Aug 10 01:32:42 2008 +0200
+++ b/net-misc/rabbitmq-server/Manifest	Fri Aug 15 17:26:54 2008 +0200
@@ -1,2 +1,2 @@
 DIST rabbitmq-server-generic-unix-1.4.0.tar.gz 394991 RMD160 f3ced06ec6f8ced09a9e0f5c60f0b73954ea8634 SHA1 bea27fa2255324f13e343ed82c50e69c6983628a SHA256 642ffe9cdca8ac5bd030647d24d60cca388df20f1d6a5913c3a2ae036f75018e
-EBUILD rabbitmq-server-1.4.0.ebuild 7680 RMD160 d66d21153bdef80641510d118ae3948c088e67e0 SHA1 4888a5cad90ee282817dd0e134b4dc4d4e858ef7 SHA256 db327700e6d7d348cfa19c1f595822bc19b694f1416bb9144661cd23d87c79ba
+EBUILD rabbitmq-server-1.4.0.ebuild 1066 RMD160 98d1bc0fa46375677176adcd9bcc58c6eb032b60 SHA1 b4f135e52539a267c105cda6199207850ce9ed7c SHA256 15693e4118e305c5e0c8437db3dd1bdd0a427fe5e917e9f3e0a18606931561e4
--- a/net-misc/rabbitmq-server/rabbitmq-server-1.4.0.ebuild	Sun Aug 10 01:32:42 2008 +0200
+++ b/net-misc/rabbitmq-server/rabbitmq-server-1.4.0.ebuild	Fri Aug 15 17:26:54 2008 +0200
@@ -2,168 +2,39 @@
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
-# NOTE: The comments in this file are for instruction and documentation.
-# They're not meant to appear with your final, production ebuild.  Please
-# remember to remove them before submitting or committing your ebuild.  That
-# doesn't mean you can't add your own comments though.
-
-# The 'Header' on the third line should just be left alone.  When your ebuild
-# will be committed to cvs, the details on that line will be automatically
-# generated to contain the correct data.
-
-# The EAPI variable tells the ebuild format in use.
-# Defaults to 0 if not specified. The current PMS draft contains details on
-# a proposed EAPI=0 definition but is not finalized yet.
-# Eclasses will test for this variable if they need to use EAPI > 0 features.
-# Ebuilds should not define EAPI > 0 unless they absolutely need to use
-# features added in that version.
-#EAPI=0
-
-# inherit lists eclasses to inherit functions from. Almost all ebuilds should
-# inherit eutils, as a large amount of important functionality has been
-# moved there. For example, the $(get_libdir) mentioned below wont work
-# without the following line:
 inherit eutils
-# A well-used example of an eclass function that needs eutils is epatch. If
-# your source needs patches applied, it's suggested to put your patch in the
-# 'files' directory and use:
-#
-#   epatch ${FILESDIR}/patch-name-here
-#
-# eclasses tend to list descriptions of how to use their functions properly.
-# take a look at /usr/portage/eclasses/ for more examples.
-
-# Short one-line description of this package.
-DESCRIPTION="RabbitMQ is a high-performance AMQP-compliant message broker written in Erlang."
-
-# Homepage, not used by Portage directly but handy for developer reference
-HOMEPAGE="http://www.rabbitmq.com/"
-
-# Point to any required sources; these will be automatically downloaded by
-# Portage.
-SRC_URI="http://www.rabbitmq.com/releases/rabbitmq-server/v${PV}/rabbitmq-server-generic-unix-${PV}.tar.gz"
-
-# License of the package.  This must match the name of file(s) in
-# /usr/portage/licenses/.  For complex license combination see the developer
-# docs on gentoo.org for details.
-LICENSE="MPL"
 
-# The SLOT variable is used to tell Portage if it's OK to keep multiple
-# versions of the same package installed at the same time.  For example,
-# if we have a libfoo-1.2.2 and libfoo-1.3.2 (which is not compatible
-# with 1.2.2), it would be optimal to instruct Portage to not remove
-# libfoo-1.2.2 if we decide to upgrade to libfoo-1.3.2.  To do this,
-# we specify SLOT="1.2" in libfoo-1.2.2 and SLOT="1.3" in libfoo-1.3.2.
-# emerge clean understands SLOTs, and will keep the most recent version
-# of each SLOT and remove everything else.
-# Note that normal applications should use SLOT="0" if possible, since
-# there should only be exactly one version installed at a time.
-# DO NOT USE SLOT=""! This tells Portage to disable SLOTs for this package.
-SLOT="0"
-
-# Using KEYWORDS, we can record masking information *inside* an ebuild
-# instead of relying on an external package.mask file.  Right now, you should
-# set the KEYWORDS variable for every ebuild so that it contains the names of
-# all the architectures with which the ebuild works.  All of the official
-# architectures can be found in the keywords.desc file which is in
-# /usr/portage/profiles/.  Usually you should just set this to "~x86".  The ~
-# in front of the architecture indicates that the package is new and should be
-# considered unstable until testing proves its stability.  So, if you've
-# confirmed that your ebuild works on x86 and ppc, you'd specify:
-# KEYWORDS="~x86 ~ppc"
-# Once packages go stable, the ~ prefix is removed.
-# For binary packages, use -* and then list the archs the bin package
-# exists for.  If the package was for an x86 binary package, then
-# KEYWORDS would be set like this: KEYWORDS="-* x86"
-# DO NOT USE KEYWORDS="*".  This is deprecated and only for backward
-# compatibility reasons.
-KEYWORDS="~x86"
-
-# Comprehensive list of any and all USE flags leveraged in the ebuild,
-# with the exception of any ARCH specific flags, i.e. "ppc", "sparc",
-# "x86" and "alpha".  This is a required variable.  If the ebuild doesn't
-# use any USE flags, set to "".
+DESCRIPTION="RabbitMQ is a high-performance AMQP-compliant message broker written in Erlang."
+HOMEPAGE="http://www.rabbitmq.com/" 
+SRC_URI="http://www.rabbitmq.com/releases/rabbitmq-server/v${PV}/rabbitmq-server-generic-unix-${PV}.tar.gz"
+LICENSE="MPL"
+SLOT="0" 
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
 IUSE=""
-
-# A space delimited list of portage features to restrict. man 5 ebuild
-# for details.  Usually not needed.
-#RESTRICT="strip"
-
-# Build-time dependencies, such as
-#    ssl? ( >=dev-libs/openssl-0.9.6b )
-#    >=dev-lang/perl-5.6.1-r1
-# It is advisable to use the >= syntax show above, to reflect what you
-# had installed on your system when you tested the package.  Then
-# other users hopefully won't be caught without the right version of
-# a dependency.
+ 
+# Q: is RDEPEND-only sufficient for a binary package, since we don't compile?
 DEPEND="dev-lang/erlang"
-
-# Run-time dependencies. Must be defined to whatever this depends on to run.
-# The below is valid if the same run-time depends are required to compile.
 RDEPEND="${DEPEND}"
 
-# Source directory; the dir where the sources can be found (automatically
-# unpacked) inside ${WORKDIR}.  The default value for S is ${WORKDIR}/${P}
-# If you don't need to change it, leave the S= line out of the ebuild
-# to keep it tidy.
-#S="${WORKDIR}/${P}"
-
-src_compile() {
-	# Most open-source packages use GNU autoconf for configuration.
-	# The quickest (and preferred) way of running configure is:
-	econf || die "econf failed"
-	#
-	# You could use something similar to the following lines to
-	# configure your package before compilation.  The "|| die" portion
-	# at the end will stop the build process if the command fails.
-	# You should use this at the end of critical commands in the build
-	# process.  (Hint: Most commands are critical, that is, the build
-	# process should abort if they aren't successful.)
-	#./configure \
-	#	--host=${CHOST} \
-	#	--prefix=/usr \
-	#	--infodir=/usr/share/info \
-	#	--mandir=/usr/share/man || die "./configure failed"
-	# Note the use of --infodir and --mandir, above. This is to make
-	# this package FHS 2.2-compliant.  For more information, see
-	#   http://www.pathname.com/fhs/
-
-	# emake (previously known as pmake) is a script that calls the
-	# standard GNU make with parallel building options for speedier
-	# builds (especially on SMP systems).  Try emake first.  It might
-	# not work for some packages, because some makefiles have bugs
-	# related to parallelism, in these cases, use emake -j1 to limit
-	# make to a single process.  The -j1 is a visual clue to others
-	# that the makefiles have bugs that have been worked around.
-	emake || die "emake failed"
-}
+# grr: the packaged directory contains an underscore
+S="${WORKDIR}/rabbitmq_server-${PV}"
 
 src_install() {
-	# You must *personally verify* that this trick doesn't install
-	# anything outside of DESTDIR; do this by reading and
-	# understanding the install part of the Makefiles.
-	# This is the preferred way to install.
-	emake DESTDIR="${D}" install || die "emake install failed"
+	# the local erlang module directory
+	local targetdir="/usr/$(get_libdir)/erlang/lib/${P}"
 
-	# When you hit a failure with emake, do not just use make. It is
-	# better to fix the Makefiles to allow proper parallelization.
-	# If you fail with that, use "emake -j1", it's still better than make.
+	# scripts
+	dosbin sbin/*
 
-	# For Makefiles that don't make proper use of DESTDIR, setting
-	# prefix is often an alternative.  However if you do this, then
-	# you also need to specify mandir and infodir, since they were
-	# passed to ./configure as absolute paths (overriding the prefix
-	# setting).
-	#emake \
-	#	prefix="${D}"/usr \
-	#	mandir="${D}"/usr/share/man \
-	#	infodir="${D}"/usr/share/info \
-	#	libdir="${D}"/usr/$(get_libdir) \
-	#	install || die "emake install failed"
-	# Again, verify the Makefiles!  We don't want anything falling
-	# outside of ${D}.
+	# erlang module
+	dodir "${targetdir}"
+	cp -dpR ebin include src "${D}/${targetdir}"
 
-	# The portage shortcut to the above command is simply:
-	#
-	#einstall || die "einstall failed"
+	# docs
+	dodoc INSTALL LICENSE LICENSE-MPL-RabbitMQ
+
+	# TODO:
+	# config to set env vars as per INSTALL?
+	# set LOGDIR to /var/log/rabbitmq.log
+	# run as different user?
 }