changeset 461:f1cc6af6f4b8

add tootle ebuild
author Dirk Olmes <dirk@xanthippe.ping.de>
date Thu, 12 Jul 2018 21:06:09 +0200
parents 6bfdb5107178
children d9b3090466c7
files net-im/tootle/Manifest net-im/tootle/tootle-0.1.5.ebuild
diffstat 2 files changed, 46 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-im/tootle/Manifest	Thu Jul 12 21:06:09 2018 +0200
@@ -0,0 +1,2 @@
+DIST tootle-0.1.5.tar.gz 931686 BLAKE2B 5068914cc12027eab83b99acd3319cee33736bdcfa337d71f6b3e684290a1b7efd9de88574cf1d0b5e211586a492b897686a05c15acaa3892bd8454dec80c730 SHA512 2db03783044a769edfb70a6be08b401be0662ae4ea9c92c9945cc0f96f74a6785725abe3f8b5a44fff819f9f63d214682181b018fdc1a10953803d9d632a9323
+EBUILD tootle-0.1.5.ebuild 746 BLAKE2B 0818eda832625f0806c0c181dde58cf527570bfa12a9a3ac71a0ee9e39b7313cee14fd94abc9b4ec3d387ca91460c4c77a0134ed671440a359ffe94263b06170 SHA512 99ac8a02c381a4f482fd51765a1c70a2da1177f4eacf4bd252b21420c37f21f9bee944f8703327a0218d6a58b5bde2995389c86febbcbdf9a1c872ba93bac35a
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-im/tootle/tootle-0.1.5.ebuild	Thu Jul 12 21:06:09 2018 +0200
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit meson vala gnome2-utils
+
+DESCRIPTION="GTK3 client for Mastodon"
+HOMEPAGE="https://github.com/bleakgrey/tootle"
+SRC_URI="https://github.com/bleakgrey/tootle/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+	dev-libs/glib
+	dev-libs/granite
+	dev-libs/json-glib
+	net-libs/libsoup:2.4
+	x11-libs/gtk+:3
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+	vala_src_prepare
+	default
+}
+
+pkg_preinst() {
+	gnome2_gconf_savelist
+	gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+	gnome2_icon_cache_update
+	gnome2_gconf_install
+	gnome2_schemas_update
+}
+
+pkg_postrm() {
+	gnome2_icon_cache_update
+}