changeset 307:f8841e212216

bump to 0.15.9
author holger
date Mon, 21 Nov 2011 11:04:15 +0100
parents 0425109c5d19
children f803cf3ec737
files net-libs/rb_libtorrent/Manifest net-libs/rb_libtorrent/rb_libtorrent-0.15.7.ebuild net-libs/rb_libtorrent/rb_libtorrent-0.15.9.ebuild
diffstat 3 files changed, 77 insertions(+), 77 deletions(-) [+]
line wrap: on
line diff
--- a/net-libs/rb_libtorrent/Manifest	Sun Nov 20 13:55:28 2011 +0100
+++ b/net-libs/rb_libtorrent/Manifest	Mon Nov 21 11:04:15 2011 +0100
@@ -1,3 +1,3 @@
-DIST libtorrent-rasterbar-0.15.7.tar.gz 2518963 RMD160 a2929a7e49187de3003af7441216e46c60b8a966 SHA1 5ddc5966436f98c146b6aba8595dfe86cecb6724 SHA256 f5cef05e6205f0e4f2a4dd01802ab121ec68c1b27f57a1c047e1fb84c17b0af0
-EBUILD rb_libtorrent-0.15.7.ebuild 2188 RMD160 f7909bc20c88555cc51a6583f54f6c6e0579ffa4 SHA1 c3bd790653f6e1445b890353317bc8331293aa16 SHA256 3fc0bc1d72e4511e963439d6e13fcb4077d35c75c2b97b81921e966efb139d4d
+DIST libtorrent-rasterbar-0.15.9.tar.gz 2619950 RMD160 54461ff314af9602309a9a34a97cb481dc38179c SHA1 d86eb9d4452d07715a355d3a67312f162d6eff3a SHA256 a2ea68011e9933c7deb473268122f016171d24f0f35e744fbdadd14bf6bac23d
+EBUILD rb_libtorrent-0.15.9.ebuild 2188 RMD160 f7909bc20c88555cc51a6583f54f6c6e0579ffa4 SHA1 c3bd790653f6e1445b890353317bc8331293aa16 SHA256 3fc0bc1d72e4511e963439d6e13fcb4077d35c75c2b97b81921e966efb139d4d
 MISC metadata.xml 279 RMD160 fee9ba43ed5741d59ca721d799c0580f00cc71ef SHA1 093f218c86045f1c60aebde8a54cb673dee8f7f7 SHA256 36618b123d1f4f5b758e481463ea56c0d2a61230f223ccb4a8f1cc2ed4d01584
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.15.7.ebuild	Sun Nov 20 13:55:28 2011 +0100
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,75 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.15.6.ebuild,v 1.5 2011/05/26 21:21:00 maekke Exp $
-
-EAPI="2"
-PYTHON_DEPEND="python? 2:2.6"
-PYTHON_USE_WITH="threads"
-
-inherit eutils versionator python
-
-MY_P=${P/rb_/}
-MY_P=${MY_P/torrent/torrent-rasterbar}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
-HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
-SRC_URI="http://libtorrent.googlecode.com/files/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
-IUSE="debug doc examples python ssl"
-RESTRICT="test"
-
-DEPEND=">=dev-libs/boost-1.36[python?]
-	>=sys-devel/libtool-2.2
-	sys-libs/zlib
-	examples? ( !net-p2p/mldonkey )
-	ssl? ( dev-libs/openssl )"
-
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
-	use python && python_set_active_version 2
-}
-
-src_prepare() {
-	use python && python_convert_shebangs -r 2 .
-}
-
-src_configure() {
-	# use multi-threading versions of boost libs
-	local BOOST_LIBS="--with-boost-system=boost_system-mt \
-		--with-boost-filesystem=boost_filesystem-mt \
-		--with-boost-thread=boost_thread-mt \
-		--with-boost-python=boost_python-mt"
-	# detect boost version and location, bug 295474
-	BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
-	BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
-	BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
-	BOOST_INC="/usr/include/boost-${BOOST_VER}"
-	BOOST_LIB="/usr/$(get_libdir)/boost-${BOOST_VER}"
-
-	local LOGGING
-	use debug && LOGGING="--enable-logging=verbose"
-
-	econf $(use_enable debug) \
-		$(use_enable test tests) \
-		$(use_enable examples) \
-		$(use_enable python python-binding) \
-		$(use_enable ssl encryption) \
-		--with-zlib=system \
-		${LOGGING} \
-		--with-boost=${BOOST_INC} \
-		--with-boost-libdir=${BOOST_LIB} \
-		${BOOST_LIBS}
-}
-
-src_install() {
-	emake DESTDIR="${D}" install || die 'emake install failed'
-	dodoc ChangeLog AUTHORS NEWS README || die 'dodoc failed'
-	if use doc ; then
-		dohtml docs/* || die "Could not install HTML documentation"
-	fi
-}
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.15.9.ebuild	Mon Nov 21 11:04:15 2011 +0100
@@ -0,0 +1,75 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.15.6.ebuild,v 1.5 2011/05/26 21:21:00 maekke Exp $
+
+EAPI="2"
+PYTHON_DEPEND="python? 2:2.6"
+PYTHON_USE_WITH="threads"
+
+inherit eutils versionator python
+
+MY_P=${P/rb_/}
+MY_P=${MY_P/torrent/torrent-rasterbar}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
+HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
+SRC_URI="http://libtorrent.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
+IUSE="debug doc examples python ssl"
+RESTRICT="test"
+
+DEPEND=">=dev-libs/boost-1.36[python?]
+	>=sys-devel/libtool-2.2
+	sys-libs/zlib
+	examples? ( !net-p2p/mldonkey )
+	ssl? ( dev-libs/openssl )"
+
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+	use python && python_set_active_version 2
+}
+
+src_prepare() {
+	use python && python_convert_shebangs -r 2 .
+}
+
+src_configure() {
+	# use multi-threading versions of boost libs
+	local BOOST_LIBS="--with-boost-system=boost_system-mt \
+		--with-boost-filesystem=boost_filesystem-mt \
+		--with-boost-thread=boost_thread-mt \
+		--with-boost-python=boost_python-mt"
+	# detect boost version and location, bug 295474
+	BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
+	BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+	BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+	BOOST_INC="/usr/include/boost-${BOOST_VER}"
+	BOOST_LIB="/usr/$(get_libdir)/boost-${BOOST_VER}"
+
+	local LOGGING
+	use debug && LOGGING="--enable-logging=verbose"
+
+	econf $(use_enable debug) \
+		$(use_enable test tests) \
+		$(use_enable examples) \
+		$(use_enable python python-binding) \
+		$(use_enable ssl encryption) \
+		--with-zlib=system \
+		${LOGGING} \
+		--with-boost=${BOOST_INC} \
+		--with-boost-libdir=${BOOST_LIB} \
+		${BOOST_LIBS}
+}
+
+src_install() {
+	emake DESTDIR="${D}" install || die 'emake install failed'
+	dodoc ChangeLog AUTHORS NEWS README || die 'dodoc failed'
+	if use doc ; then
+		dohtml docs/* || die "Could not install HTML documentation"
+	fi
+}