changeset 118:fc14e6182db4

bump postgres to 8.3.7
author holger@hoho.dyndns.org
date Tue, 17 Mar 2009 04:03:14 +0100
parents ef3299334bd6
children 64fce6b4ea9c
files dev-db/postgresql-base/Manifest dev-db/postgresql-base/postgresql-base-8.3.6.ebuild dev-db/postgresql-base/postgresql-base-8.3.7.ebuild dev-db/postgresql-server/Manifest dev-db/postgresql-server/postgresql-server-8.3.6.ebuild dev-db/postgresql-server/postgresql-server-8.3.7.ebuild
diffstat 6 files changed, 401 insertions(+), 401 deletions(-) [+]
line wrap: on
line diff
--- a/dev-db/postgresql-base/Manifest	Mon Mar 09 21:07:16 2009 +0100
+++ b/dev-db/postgresql-base/Manifest	Tue Mar 17 04:03:14 2009 +0100
@@ -1,5 +1,5 @@
 AUX postgresql-8.3-base.patch 4130 RMD160 53cf20e4161ac9a9abd14c1a834f2e4508c5b44a SHA1 f58dbfde59f1543c8bd87527a1dfc3356c06db90 SHA256 a3bb8eca2d472a22d744a23d47d829b9931cd5bae2206e90d7e0fac4399927a5
 AUX postgresql-8.3-common.patch 2641 RMD160 0822bf1512457e91d5f32f9d192de6f197db9c55 SHA1 e4bdbd5eee1023e8f0b42ef408b34b57495d1e2b SHA256 e416c26d9c3d266b306ddbc0a2b648054739b7ace35e2b4e449fbdaf094bc197
 AUX postgresql-8.x-relax_ssl_perms.patch 764 RMD160 d1ce5164779c0b0c9229dc13d2eebe6b8c960616 SHA1 f28af41e549bbe3a0b4b8669a2762f71bf3e8a9e SHA256 98bc99954521db083320bd9a6b3a0a5d6eb960af3699527c16e53c567e22394a
-DIST postgresql-8.3.6.tar.bz2 14081040 RMD160 fa30a5e426ffd4800bd918012e0094c56ad1bae1 SHA1 6ef6d564988209e5c85b061c71af58bebac522bd SHA256 fd0239849839227649e2f472a1ffeab87f9eedc75a1d11c803dde65b109d7479
-EBUILD postgresql-base-8.3.6.ebuild 4664 RMD160 e131ef0e13d31fd982a739c8fe9c83f199852b56 SHA1 a5e1e81459439d9d683a58aa453209e35c747e48 SHA256 6978b378a20196ffb4851dac809653c6ad7c026fbbd8bc1847824c1e38d3764a
+DIST postgresql-8.3.7.tar.bz2 14124712 RMD160 93b9360d83546fff2d5dadfb9ec32ca3ad7984db SHA1 96facdf7229a7f18f016d86ff6cb350ca5d50bd5 SHA256 eee00caf1860646f6c03b4266f2b2b7936e469b3305bd63b80b7b663c0ae1661
+EBUILD postgresql-base-8.3.7.ebuild 4664 RMD160 e131ef0e13d31fd982a739c8fe9c83f199852b56 SHA1 a5e1e81459439d9d683a58aa453209e35c747e48 SHA256 6978b378a20196ffb4851dac809653c6ad7c026fbbd8bc1847824c1e38d3764a
--- a/dev-db/postgresql-base/postgresql-base-8.3.6.ebuild	Mon Mar 09 21:07:16 2009 +0100
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,148 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-base/postgresql-base-8.3.5.ebuild,v 1.1 2008/12/03 19:21:50 caleb Exp $
-
-EAPI="1"
-
-WANT_AUTOCONF="latest"
-WANT_AUTOMAKE="none"
-
-inherit eutils multilib toolchain-funcs versionator autotools
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-
-DESCRIPTION="PostgreSQL libraries and clients"
-HOMEPAGE="http://www.postgresql.org/"
-SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
-LICENSE="POSTGRESQL"
-SLOT="$(get_version_component_range 1-2)"
-IUSE_LINGUAS="
-	linguas_af linguas_cs linguas_de linguas_es linguas_fa linguas_fr
-	linguas_hr linguas_hu linguas_it linguas_ko linguas_nb linguas_pl
-	linguas_pt_BR linguas_ro linguas_ru linguas_sk linguas_sl linguas_sv
-	linguas_tr linguas_zh_CN linguas_zh_TW"
-IUSE="doc kerberos nls pam pg-intdatetime readline ssl threads zlib ldap ${IUSE_LINGUAS}"
-RESTRICT="test"
-
-wanted_languages() {
-	for u in ${IUSE_LINGUAS} ; do
-		use $u && echo -n "${u#linguas_} "
-	done
-}
-
-RDEPEND="kerberos? ( virtual/krb5 )
-	pam? ( virtual/pam )
-	readline? ( >=sys-libs/readline-4.1 )
-	ssl? ( >=dev-libs/openssl-0.9.6-r1 )
-	zlib? ( >=sys-libs/zlib-1.1.3 )
-	>=app-admin/eselect-postgresql-0.3
-	!dev-db/postgresql-libs
-	!dev-db/postgresql-client
-	!dev-db/libpq
-	!dev-db/postgresql
-	ldap? ( net-nds/openldap )"
-DEPEND="${RDEPEND}
-	sys-devel/flex
-	>=sys-devel/bison-1.875
-	nls? ( sys-devel/gettext )"
-PDEPEND="doc? ( dev-db/postgresql-docs:${SLOT} )"
-
-S="${WORKDIR}/postgresql-${PV}"
-
-src_unpack() {
-	unpack ${A}
-	cd "${S}"
-
-	epatch "${FILESDIR}/postgresql-${SLOT}-common.patch" \
-		"${FILESDIR}/postgresql-${SLOT}-base.patch" \
-		"${FILESDIR}/postgresql-8.x-relax_ssl_perms.patch"
-
-	# to avoid collision - it only should be installed by server
-	rm "${S}/src/backend/nls.mk"
-
-	# because psql/help.c includes the file
-	ln -s "${S}/src/include/libpq/pqsignal.h" "${S}/src/bin/psql/"
-
-	eautoconf
-}
-
-src_compile() {
-	econf --prefix=/usr/$(get_libdir)/postgresql-${SLOT} \
-		--datadir=/usr/share/postgresql-${SLOT} \
-		--sysconfdir=/etc/postgresql-${SLOT} \
-		--includedir=/usr/include/postgresql-${SLOT} \
-		--with-locale-dir=/usr/share/postgresql-${SLOT}/locale \
-		--mandir=/usr/share/postgresql-${SLOT}/man \
-		--without-docdir \
-		--enable-depend \
-		--without-tcl \
-		--without-perl \
-		--without-python \
-		$(use_with readline) \
-		$(use_with kerberos krb5) \
-		$(use_with kerberos gssapi) \
-		"$(use_enable nls nls "$(wanted_languages)")" \
-		$(use_with pam) \
-		$(use_enable pg-intdatetime integer-datetimes ) \
-		$(use_with ssl openssl) \
-		$(use_enable threads thread-safety) \
-		$(use_enable threads thread-safety-force) \
-		$(use_with zlib) \
-		$(use_with ldap) \
-		${myconf} \
-		|| die "configure failed"
-
-	emake LD="$(tc-getLD) $(get_abi_LDFLAGS)" || die "emake failed"
-
-	cd "${S}/contrib"
-	emake LD="$(tc-getLD) $(get_abi_LDFLAGS)" || die "emake failed"
-}
-
-src_install() {
-	emake DESTDIR="${D}" install || die "emake install failed"
-	insinto /usr/include/postgresql-${SLOT}/postmaster
-	doins "${S}"/src/include/postmaster/*.h
-	dodir /usr/share/postgresql-${SLOT}/man/man1
-	tar -zxf "${S}/doc/man.tar.gz" -C "${D}"/usr/share/postgresql-${SLOT}/man man1/{ecpg,pg_config}.1
-
-	rm "${D}/usr/share/postgresql-${SLOT}/man/man1"/{initdb,ipcclean,pg_controldata,pg_ctl,pg_resetxlog,pg_restore,postgres,postmaster}.1
-	dodoc README HISTORY doc/{README.*,TODO,bug.template}
-
-	cd "${S}/contrib"
-	emake DESTDIR="${D}" install || die "emake install failed"
-	cd "${S}"
-
-	dodir /etc/eselect/postgresql/slots/${SLOT}
-
-	IDIR="/usr/include/postgresql-${SLOT}"
-	cat > "${D}/etc/eselect/postgresql/slots/${SLOT}/base" <<-__EOF__
-postgres_ebuilds="\${postgres_ebuilds} ${PF}"
-postgres_prefix=/usr/$(get_libdir)/postgresql-${SLOT}
-postgres_datadir=/usr/share/postgresql-${SLOT}
-postgres_bindir=/usr/$(get_libdir)/postgresql-${SLOT}/bin
-postgres_symlinks=(
-	${IDIR} /usr/include/postgresql
-	${IDIR}/libpq-fe.h /usr/include/libpq-fe.h
-	${IDIR}/libpq /usr/include/libpq
-	${IDIR}/postgres_ext.h /usr/include/postgres_ext.h
-)
-__EOF__
-
-	cat >"${T}/50postgresql-94-${SLOT}" <<-__EOF__
-		LDPATH=/usr/$(get_libdir)/postgresql-${SLOT}/$(get_libdir)
-		MANPATH=/usr/share/postgresql-${SLOT}/man
-	__EOF__
-	doenvd "${T}/50postgresql-94-${SLOT}"
-
-	keepdir /etc/postgresql-${SLOT}
-}
-
-pkg_postinst() {
-	eselect postgresql update
-	[[ "$(eselect postgresql show)" = "(none)" ]] && eselect postgresql set ${SLOT}
-	elog "If you need a global psqlrc-file, you can place it in '${ROOT}/etc/postgresql-${SLOT}/'."
-}
-
-pkg_postrm() {
-	eselect postgresql update
-}
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-db/postgresql-base/postgresql-base-8.3.7.ebuild	Tue Mar 17 04:03:14 2009 +0100
@@ -0,0 +1,148 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-base/postgresql-base-8.3.5.ebuild,v 1.1 2008/12/03 19:21:50 caleb Exp $
+
+EAPI="1"
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="none"
+
+inherit eutils multilib toolchain-funcs versionator autotools
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+DESCRIPTION="PostgreSQL libraries and clients"
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
+LICENSE="POSTGRESQL"
+SLOT="$(get_version_component_range 1-2)"
+IUSE_LINGUAS="
+	linguas_af linguas_cs linguas_de linguas_es linguas_fa linguas_fr
+	linguas_hr linguas_hu linguas_it linguas_ko linguas_nb linguas_pl
+	linguas_pt_BR linguas_ro linguas_ru linguas_sk linguas_sl linguas_sv
+	linguas_tr linguas_zh_CN linguas_zh_TW"
+IUSE="doc kerberos nls pam pg-intdatetime readline ssl threads zlib ldap ${IUSE_LINGUAS}"
+RESTRICT="test"
+
+wanted_languages() {
+	for u in ${IUSE_LINGUAS} ; do
+		use $u && echo -n "${u#linguas_} "
+	done
+}
+
+RDEPEND="kerberos? ( virtual/krb5 )
+	pam? ( virtual/pam )
+	readline? ( >=sys-libs/readline-4.1 )
+	ssl? ( >=dev-libs/openssl-0.9.6-r1 )
+	zlib? ( >=sys-libs/zlib-1.1.3 )
+	>=app-admin/eselect-postgresql-0.3
+	!dev-db/postgresql-libs
+	!dev-db/postgresql-client
+	!dev-db/libpq
+	!dev-db/postgresql
+	ldap? ( net-nds/openldap )"
+DEPEND="${RDEPEND}
+	sys-devel/flex
+	>=sys-devel/bison-1.875
+	nls? ( sys-devel/gettext )"
+PDEPEND="doc? ( dev-db/postgresql-docs:${SLOT} )"
+
+S="${WORKDIR}/postgresql-${PV}"
+
+src_unpack() {
+	unpack ${A}
+	cd "${S}"
+
+	epatch "${FILESDIR}/postgresql-${SLOT}-common.patch" \
+		"${FILESDIR}/postgresql-${SLOT}-base.patch" \
+		"${FILESDIR}/postgresql-8.x-relax_ssl_perms.patch"
+
+	# to avoid collision - it only should be installed by server
+	rm "${S}/src/backend/nls.mk"
+
+	# because psql/help.c includes the file
+	ln -s "${S}/src/include/libpq/pqsignal.h" "${S}/src/bin/psql/"
+
+	eautoconf
+}
+
+src_compile() {
+	econf --prefix=/usr/$(get_libdir)/postgresql-${SLOT} \
+		--datadir=/usr/share/postgresql-${SLOT} \
+		--sysconfdir=/etc/postgresql-${SLOT} \
+		--includedir=/usr/include/postgresql-${SLOT} \
+		--with-locale-dir=/usr/share/postgresql-${SLOT}/locale \
+		--mandir=/usr/share/postgresql-${SLOT}/man \
+		--without-docdir \
+		--enable-depend \
+		--without-tcl \
+		--without-perl \
+		--without-python \
+		$(use_with readline) \
+		$(use_with kerberos krb5) \
+		$(use_with kerberos gssapi) \
+		"$(use_enable nls nls "$(wanted_languages)")" \
+		$(use_with pam) \
+		$(use_enable pg-intdatetime integer-datetimes ) \
+		$(use_with ssl openssl) \
+		$(use_enable threads thread-safety) \
+		$(use_enable threads thread-safety-force) \
+		$(use_with zlib) \
+		$(use_with ldap) \
+		${myconf} \
+		|| die "configure failed"
+
+	emake LD="$(tc-getLD) $(get_abi_LDFLAGS)" || die "emake failed"
+
+	cd "${S}/contrib"
+	emake LD="$(tc-getLD) $(get_abi_LDFLAGS)" || die "emake failed"
+}
+
+src_install() {
+	emake DESTDIR="${D}" install || die "emake install failed"
+	insinto /usr/include/postgresql-${SLOT}/postmaster
+	doins "${S}"/src/include/postmaster/*.h
+	dodir /usr/share/postgresql-${SLOT}/man/man1
+	tar -zxf "${S}/doc/man.tar.gz" -C "${D}"/usr/share/postgresql-${SLOT}/man man1/{ecpg,pg_config}.1
+
+	rm "${D}/usr/share/postgresql-${SLOT}/man/man1"/{initdb,ipcclean,pg_controldata,pg_ctl,pg_resetxlog,pg_restore,postgres,postmaster}.1
+	dodoc README HISTORY doc/{README.*,TODO,bug.template}
+
+	cd "${S}/contrib"
+	emake DESTDIR="${D}" install || die "emake install failed"
+	cd "${S}"
+
+	dodir /etc/eselect/postgresql/slots/${SLOT}
+
+	IDIR="/usr/include/postgresql-${SLOT}"
+	cat > "${D}/etc/eselect/postgresql/slots/${SLOT}/base" <<-__EOF__
+postgres_ebuilds="\${postgres_ebuilds} ${PF}"
+postgres_prefix=/usr/$(get_libdir)/postgresql-${SLOT}
+postgres_datadir=/usr/share/postgresql-${SLOT}
+postgres_bindir=/usr/$(get_libdir)/postgresql-${SLOT}/bin
+postgres_symlinks=(
+	${IDIR} /usr/include/postgresql
+	${IDIR}/libpq-fe.h /usr/include/libpq-fe.h
+	${IDIR}/libpq /usr/include/libpq
+	${IDIR}/postgres_ext.h /usr/include/postgres_ext.h
+)
+__EOF__
+
+	cat >"${T}/50postgresql-94-${SLOT}" <<-__EOF__
+		LDPATH=/usr/$(get_libdir)/postgresql-${SLOT}/$(get_libdir)
+		MANPATH=/usr/share/postgresql-${SLOT}/man
+	__EOF__
+	doenvd "${T}/50postgresql-94-${SLOT}"
+
+	keepdir /etc/postgresql-${SLOT}
+}
+
+pkg_postinst() {
+	eselect postgresql update
+	[[ "$(eselect postgresql show)" = "(none)" ]] && eselect postgresql set ${SLOT}
+	elog "If you need a global psqlrc-file, you can place it in '${ROOT}/etc/postgresql-${SLOT}/'."
+}
+
+pkg_postrm() {
+	eselect postgresql update
+}
--- a/dev-db/postgresql-server/Manifest	Mon Mar 09 21:07:16 2009 +0100
+++ b/dev-db/postgresql-server/Manifest	Tue Mar 17 04:03:14 2009 +0100
@@ -2,5 +2,5 @@
 AUX postgresql-8.3-server.patch 66296 RMD160 6acd5dec3b411d0439bab47a344406df25c08b7a SHA1 fca417c169d5de6c2ea036ab80a4ce02665ae881 SHA256 74684e07df2ff15f3c10d4f586cd72fba51c996ab9a97b6aee11f79987fc4de6
 AUX postgresql.conf-8.3 1725 RMD160 5bdd027b82013feddcba5d68c09e4122e219ecd2 SHA1 c1bc9ba72623efa12bfad55a0e12a57350955409 SHA256 15cb0f8052d0ecc1bced449777f76875c06ab088f67c1f7f3148b84e97082233
 AUX postgresql.init-8.3 3036 RMD160 9a6e0eab7413b82ccf4bfaf6494b3eaa1abf3c4c SHA1 8896cd60d669bdbc5b76649ee26bb23e2c5c9654 SHA256 0685e2e5ff9b97ff22cdbf590fed0c76cb13b4c087bb961a751fdb4e03fb3dea
-DIST postgresql-8.3.6.tar.bz2 14081040 RMD160 fa30a5e426ffd4800bd918012e0094c56ad1bae1 SHA1 6ef6d564988209e5c85b061c71af58bebac522bd SHA256 fd0239849839227649e2f472a1ffeab87f9eedc75a1d11c803dde65b109d7479
-EBUILD postgresql-server-8.3.6.ebuild 9662 RMD160 48e9383552053aca0728635ba977412fedbcfc73 SHA1 8a2076011865de5e03e75f80fc64d61bff70ec92 SHA256 8c6e0a3732d8ce8460155d9862fb8e6720fec95a2e62388ed8011eab9113e2e2
+DIST postgresql-8.3.7.tar.bz2 14124712 RMD160 93b9360d83546fff2d5dadfb9ec32ca3ad7984db SHA1 96facdf7229a7f18f016d86ff6cb350ca5d50bd5 SHA256 eee00caf1860646f6c03b4266f2b2b7936e469b3305bd63b80b7b663c0ae1661
+EBUILD postgresql-server-8.3.7.ebuild 9662 RMD160 48e9383552053aca0728635ba977412fedbcfc73 SHA1 8a2076011865de5e03e75f80fc64d61bff70ec92 SHA256 8c6e0a3732d8ce8460155d9862fb8e6720fec95a2e62388ed8011eab9113e2e2
--- a/dev-db/postgresql-server/postgresql-server-8.3.6.ebuild	Mon Mar 09 21:07:16 2009 +0100
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,249 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-server/postgresql-server-8.3.5.ebuild,v 1.1 2008/12/03 19:27:06 caleb Exp $
-
-EAPI="1"
-
-WANT_AUTOCONF="latest"
-WANT_AUTOMAKE="none"
-inherit eutils multilib toolchain-funcs versionator autotools
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
-
-DESCRIPTION="PostgreSQL server"
-HOMEPAGE="http://www.postgresql.org/"
-SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
-LICENSE="POSTGRESQL"
-SLOT="$(get_version_component_range 1-2)"
-IUSE_LINGUAS="
-	linguas_af linguas_cs linguas_de linguas_es linguas_fa linguas_fr
-	linguas_hr linguas_hu linguas_it linguas_ko linguas_nb linguas_pl
-	linguas_pt_BR linguas_ro linguas_ru linguas_sk linguas_sl linguas_sv
-	linguas_tr linguas_zh_CN linguas_zh_TW"
-IUSE="doc perl python selinux tcl uuid xml nls kernel_linux ${IUSE_LINGUAS}"
-
-wanted_languages() {
-	for u in ${IUSE_LINGUAS} ; do
-		use $u && echo -n "${u#linguas_} "
-	done
-}
-
-RDEPEND="~dev-db/postgresql-base-${PV}:${SLOT}
-	perl? ( >=dev-lang/perl-5.6.1-r2 )
-	python? ( >=dev-lang/python-2.2 dev-python/egenix-mx-base )
-	selinux? ( sec-policy/selinux-postgresql )
-	tcl? ( >=dev-lang/tcl-8 )
-	uuid? ( dev-libs/ossp-uuid )
-	xml? ( dev-libs/libxml2 dev-libs/libxslt )"
-DEPEND="${RDEPEND}
-	sys-devel/flex
-	xml? ( dev-util/pkgconfig )"
-PDEPEND="doc? ( dev-db/postgresql-docs:${SLOT} )"
-
-S="${WORKDIR}/postgresql-${PV}"
-
-pkg_setup() {
-	enewgroup postgres 70
-	enewuser postgres 70 /bin/bash /var/lib/postgresql postgres
-}
-
-src_unpack() {
-	unpack ${A}
-	cd "${S}"
-
-	epatch "${FILESDIR}/postgresql-${SLOT}-common.patch" \
-		"${FILESDIR}/postgresql-${SLOT}-server.patch"
-
-	if hasq test ${FEATURES}; then
-		sed -e "s|/no/such/location|${S}/src/test/regress/tmp_check/no/such/location|g" -i src/test/regress/{input,output}/tablespace.source
-	else
-		echo "all install:" > "${S}/src/test/regress/GNUmakefile"
-	fi
-
-	eautoconf
-}
-
-src_compile() {
-	# TODO: test if PPC really cannot work with other CFLAGS settings
-	# use ppc && CFLAGS="-pipe -fsigned-char"
-
-	# eval is needed to get along with pg_config quotation of space-rich entities.
-	eval econf "$(/usr/$(get_libdir)/postgresql-${SLOT}/bin/pg_config --configure)" \
-		--disable-thread-safety \
-		$(use_with perl) \
-		$(use_with python) \
-		$(use_with tcl) \
-		$(use_with xml libxml) \
-		$(use_with xml libxslt) \
-		$(use_with uuid ossp-uuid) \
-		--with-system-tzdata="/usr/share/zoneinfo" \
-		--with-includes="/usr/include/postgresql-${SLOT}/" \
-		"$(built_with_use ~dev-db/postgresql-base-${PV} nls && use_enable nls nls "$(wanted_languages)")" \
-		|| die "configure failed"
-
-	for bd in . contrib $(use xml && echo contrib/xml2); do
-		PATH="/usr/$(get_libdir)/postgresql-${SLOT}/bin:${PATH}" \
-			emake -C $bd -j1 LD="$(tc-getLD) $(get_abi_LDFLAGS)" \
-				PGXS=$(/usr/$(get_libdir)/postgresql-${SLOT}/bin/pg_config --pgxs) \
-				PGXS_IN_SERVER=1 PGXS_WITH_SERVER="${S}/src/backend/postgres" \
-				NO_PGXS=0 USE_PGXS=1 docdir=/usr/share/doc/${PF} || die "emake in $bd failed"
-	done
-}
-
-src_install() {
-	if use perl ; then
-		mv -f "${S}/src/pl/plperl/GNUmakefile" "${S}/src/pl/plperl/GNUmakefile_orig"
-		sed -e "s:\$(DESTDIR)\$(plperl_installdir):\$(plperl_installdir):" \
-			"${S}/src/pl/plperl/GNUmakefile_orig" > "${S}/src/pl/plperl/GNUmakefile"
-	fi
-
-	for bd in . contrib $(use xml && echo contrib/xml2) ; do
-		PATH="/usr/$(get_libdir)/postgresql-${SLOT}/bin:${PATH}" \
-			emake install -C $bd -j1 DESTDIR="${D}" \
-				PGXS_IN_SERVER=1 PGXS_WITH_SERVER="${S}/src/backend/postgres" \
-				PGXS=$(/usr/$(get_libdir)/postgresql-${SLOT}/bin/pg_config --pgxs) \
-				NO_PGXS=0 USE_PGXS=1 docdir=/usr/share/doc/${PF} || die "emake install in $bd failed"
-	done
-
-	rm -rf "${D}/usr/share/postgresql-${SLOT}/man/man7/" "${D}/usr/share/doc/${PF}/html"
-	rm "${D}"/usr/share/postgresql-${SLOT}/man/man1/{clusterdb,create{db,lang,user},drop{db,lang,user},ecpg,pg_{config,dump,dumpall,restore},psql,reindexdb,vacuumdb}.1
-
-	dodoc README HISTORY doc/{README.*,TODO,bug.template}
-
-	dodir /etc/eselect/postgresql/slots/${SLOT}
-	cat >"${D}/etc/eselect/postgresql/slots/${SLOT}/service" <<-__EOF__
-		postgres_ebuilds="\${postgres_ebuilds} ${PF}"
-		postgres_service="postgresql-${SLOT}"
-	__EOF__
-
-	newinitd "${FILESDIR}/postgresql.init-${SLOT}" postgresql-${SLOT} || die "Inserting init.d-file failed"
-	newconfd "${FILESDIR}/postgresql.conf-${SLOT}" postgresql-${SLOT} || die "Inserting conf.d-file failed"
-
-	keepdir /var/run/postgresql
-	fperms 0770 /var/run/postgresql
-	fowners postgres:postgres /var/run/postgresql
-}
-
-pkg_postinst() {
-	eselect postgresql update
-	[[ "$(eselect postgresql show)" = "(none)" ]] && eselect postgresql set ${SLOT}
-	[[ "$(eselect postgresql show-service)" = "(none)" ]] && eselect postgresql set-service ${SLOT}
-
-	ewarn "Please note that the standard location of the socket has changed from /tmp"
-	ewarn "to /var/run/postgresql and you have to be in the 'postgres' group to access"
-	ewarn "the socket."
-	ewarn "This can break applications which have the standard location hard-coded."
-	ewarn "If such an application links against the libpq, please re-emerge it,"
-	ewarn "if that doesn't help or the application accesses the socket without using libpq,"
-	ewarn "please file a bug-report."
-	ewarn "You can set PGOPTS='-k /tmp' in /etc/conf.d/postgresql-${SLOT} to restore the original location."
-
-	elog "Execute the following command to setup the initial database environment:"
-	elog
-	elog "emerge --config =${CATEGORY}/${PF}"
-	elog
-	elog "The autovacuum function, which was in contrib, has been moved to the main"
-	elog "PostgreSQL functions starting with 8.1."
-	elog "You can enable it in the clusters postgresql.conf."
-}
-
-pkg_postrm() {
-	eselect postgresql update
-}
-
-pkg_config() {
-	[[ -z "${PGDATA}" ]] && PGDATA="/var/lib/postgresql/${SLOT}/data"
-
-	einfo "You can pass options to initdb by setting the PG_INITDB_OPTS variable."
-	einfo "More information can be found here:"
-	einfo "    http://www.postgresql.org/docs/${SLOT}/static/creating-cluster.html"
-	einfo "    http://www.postgresql.org/docs/${SLOT}/static/app-initdb.html"
-	einfo "Simply add the options you would have added to initdb to the PG_INITDB_OPTS variable."
-	einfo
-	einfo "You can change the directory where the database cluster is being created by setting"
-	einfo "the PGDATA variable."
-	einfo
-	einfo "PG_INITDB_OPTS is currently set to:"
-	einfo "    \"${PG_INITDB_OPTS}\""
-	einfo "and the database cluster will be created in:"
-	einfo "    \"${PGDATA}\""
-	einfo "Are you ready to continue? (Y/n)"
-	read answer
-	[ -z $answer ] && answer=Y
-	[ "$answer" == "Y" ] || [ "$answer" == "y" ] || die "aborted"
-
-	if [[ -f "${PGDATA}/PG_VERSION" ]] ; then
-		eerror "The given directory \"${PGDATA}\" already contains a database cluster."
-		die "cluster already exists"
-	fi
-
-	[ -z "${PG_MAX_CONNECTIONS}" ] && PG_MAX_CONNECTIONS="128"
-	einfo "Checking system parameters..."
-
-	if ! use kernel_linux ; then
-		SKIP_SYSTEM_TESTS=yes
-		einfo "  Tests not supported on this OS (yet)"
-	fi
-
-	if [ -z ${SKIP_SYSTEM_TESTS} ] ; then
-		einfo "Checking whether your system supports at least ${PG_MAX_CONNECTIONS} connections..."
-
-		local SEMMSL=$(sysctl -n kernel.sem | cut -f1)
-		local SEMMNS=$(sysctl -n kernel.sem | cut -f2)
-		local SEMMNI=$(sysctl -n kernel.sem | cut -f4)
-		local SHMMAX=$(sysctl -n kernel.shmmax)
-
-		local SEMMSL_MIN=17
-		local SEMMNS_MIN=$(( ( ${PG_MAX_CONNECTIONS}/16 ) * 17 ))
-		local SEMMNI_MIN=$(( ( ${PG_MAX_CONNECTIONS}+15 ) / 16 ))
-		local SHMMAX_MIN=$(( 500000 + ( 30600 * ${PG_MAX_CONNECTIONS} ) ))
-
-		for p in SEMMSL SEMMNS SEMMNI SHMMAX ; do
-			if [ $(eval echo \$$p) -lt $(eval echo \$${p}_MIN) ] ; then
-				eerror "The value for ${p} $(eval echo \$$p) is below the recommended value $(eval echo \$${p}_MIN)"
-				eerror "You have now several options:"
-				eerror "  - Change the mentioned system parameter"
-				eerror "  - Lower the number of max.connections by setting PG_MAX_CONNECTIONS to a value lower than ${PG_MAX_CONNECTIONS}"
-				eerror "  - Set SKIP_SYSTEM_TESTS in case you want to ignore this test completely"
-				eerror "More information can be found here:"
-				eerror "  http://www.postgresql.org/docs/${SLOT}/static/kernel-resources.html"
-				die "system test failed"
-			fi
-		done
-		einfo "Passed."
-	else
-		einfo "Skipped."
-	fi
-
-	einfo "Creating the data directory ..."
-	mkdir -p "${PGDATA}"
-	chown -Rf postgres:postgres "${PGDATA}"
-	chmod 0700 "${PGDATA}"
-
-	einfo "Initializing the database ..."
-
-	su postgres -c "/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb --pgdata \"${PGDATA}\" ${PG_INITDB_OPTS}"
-
-	einfo
-	einfo "You can use the '${ROOT}/etc/init.d/postgresql-${SLOT}' script to run PostgreSQL instead of 'pg_ctl'."
-	einfo
-
-	if [ "${PGDATA}" != "/var/lib/postgresql/${SLOT}/data" ] ; then
-		ewarn "You didn't install the database cluster in the standard location, please make sure that you set"
-		ewarn "PGDATA=\"${PGDATA}\" in the appropriate conf.d file (probably /etc/conf.d/postgresql-${SLOT})"
-	fi
-}
-
-src_test() {
-	einfo ">>> Test phase [check]: ${CATEGORY}/${PF}"
-	PATH="/usr/$(get_libdir)/postgresql-${SLOT}/bin:${PATH}" \
-		emake -j1 check \
-			PGXS=$(/usr/$(get_libdir)/postgresql-${SLOT}/bin/pg_config --pgxs) \
-			NO_PGXS=0 USE_PGXS=1 SLOT=${SLOT} || die "Make check failed. See above for details."
-
-	einfo "Yes, there are other tests which could be run."
-	einfo "... and no, we don't plan to add/support them."
-	einfo "For now, the main regressions tests will suffice."
-	einfo "If you think other tests are necessary, please submit a"
-	einfo "bug including a patch for this ebuild to enable them."
-}
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-db/postgresql-server/postgresql-server-8.3.7.ebuild	Tue Mar 17 04:03:14 2009 +0100
@@ -0,0 +1,249 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-server/postgresql-server-8.3.5.ebuild,v 1.1 2008/12/03 19:27:06 caleb Exp $
+
+EAPI="1"
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="none"
+inherit eutils multilib toolchain-funcs versionator autotools
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+
+DESCRIPTION="PostgreSQL server"
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
+LICENSE="POSTGRESQL"
+SLOT="$(get_version_component_range 1-2)"
+IUSE_LINGUAS="
+	linguas_af linguas_cs linguas_de linguas_es linguas_fa linguas_fr
+	linguas_hr linguas_hu linguas_it linguas_ko linguas_nb linguas_pl
+	linguas_pt_BR linguas_ro linguas_ru linguas_sk linguas_sl linguas_sv
+	linguas_tr linguas_zh_CN linguas_zh_TW"
+IUSE="doc perl python selinux tcl uuid xml nls kernel_linux ${IUSE_LINGUAS}"
+
+wanted_languages() {
+	for u in ${IUSE_LINGUAS} ; do
+		use $u && echo -n "${u#linguas_} "
+	done
+}
+
+RDEPEND="~dev-db/postgresql-base-${PV}:${SLOT}
+	perl? ( >=dev-lang/perl-5.6.1-r2 )
+	python? ( >=dev-lang/python-2.2 dev-python/egenix-mx-base )
+	selinux? ( sec-policy/selinux-postgresql )
+	tcl? ( >=dev-lang/tcl-8 )
+	uuid? ( dev-libs/ossp-uuid )
+	xml? ( dev-libs/libxml2 dev-libs/libxslt )"
+DEPEND="${RDEPEND}
+	sys-devel/flex
+	xml? ( dev-util/pkgconfig )"
+PDEPEND="doc? ( dev-db/postgresql-docs:${SLOT} )"
+
+S="${WORKDIR}/postgresql-${PV}"
+
+pkg_setup() {
+	enewgroup postgres 70
+	enewuser postgres 70 /bin/bash /var/lib/postgresql postgres
+}
+
+src_unpack() {
+	unpack ${A}
+	cd "${S}"
+
+	epatch "${FILESDIR}/postgresql-${SLOT}-common.patch" \
+		"${FILESDIR}/postgresql-${SLOT}-server.patch"
+
+	if hasq test ${FEATURES}; then
+		sed -e "s|/no/such/location|${S}/src/test/regress/tmp_check/no/such/location|g" -i src/test/regress/{input,output}/tablespace.source
+	else
+		echo "all install:" > "${S}/src/test/regress/GNUmakefile"
+	fi
+
+	eautoconf
+}
+
+src_compile() {
+	# TODO: test if PPC really cannot work with other CFLAGS settings
+	# use ppc && CFLAGS="-pipe -fsigned-char"
+
+	# eval is needed to get along with pg_config quotation of space-rich entities.
+	eval econf "$(/usr/$(get_libdir)/postgresql-${SLOT}/bin/pg_config --configure)" \
+		--disable-thread-safety \
+		$(use_with perl) \
+		$(use_with python) \
+		$(use_with tcl) \
+		$(use_with xml libxml) \
+		$(use_with xml libxslt) \
+		$(use_with uuid ossp-uuid) \
+		--with-system-tzdata="/usr/share/zoneinfo" \
+		--with-includes="/usr/include/postgresql-${SLOT}/" \
+		"$(built_with_use ~dev-db/postgresql-base-${PV} nls && use_enable nls nls "$(wanted_languages)")" \
+		|| die "configure failed"
+
+	for bd in . contrib $(use xml && echo contrib/xml2); do
+		PATH="/usr/$(get_libdir)/postgresql-${SLOT}/bin:${PATH}" \
+			emake -C $bd -j1 LD="$(tc-getLD) $(get_abi_LDFLAGS)" \
+				PGXS=$(/usr/$(get_libdir)/postgresql-${SLOT}/bin/pg_config --pgxs) \
+				PGXS_IN_SERVER=1 PGXS_WITH_SERVER="${S}/src/backend/postgres" \
+				NO_PGXS=0 USE_PGXS=1 docdir=/usr/share/doc/${PF} || die "emake in $bd failed"
+	done
+}
+
+src_install() {
+	if use perl ; then
+		mv -f "${S}/src/pl/plperl/GNUmakefile" "${S}/src/pl/plperl/GNUmakefile_orig"
+		sed -e "s:\$(DESTDIR)\$(plperl_installdir):\$(plperl_installdir):" \
+			"${S}/src/pl/plperl/GNUmakefile_orig" > "${S}/src/pl/plperl/GNUmakefile"
+	fi
+
+	for bd in . contrib $(use xml && echo contrib/xml2) ; do
+		PATH="/usr/$(get_libdir)/postgresql-${SLOT}/bin:${PATH}" \
+			emake install -C $bd -j1 DESTDIR="${D}" \
+				PGXS_IN_SERVER=1 PGXS_WITH_SERVER="${S}/src/backend/postgres" \
+				PGXS=$(/usr/$(get_libdir)/postgresql-${SLOT}/bin/pg_config --pgxs) \
+				NO_PGXS=0 USE_PGXS=1 docdir=/usr/share/doc/${PF} || die "emake install in $bd failed"
+	done
+
+	rm -rf "${D}/usr/share/postgresql-${SLOT}/man/man7/" "${D}/usr/share/doc/${PF}/html"
+	rm "${D}"/usr/share/postgresql-${SLOT}/man/man1/{clusterdb,create{db,lang,user},drop{db,lang,user},ecpg,pg_{config,dump,dumpall,restore},psql,reindexdb,vacuumdb}.1
+
+	dodoc README HISTORY doc/{README.*,TODO,bug.template}
+
+	dodir /etc/eselect/postgresql/slots/${SLOT}
+	cat >"${D}/etc/eselect/postgresql/slots/${SLOT}/service" <<-__EOF__
+		postgres_ebuilds="\${postgres_ebuilds} ${PF}"
+		postgres_service="postgresql-${SLOT}"
+	__EOF__
+
+	newinitd "${FILESDIR}/postgresql.init-${SLOT}" postgresql-${SLOT} || die "Inserting init.d-file failed"
+	newconfd "${FILESDIR}/postgresql.conf-${SLOT}" postgresql-${SLOT} || die "Inserting conf.d-file failed"
+
+	keepdir /var/run/postgresql
+	fperms 0770 /var/run/postgresql
+	fowners postgres:postgres /var/run/postgresql
+}
+
+pkg_postinst() {
+	eselect postgresql update
+	[[ "$(eselect postgresql show)" = "(none)" ]] && eselect postgresql set ${SLOT}
+	[[ "$(eselect postgresql show-service)" = "(none)" ]] && eselect postgresql set-service ${SLOT}
+
+	ewarn "Please note that the standard location of the socket has changed from /tmp"
+	ewarn "to /var/run/postgresql and you have to be in the 'postgres' group to access"
+	ewarn "the socket."
+	ewarn "This can break applications which have the standard location hard-coded."
+	ewarn "If such an application links against the libpq, please re-emerge it,"
+	ewarn "if that doesn't help or the application accesses the socket without using libpq,"
+	ewarn "please file a bug-report."
+	ewarn "You can set PGOPTS='-k /tmp' in /etc/conf.d/postgresql-${SLOT} to restore the original location."
+
+	elog "Execute the following command to setup the initial database environment:"
+	elog
+	elog "emerge --config =${CATEGORY}/${PF}"
+	elog
+	elog "The autovacuum function, which was in contrib, has been moved to the main"
+	elog "PostgreSQL functions starting with 8.1."
+	elog "You can enable it in the clusters postgresql.conf."
+}
+
+pkg_postrm() {
+	eselect postgresql update
+}
+
+pkg_config() {
+	[[ -z "${PGDATA}" ]] && PGDATA="/var/lib/postgresql/${SLOT}/data"
+
+	einfo "You can pass options to initdb by setting the PG_INITDB_OPTS variable."
+	einfo "More information can be found here:"
+	einfo "    http://www.postgresql.org/docs/${SLOT}/static/creating-cluster.html"
+	einfo "    http://www.postgresql.org/docs/${SLOT}/static/app-initdb.html"
+	einfo "Simply add the options you would have added to initdb to the PG_INITDB_OPTS variable."
+	einfo
+	einfo "You can change the directory where the database cluster is being created by setting"
+	einfo "the PGDATA variable."
+	einfo
+	einfo "PG_INITDB_OPTS is currently set to:"
+	einfo "    \"${PG_INITDB_OPTS}\""
+	einfo "and the database cluster will be created in:"
+	einfo "    \"${PGDATA}\""
+	einfo "Are you ready to continue? (Y/n)"
+	read answer
+	[ -z $answer ] && answer=Y
+	[ "$answer" == "Y" ] || [ "$answer" == "y" ] || die "aborted"
+
+	if [[ -f "${PGDATA}/PG_VERSION" ]] ; then
+		eerror "The given directory \"${PGDATA}\" already contains a database cluster."
+		die "cluster already exists"
+	fi
+
+	[ -z "${PG_MAX_CONNECTIONS}" ] && PG_MAX_CONNECTIONS="128"
+	einfo "Checking system parameters..."
+
+	if ! use kernel_linux ; then
+		SKIP_SYSTEM_TESTS=yes
+		einfo "  Tests not supported on this OS (yet)"
+	fi
+
+	if [ -z ${SKIP_SYSTEM_TESTS} ] ; then
+		einfo "Checking whether your system supports at least ${PG_MAX_CONNECTIONS} connections..."
+
+		local SEMMSL=$(sysctl -n kernel.sem | cut -f1)
+		local SEMMNS=$(sysctl -n kernel.sem | cut -f2)
+		local SEMMNI=$(sysctl -n kernel.sem | cut -f4)
+		local SHMMAX=$(sysctl -n kernel.shmmax)
+
+		local SEMMSL_MIN=17
+		local SEMMNS_MIN=$(( ( ${PG_MAX_CONNECTIONS}/16 ) * 17 ))
+		local SEMMNI_MIN=$(( ( ${PG_MAX_CONNECTIONS}+15 ) / 16 ))
+		local SHMMAX_MIN=$(( 500000 + ( 30600 * ${PG_MAX_CONNECTIONS} ) ))
+
+		for p in SEMMSL SEMMNS SEMMNI SHMMAX ; do
+			if [ $(eval echo \$$p) -lt $(eval echo \$${p}_MIN) ] ; then
+				eerror "The value for ${p} $(eval echo \$$p) is below the recommended value $(eval echo \$${p}_MIN)"
+				eerror "You have now several options:"
+				eerror "  - Change the mentioned system parameter"
+				eerror "  - Lower the number of max.connections by setting PG_MAX_CONNECTIONS to a value lower than ${PG_MAX_CONNECTIONS}"
+				eerror "  - Set SKIP_SYSTEM_TESTS in case you want to ignore this test completely"
+				eerror "More information can be found here:"
+				eerror "  http://www.postgresql.org/docs/${SLOT}/static/kernel-resources.html"
+				die "system test failed"
+			fi
+		done
+		einfo "Passed."
+	else
+		einfo "Skipped."
+	fi
+
+	einfo "Creating the data directory ..."
+	mkdir -p "${PGDATA}"
+	chown -Rf postgres:postgres "${PGDATA}"
+	chmod 0700 "${PGDATA}"
+
+	einfo "Initializing the database ..."
+
+	su postgres -c "/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb --pgdata \"${PGDATA}\" ${PG_INITDB_OPTS}"
+
+	einfo
+	einfo "You can use the '${ROOT}/etc/init.d/postgresql-${SLOT}' script to run PostgreSQL instead of 'pg_ctl'."
+	einfo
+
+	if [ "${PGDATA}" != "/var/lib/postgresql/${SLOT}/data" ] ; then
+		ewarn "You didn't install the database cluster in the standard location, please make sure that you set"
+		ewarn "PGDATA=\"${PGDATA}\" in the appropriate conf.d file (probably /etc/conf.d/postgresql-${SLOT})"
+	fi
+}
+
+src_test() {
+	einfo ">>> Test phase [check]: ${CATEGORY}/${PF}"
+	PATH="/usr/$(get_libdir)/postgresql-${SLOT}/bin:${PATH}" \
+		emake -j1 check \
+			PGXS=$(/usr/$(get_libdir)/postgresql-${SLOT}/bin/pg_config --pgxs) \
+			NO_PGXS=0 USE_PGXS=1 SLOT=${SLOT} || die "Make check failed. See above for details."
+
+	einfo "Yes, there are other tests which could be run."
+	einfo "... and no, we don't plan to add/support them."
+	einfo "For now, the main regressions tests will suffice."
+	einfo "If you think other tests are necessary, please submit a"
+	einfo "bug including a patch for this ebuild to enable them."
+}