changeset 193:fcfaf7078eb6

erlang-13b03 is in portage
author holger
date Tue, 15 Dec 2009 15:00:50 +0100
parents 38e70d03a68c
children 48a70956f8ca
files dev-lang/erlang/Manifest dev-lang/erlang/erlang-13.2.3.ebuild
diffstat 2 files changed, 0 insertions(+), 169 deletions(-) [+]
line wrap: on
line diff
--- a/dev-lang/erlang/Manifest	Tue Dec 01 04:01:33 2009 +0100
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,4 +0,0 @@
-DIST otp_doc_html_R13B03.tar.gz 26682590 RMD160 b2971024e56e3b05ba537c722fca694daade2ffb SHA1 3a578b3d83fe7bb7abd74823d65548e17cd228e6 SHA256 7be572da5856a659e747c79493980da0d88b285f3f56638aa46cb11f1fb8a0e0
-DIST otp_doc_man_R13B03.tar.gz 1108822 RMD160 8d6af7ea55fe6d8696fd28c563f9c4e5d9aee779 SHA1 2241651db8c4bce02fc5d34d63c983a3d55d1011 SHA256 c06967938826be25babaaecce8673738aef2093e8bbd66e5f66335455d5ae9f7
-DIST otp_src_R13B03.tar.gz 57524485 RMD160 7cf3d1cf6cdf73ff19f5a416396c4024e641ec29 SHA1 161f22d498da244d4b32181a78b04d97523857d1 SHA256 e7c46c8b2778f22064a3b369c1a1b572a1cc0e8a2198166858d4b9a1b488d662
-EBUILD erlang-13.2.3.ebuild 4678 RMD160 b01fe2512377f24a2650557482f01ea914233e75 SHA1 373abf132d95f23876cc92d102b265753bae84e1 SHA256 2ff62989b134a6bc839e6e709cd3e0be7bfb37f3df6d02c135ac02a139e476b6
--- a/dev-lang/erlang/erlang-13.2.3.ebuild	Tue Dec 01 04:01:33 2009 +0100
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,165 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-13.2.2.ebuild,v 1.5 2009/11/25 11:21:02 maekke Exp $
-
-EAPI=2
-WX_GTK_VER="2.8"
-
-inherit autotools elisp-common eutils multilib versionator wxwidgets
-
-# NOTE: If you need symlinks for binaries please tell maintainers or
-# open up a bug to let it be created.
-
-# erlang uses a really weird versioning scheme which caused quite a few problems
-# already. Thus we do a slight modification converting all letters to digits to
-# make it more sane (see e.g. #26420)
-
-# the next line selects the right source.
-ERL_VER=($(get_version_components))
-MY_PV="R$(get_major_version)B0${ERL_VER[2]}"
-
-# ATTN!! Take care when processing the C, etc version!
-MY_P=otp_src_${MY_PV}
-
-DESCRIPTION="Erlang programming language, runtime environment, and large collection of libraries"
-HOMEPAGE="http://www.erlang.org/"
-SRC_URI="http://www.erlang.org/download/${MY_P}.tar.gz
-	doc? ( http://erlang.org/download/otp_doc_man_${MY_PV}.tar.gz
-		http://erlang.org/download/otp_doc_html_${MY_PV}.tar.gz )"
-
-LICENSE="EPL"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~ia64 ppc ~ppc64 ~sparc x86 ~x86-fbsd"
-IUSE="doc emacs hipe java kpoll odbc smp sctp ssl tk wxwindows"
-
-RDEPEND=">=dev-lang/perl-5.6.1
-	ssl? ( >=dev-libs/openssl-0.9.7d )
-	emacs? ( virtual/emacs )
-	java? ( >=virtual/jdk-1.2 )
-	odbc? ( dev-db/unixODBC )"
-DEPEND="${RDEPEND}
-	wxwindows? ( x11-libs/wxGTK:2.8[opengl] )
-	sctp? ( net-misc/lksctp-tools )
-	tk? ( dev-lang/tk )"
-
-S="${WORKDIR}/${MY_P}"
-
-SITEFILE=50${PN}-gentoo.el
-
-pkg_setup() {
-	use wxwindows && wxwidgets_pkg_setup
-}
-
-src_prepare() {
-	use odbc || sed -i 's: odbc : :' lib/Makefile
-
-	if ! use wxwindows; then
-		sed -i 's: wx : :' lib/Makefile
-		rm -rf lib/wx
-	fi
-
-	if use hipe; then
-		ewarn
-		ewarn "You enabled High performance Erlang. Be aware that this extension"
-		ewarn "can break the compilation in many ways, especially on hardened systems."
-		ewarn "Don't cry, don't file bugs, just disable it! If you have a fix, tell us though on Bugzilla."
-		ewarn
-	fi
-	eautoreconf
-}
-
-src_configure() {
-	use java || export JAVAC=false
-
-	econf \
-		--enable-threads \
-		$(use_enable sctp) \
-		$(use_enable hipe) \
-		$(use_with ssl) \
-		$(use_enable ssl dynamic-ssl-lib) \
-		$(use_enable kpoll kernel-poll) \
-		$(use_enable smp smp-support) \
-		|| die
-}
-
-src_compile() {
-	use java || export JAVAC=false
-	emake -j1 || die
-
-	if use emacs ; then
-		pushd lib/tools/emacs
-		elisp-compile *.el || die
-		popd
-	fi
-}
-
-extract_version() {
-	sed -n -e "/^$2 = \(.*\)$/s::\1:p" "${S}/$1/vsn.mk"
-}
-
-src_install() {
-	local ERL_LIBDIR=/usr/$(get_libdir)/erlang
-	local ERL_INTERFACE_VER=$(extract_version lib/erl_interface EI_VSN)
-	local ERL_ERTS_VER=$(extract_version erts VSN)
-
-	emake -j1 INSTALL_PREFIX="${D}" install || die
-	dodoc AUTHORS README
-
-	dosym "${ERL_LIBDIR}/bin/erl" /usr/bin/erl
-	dosym "${ERL_LIBDIR}/bin/erlc" /usr/bin/erlc
-	dosym "${ERL_LIBDIR}/bin/escript" /usr/bin/escript
-	dosym \
-		"${ERL_LIBDIR}/lib/erl_interface-${ERL_INTERFACE_VER}/bin/erl_call" \
-		/usr/bin/erl_call
-	dosym "${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam" /usr/bin/beam
-	use smp && dosym "${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam.smp" /usr/bin/beam.smp
-
-	## Remove ${D} from the following files
-	dosed "${ERL_LIBDIR}/bin/erl"
-	dosed "${ERL_LIBDIR}/bin/start"
-	grep -rle "${D}" "${D}/${ERL_LIBDIR}/erts-${ERL_ERTS_VER}" | xargs sed -i -e "s:${D}::g"
-
-	## Clean up the no longer needed files
-	rm "${D}/${ERL_LIBDIR}/Install"
-
-	if use doc ; then
-		for i in "${WORKDIR}"/man/man* ; do
-			dodir "${ERL_LIBDIR}/${i##${WORKDIR}}"
-		done
-		for file in "${WORKDIR}"/man/man*/*.[1-9]; do
-			# doman sucks so we can't use it
-			cp ${file} "${D}/${ERL_LIBDIR}"/man/man${file##*.}/
-		done
-		# extend MANPATH, so the normal man command can find it
-		# see bug 189639
-		dodir /etc/env.d/
-		echo "MANPATH=\"${ERL_LIBDIR}/man\"" > "${D}/etc/env.d/90erlang"
-		dohtml -A README,erl,hrl,c,h,kwc,info -r \
-			"${WORKDIR}"/doc "${WORKDIR}"/lib "${WORKDIR}"/erts-*
-	fi
-
-	if use emacs ; then
-		pushd "${S}"
-		elisp-install erlang lib/tools/emacs/*.{el,elc}
-		elisp-site-file-install "${FILESDIR}"/${SITEFILE}
-		popd
-	fi
-
-	# prepare erl for SMP, fixes bug #188112
-	use smp && sed -i -e 's:\(exec.*erlexec\):\1 -smp:' \
-		"${D}/${ERL_LIBDIR}/bin/erl"
-}
-
-pkg_postinst() {
-	use emacs && elisp-site-regen
-	elog
-	elog "If you need a symlink to one of Erlang's binaries,"
-	elog "please open a bug on http://bugs.gentoo.org/"
-	elog
-	elog "Gentoo's versioning scheme differs from the author's, so please refer to this version as ${MY_PV}"
-	elog
-}
-
-pkg_postrm() {
-	use emacs && elisp-site-regen
-}