comparison net-misc/ike/ike-2.2.1-r4.ebuild @ 488:093472aabdbc

use a modernized version of the ike source from github
author Dirk Olmes <dirk@xanthippe.ping.de>
date Wed, 09 Oct 2019 08:47:06 +0200
parents
children
comparison
equal deleted inserted replaced
487:6df6fb0af440 488:093472aabdbc
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=7
6
7 CMAKE_IN_SOURCE_BUILD="1"
8 inherit cmake-utils git-r3 linux-info
9
10 DESCRIPTION="Shrew soft VPN Client"
11 HOMEPAGE="http://www.shrew.net/"
12
13 #EGIT_REPO_URI="https://github.com/yrro/${PN}"
14 #EGIT_OVERRIDE_COMMIT_YRRO_IKE="c3560d24bfe020a27ed886fd987b45387b213f0c"
15 EGIT_REPO_URI="https://github.com/dpolitis/shrew.net-vpn-openssl1.1.1"
16
17 LICENSE="shrew"
18 SLOT="0"
19 KEYWORDS="~amd64"
20 IUSE="ldap nat qt4"
21
22 COMMON_DEPEND="dev-libs/libedit
23 dev-libs/openssl
24 qt4? ( dev-qt/qtcore )
25 ldap? ( net-nds/openldap )"
26 DEPEND="${COMMON_DEPEND}
27 dev-util/cmake
28 >=sys-devel/bison-2.3
29 sys-devel/flex"
30 RDEPEND="${COMMON_DEPEND}"
31
32 DOCS="CONTRIB.TXT README.TXT TODO.TXT"
33
34 CONFIG_CHECK="INET_XFRM_TUNNEL"
35
36 S="${WORKDIR}/${P}"
37
38 src_configure(){
39 mycmakeargs+=( -DLDAP=$(usex ldap)
40 -DNATT=$(usex nat)
41 -DQTGUI=$(usex qt4)
42 "-DMANDIR=/usr/share/man")
43
44 cmake-utils_src_configure
45 }
46
47 src_install(){
48 cmake-utils_src_install
49 # multilib strict fix
50 mv "${ED}/usr/lib" "${ED}/usr/$(get_libdir)" || die "mv failed"
51 doinitd ${FILESDIR}/iked || die
52 }