Mercurial > hg > portage
view net-misc/ike/ike-2.2.1-r4.ebuild @ 488:093472aabdbc
use a modernized version of the ike source from github
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Wed, 09 Oct 2019 08:47:06 +0200 |
parents | |
children |
line wrap: on
line source
# Copyright 1999-2010 Gentoo Foundation # Distributed under the terms of the GNU General Public License v2 # $Header: $ EAPI=7 CMAKE_IN_SOURCE_BUILD="1" inherit cmake-utils git-r3 linux-info DESCRIPTION="Shrew soft VPN Client" HOMEPAGE="http://www.shrew.net/" #EGIT_REPO_URI="https://github.com/yrro/${PN}" #EGIT_OVERRIDE_COMMIT_YRRO_IKE="c3560d24bfe020a27ed886fd987b45387b213f0c" EGIT_REPO_URI="https://github.com/dpolitis/shrew.net-vpn-openssl1.1.1" LICENSE="shrew" SLOT="0" KEYWORDS="~amd64" IUSE="ldap nat qt4" COMMON_DEPEND="dev-libs/libedit dev-libs/openssl qt4? ( dev-qt/qtcore ) ldap? ( net-nds/openldap )" DEPEND="${COMMON_DEPEND} dev-util/cmake >=sys-devel/bison-2.3 sys-devel/flex" RDEPEND="${COMMON_DEPEND}" DOCS="CONTRIB.TXT README.TXT TODO.TXT" CONFIG_CHECK="INET_XFRM_TUNNEL" S="${WORKDIR}/${P}" src_configure(){ mycmakeargs+=( -DLDAP=$(usex ldap) -DNATT=$(usex nat) -DQTGUI=$(usex qt4) "-DMANDIR=/usr/share/man") cmake-utils_src_configure } src_install(){ cmake-utils_src_install # multilib strict fix mv "${ED}/usr/lib" "${ED}/usr/$(get_libdir)" || die "mv failed" doinitd ${FILESDIR}/iked || die }