comparison net-im/psi-plus/psi-plus-0.16.452.ebuild @ 394:323ff9881d83

fix the compilation for newer psi snapshots ...
author Dirk Olmes <dirk@xanthippe.ping.de>
date Thu, 11 Jun 2015 16:18:32 +0200
parents
children
comparison
equal deleted inserted replaced
393:1135ba64f157 394:323ff9881d83
1
2 EAPI=5
3
4 inherit eutils l10n multilib gnome2-utils qt4-r2
5
6 DESCRIPTION="Qt4 Jabber client, with Licq-like interface"
7 HOMEPAGE="https://github.com/psi-plus/psi-plus-snapshots/"
8 SRC_URI="https://github.com/psi-plus/psi-plus-snapshots/archive/${PV}.tar.gz"
9
10 S="${WORKDIR}/psi-plus-snapshots-${PV}"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="autoreplyplugin crypt dbus debug doc jingle otrplugin plugins spell ssl xscreensaver watcherplugin whiteboarding"
16 #RESTRICT="test"
17
18 RDEPEND="app-arch/unzip
19 >=dev-qt/qtgui-4.7:4
20 >=app-crypt/qca-2.0.2:2[qt4(+)]
21 x11-libs/libX11
22 dbus? ( >=dev-qt/qtdbus-4.7:4 )
23 spell? ( >=app-text/enchant-1.3.0 )
24 xscreensaver? ( x11-libs/libXScrnSaver )
25 whiteboarding? ( dev-qt/qtsvg:4 )
26 || ( >=sys-libs/zlib-1.2.5.1-r2[minizip] <sys-libs/zlib-1.2.5.1-r1 )"
27
28 DEPEND="${RDEPEND}
29 sys-devel/qconf
30 doc? ( app-doc/doxygen )"
31
32 PDEPEND="crypt? ( app-crypt/qca:2[gpg] )
33 jingle? ( net-im/psimedia
34 app-crypt/qca:2[openssl] )
35 ssl? ( app-crypt/qca:2[openssl] )
36 otrplugin? ( net-libs/libotr app-text/htmltidy )"
37
38 src_prepare() {
39 epatch "${FILESDIR}/qmake.patch"
40 epatch_user
41 }
42
43 src_configure() {
44 # unable to use econf because of non-standard configure script
45 local confcmd="./configure
46 --prefix=/usr
47 --datadir=/usr/share
48 --libdir=/usr/lib64
49 --disable-growl
50 $(use dbus || echo '--disable-qdbus')
51 $(use debug && echo '--debug')
52 $(use plugins && echo '--enable-plugins')
53 $(use spell || echo '--disable-aspell')
54 $(use spell || echo '--disable-enchant')
55 $(use xscreensaver || echo '--disable-xss')
56 $(use whiteboarding && echo '--enable-whiteboarding')"
57
58 echo ${confcmd}
59 ${confcmd} || die "configure failed"
60 ## Makefile is not always created...
61 #[[ ! -f Makefile ]] && die "configure failed"
62 }
63
64 src_compile() {
65 emake || die "emake failed"
66
67 if use autoreplyplugin; then
68 cd src/plugins/generic/autoreplyplugin
69 qmake
70 make
71 cd ../../../..
72 fi
73
74 if use otrplugin; then
75 cd src/plugins/generic/otrplugin
76 qmake
77 make
78 cd ../../../..
79 fi
80
81 if use watcherplugin; then
82 cd src/plugins/generic/watcherplugin
83 qmake
84 make
85 cd ../../../..
86 fi
87 }
88
89 src_install() {
90 emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
91 dodoc README TODO ChangeLog
92
93 if use autoreplyplugin; then
94 cd src/plugins/generic/autoreplyplugin
95
96 local plugindir="/usr/$(get_libdir)/psi-plus/plugins"
97 dodir "${plugindir}"
98 insinto "${plugindir}"
99 doins libautoreplyplugin.so
100
101 cd ../../../..
102 fi
103
104 if use otrplugin; then
105 cd src/plugins/generic/otrplugin
106
107 local plugindir="/usr/$(get_libdir)/psi-plus/plugins"
108 dodir "${plugindir}"
109 insinto "${plugindir}"
110 doins libotrplugin.so
111
112 cd ../../../..
113 fi
114
115 if use watcherplugin; then
116 cd src/plugins/generic/watcherplugin
117
118 local plugindir="/usr/$(get_libdir)/psi-plus/plugins"
119 dodir "${plugindir}"
120 insinto "${plugindir}"
121 doins libwatcherplugin.so
122
123 cd ../../../..
124 fi
125 }
126
127 pkg_preinst() {
128 gnome2_icon_savelist
129 }
130
131 pkg_postinst() {
132 gnome2_icon_cache_update
133 }
134
135 pkg_postrm() {
136 gnome2_icon_cache_update
137 }