Mercurial > hg > portage
comparison www-apps/gallery/gallery-3.0.1.ebuild @ 255:8ddc2d47fc7d
add the latest gallery ebuild from bugs.gentoo.org
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Tue, 01 Mar 2011 05:07:23 +0100 |
parents | |
children |
comparison
equal
deleted
inserted
replaced
254:c9d209e62e25 | 255:8ddc2d47fc7d |
---|---|
1 # Copyright 1999-2010 Gentoo Foundation | |
2 # Distributed under the terms of the GNU General Public License v2 | |
3 # $Header $ | |
4 | |
5 EAPI="2" | |
6 | |
7 inherit webapp eutils depend.php | |
8 | |
9 DESCRIPTION="Web based (PHP Script) photo album viewer/creator" | |
10 HOMEPAGE="http://gallery.menalto.com/" | |
11 SRC_URI="mirror://sourceforge/gallery/${P}.zip" | |
12 | |
13 LICENSE="GPL-2" | |
14 KEYWORDS="~x86 ~amd64" | |
15 IUSE="" | |
16 | |
17 # Build depend is on unzip | |
18 DEPEND="app-arch/unzip" | |
19 | |
20 RDEPEND=" | |
21 >=dev-db/mysql-5 | |
22 >=dev-lang/php-5.2.3 | |
23 >=www-servers/apache-2 | |
24 " | |
25 | |
26 My_PN="${PN}3" | |
27 S=${WORKDIR}/${My_PN} | |
28 | |
29 need_httpd_cgi | |
30 need_php_httpd | |
31 | |
32 | |
33 src_install() { | |
34 webapp_src_preinst | |
35 | |
36 INSTALL_DIR="/${My_PN}" | |
37 | |
38 cp -R * ${D}/${MY_HTDOCSDIR} | |
39 | |
40 keepdir ${MY_HTDOCSDIR}/var | |
41 webapp_serverowned ${MY_HTDOCSDIR}/var | |
42 | |
43 ewarn "ATTANTION!" | |
44 ewarn "gallery3 requires short_open_tag to be On" | |
45 ewarn "You need to edit \"/etc/php/apache2-php5.?/php.ini\"" | |
46 ewarn "and change short_open_tag to \"On\" and " | |
47 ewarn "re-start apache (/etc/init.d/apache2 restart)" | |
48 | |
49 webapp_src_install | |
50 } | |
51 | |
52 pkg_postinst() { | |
53 elog | |
54 elog "To start \"gallery3\" just browse to " | |
55 elog | |
56 elog "http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/gallery3" | |
57 elog | |
58 elog "and follow the simple instructions." | |
59 elog | |
60 ewarn "MAKE SURE TO CHANGE YOUR ADMIN PASSWORD!" | |
61 elog | |
62 elog | |
63 elog "Please read the file http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/README" | |
64 elog "for additional information." | |
65 elog "For example, how to upgrade from gallery2 to gallery3." | |
66 elog | |
67 elog "For additional information refer to ${HOMEPAGE}, please." | |
68 elog | |
69 | |
70 webapp_pkg_postinst | |
71 } | |
72 |