changeset 255:8ddc2d47fc7d

add the latest gallery ebuild from bugs.gentoo.org
author Dirk Olmes <dirk@xanthippe.ping.de>
date Tue, 01 Mar 2011 05:07:23 +0100
parents c9d209e62e25
children 84669d0adbe8
files www-apps/gallery/Manifest www-apps/gallery/gallery-3.0.1.ebuild
diffstat 2 files changed, 74 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/www-apps/gallery/Manifest	Tue Mar 01 05:07:23 2011 +0100
@@ -0,0 +1,2 @@
+DIST gallery-3.0.1.zip 1810327 RMD160 07fe57682b4bce71f952c8673f9c1ebc293b7bd0 SHA1 7a023960a4035aec451a25af4de70090ab4ec924 SHA256 bdff3e0f5f157343f414cdfe000b11c93400d379103529bbc5852d85eb54b64f
+EBUILD gallery-3.0.1.ebuild 1522 RMD160 fdfa8646f7b58a95976a0b3d3127282d1c3d961a SHA1 c3f099ac623d58356f13e3c32e9a1f3800987d55 SHA256 231b68b8e83c4cefe5cb27585fc67b708937b126a671cbbf68cfe4a25fd15872
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/www-apps/gallery/gallery-3.0.1.ebuild	Tue Mar 01 05:07:23 2011 +0100
@@ -0,0 +1,72 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+EAPI="2"
+
+inherit webapp eutils depend.php 
+
+DESCRIPTION="Web based (PHP Script) photo album viewer/creator"
+HOMEPAGE="http://gallery.menalto.com/"
+SRC_URI="mirror://sourceforge/gallery/${P}.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+# Build depend is on unzip
+DEPEND="app-arch/unzip"
+
+RDEPEND="
+	>=dev-db/mysql-5
+	>=dev-lang/php-5.2.3
+	>=www-servers/apache-2
+	"
+
+My_PN="${PN}3"
+S=${WORKDIR}/${My_PN}
+
+need_httpd_cgi
+need_php_httpd
+
+
+src_install() {
+	webapp_src_preinst
+
+	INSTALL_DIR="/${My_PN}"
+
+	cp -R * ${D}/${MY_HTDOCSDIR}
+
+	keepdir ${MY_HTDOCSDIR}/var
+	webapp_serverowned ${MY_HTDOCSDIR}/var
+
+	ewarn "ATTANTION!"
+	ewarn "gallery3 requires short_open_tag to be On"
+	ewarn "You need to edit \"/etc/php/apache2-php5.?/php.ini\"" 
+	ewarn "and change short_open_tag to \"On\" and "
+	ewarn "re-start apache (/etc/init.d/apache2 restart)"
+
+	webapp_src_install
+}
+
+pkg_postinst() {
+	elog
+	elog "To start \"gallery3\" just browse to "
+	elog
+	elog "http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/gallery3"
+	elog
+	elog "and follow the simple instructions." 
+	elog
+	ewarn "MAKE SURE TO CHANGE YOUR ADMIN PASSWORD!"
+	elog
+	elog
+	elog "Please read the file http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/README"
+	elog "for additional information."
+	elog "For example, how to upgrade from gallery2 to gallery3."
+	elog
+	elog "For additional information refer to ${HOMEPAGE}, please."
+	elog
+
+	webapp_pkg_postinst
+}
+