changeset 256:84669d0adbe8

noflush 2.8 ebuild from holgi
author Dirk Olmes <dirk@xanthippe.ping.de>
date Fri, 01 Apr 2011 17:52:02 +0200
parents 8ddc2d47fc7d
children 34ae6a0a3fe8
files sys-block/noflushd/Manifest sys-block/noflushd/files/noflushd.confd sys-block/noflushd/files/noflushd.rc6 sys-block/noflushd/noflushd-2.8.ebuild
diffstat 4 files changed, 79 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/sys-block/noflushd/Manifest	Fri Apr 01 17:52:02 2011 +0200
@@ -0,0 +1,4 @@
+AUX noflushd.confd 356 RMD160 f3f49376df7f5aca70f9effcf4670e0107441292 SHA1 32188bc97d77cd60d45063d77962cf6ec99b9bfa SHA256 524422ec5562c0beac78bb01e9d9f094e62a3ae5940165d0b55e6e2d84df118c
+AUX noflushd.rc6 776 RMD160 b5ae0f8534e23d8a34af9c39eee5c18149056dab SHA1 d469d5507ac9d8df0f6de12ec2242f2f11e6fa67 SHA256 6a5782efef04c2ae0953f2e37f634ae64b3a4aa1ce2f71ced92e7266aa206b52
+DIST noflushd-2.8.tar.gz 180386 RMD160 7c659a8340fe5cdc2f18b2ad5f9bdba920a0bc08 SHA1 5f49249c2fe8556ab2be1485a9d394cce26fa59a SHA256 aa9ab7e58d9c34e189ac63279fd8f5772564630d26c9f036b4943ecece54c278
+EBUILD noflushd-2.8.ebuild 874 RMD160 3197e7c2de3c7b0a53196e585b12e498eeddea5a SHA1 af9f374e688c3294ee67380244fbdfc64cff465d SHA256 0aae22485bc1faf142629449465e52b41330560710f36b3190bd1e47d1c8af35
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/sys-block/noflushd/files/noflushd.confd	Fri Apr 01 17:52:02 2011 +0200
@@ -0,0 +1,11 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/noflushd/files/noflushd.confd,v 1.1 2005/03/06 19:19:20 ciaranm Exp $
+
+# Config file for /etc/init.d/noflushd
+
+#TIMEOUT=60
+#DISKS=/dev/discs/disc0/disc
+#EXTRA=
+#NOFLUSHD_OPTS="-n $TIMEOUT $DISKS $EXTRA"
+
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/sys-block/noflushd/files/noflushd.rc6	Fri Apr 01 17:52:02 2011 +0200
@@ -0,0 +1,31 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/noflushd/files/noflushd.rc6,v 1.1 2005/03/06 19:19:20 ciaranm Exp $
+
+# NB: Config is in /etc/conf.d/noflushd
+
+depend() {
+	need localmount
+}
+
+checkconfig() {
+	if [ -z "$NOFLUSHD_OPTS" ] ; then
+		eerror "You need to setup your NOFLUSHD_OPTS first"
+		eerror "Check that you've adjusted /etc/conf.d/noflushd for your needs"
+		return 1
+	fi
+}
+
+start() {
+	checkconfig || return 1
+	ebegin "Starting noflushd"
+	start-stop-daemon --start --quiet --exec /usr/sbin/noflushd -- $NOFLUSHD_OPTS
+	eend $?
+}
+
+stop() {
+	ebegin "Stopping noflushd"
+	start-stop-daemon --stop --quiet --pidfile /var/run/noflushd.pid
+	eend $?
+}
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/sys-block/noflushd/noflushd-2.8.ebuild	Fri Apr 01 17:52:02 2011 +0200
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/noflushd/noflushd-2.7.5.ebuild,v 1.2 2009/04/11 15:18:15 vapier Exp $
+
+DESCRIPTION="A daemon to spin down your disks and force accesses to be cached"
+HOMEPAGE="http://noflushd.sourceforge.net/"
+SRC_URI="mirror://sourceforge/noflushd/${PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_compile() {
+	econf \
+		--with-docdir=/usr/share/doc/${PF} \
+		--with-initdir=/etc/init.d
+	emake || die
+}
+
+src_install() {
+	emake install DESTDIR="${D}" || die
+	dodoc NEWS
+	prepalldocs
+
+	newinitd "${FILESDIR}"/noflushd.rc6 noflushd
+	newconfd "${FILESDIR}"/noflushd.confd noflushd
+}
+
+pkg_postinst() {
+	ewarn "noflushd works with IDE devices only."
+	ewarn "It has possible problems with reiserfs, too."
+}