comparison app-arch/pigz/pigz-2.1.5.ebuild @ 175:9839e927aee2

add patch for gunzip compatibility to pigz-2.1.5
author holger
date Sat, 14 Nov 2009 20:06:57 +0100
parents 3b3ba42f2f0e
children
comparison
equal deleted inserted replaced
174:3b3ba42f2f0e 175:9839e927aee2
19 19
20 src_unpack() { 20 src_unpack() {
21 unpack ${A} 21 unpack ${A}
22 epatch "${FILESDIR}"/${P}-respect-flags.patch 22 epatch "${FILESDIR}"/${P}-respect-flags.patch
23 epatch "${FILESDIR}"/${P}-decode-symlinks-to-stdout.patch 23 epatch "${FILESDIR}"/${P}-decode-symlinks-to-stdout.patch
24 epatch "${FILESDIR}"/${P}-gunzip-compat.patch
24 } 25 }
25 26
26 src_compile() { 27 src_compile() {
27 tc-export CC 28 tc-export CC
28 emake || die "make failed" 29 emake || die "make failed"
33 dosym /usr/bin/pigz /usr/bin/unpigz 34 dosym /usr/bin/pigz /usr/bin/unpigz
34 dodoc README 35 dodoc README
35 36
36 if use symlink; then 37 if use symlink; then
37 dosym /usr/bin/pigz /usr/bin/gzip 38 dosym /usr/bin/pigz /usr/bin/gzip
39 dosym /usr/bin/unpigz /usr/bin/gunzip
38 fi 40 fi
39 } 41 }