comparison net-misc/zmq/zmq-0.6.ebuild @ 132:fdf0c737a687

bump zeromq to 0.6
author holger
date Fri, 22 May 2009 23:45:17 +0200
parents net-misc/zmq/zmq-0.4.ebuild@49f1b15fc148
children
comparison
equal deleted inserted replaced
131:7a6ad5af4782 132:fdf0c737a687
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="ZeroMQ is a brokerless messaging kernel with extremely high performance."
8 HOMEPAGE="http://www.zeromq.org/"
9 SRC_URI="http://www.zeromq.org/local--files/area:download/${P}.tar.gz"
10 LICENSE="LGPL-3"
11 SLOT="0"
12 KEYWORDS="~x86"
13 #IUSE="c examples java profile python"
14 #DEPEND=""
15 #RDEPEND="${DEPEND}"
16
17 src_compile() {
18
19 # TODO:
20 # --with-perf build performance tests [default=no]
21 # --with-camera build camera example [default=no]
22 # --with-exchange build exchange example [default=no]
23 # --with-chat build chatroom example [default=no]
24 # --with-c build c language binding [default=no]
25 # --with-python build Python language binding [default=no]
26 # --with-java build Java language binding [default=no]
27
28 econf \
29 emake || die "emake failed"
30 }
31
32 src_install() {
33 emake DESTDIR="${D}" install || die "emake install failed"
34 }