diff net-im/psi-plus/psi-plus-0.16.449.ebuild @ 382:31a33e308598

add build support for selected plugins
author Dirk Olmes <dirk@xanthippe.ping.de>
date Thu, 12 Mar 2015 04:16:10 +0100
parents cf8e0286cc7d
children
line wrap: on
line diff
--- a/net-im/psi-plus/psi-plus-0.16.449.ebuild	Wed Mar 11 21:36:01 2015 +0100
+++ b/net-im/psi-plus/psi-plus-0.16.449.ebuild	Thu Mar 12 04:16:10 2015 +0100
@@ -12,7 +12,7 @@
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="crypt dbus debug doc jingle plugins spell ssl xscreensaver whiteboarding"
+IUSE="autoreplyplugin crypt dbus debug doc jingle otrplugin plugins spell ssl xscreensaver watcherplugin whiteboarding"
 #RESTRICT="test"
 
 RDEPEND="app-arch/unzip
@@ -32,7 +32,8 @@
 PDEPEND="crypt? ( app-crypt/qca:2[gpg] )
 	jingle? ( net-im/psimedia
 		app-crypt/qca:2[openssl] )
-	ssl? ( app-crypt/qca:2[openssl] )"
+	ssl? ( app-crypt/qca:2[openssl] )
+	otrplugin? ( net-libs/libotr app-text/htmltidy )"
 
 src_prepare() {
 	epatch_user
@@ -59,6 +60,69 @@
 	#[[ ! -f Makefile ]] && die "configure failed"
 }
 
+src_compile() {
+	emake || die "emake failed"
+	
+	if use autoreplyplugin; then
+		cd src/plugins/generic/autoreplyplugin
+		qmake
+		make
+		cd ../../../..
+	fi
+
+	if use otrplugin; then
+		cd src/plugins/generic/otrplugin
+		qmake
+		make
+		cd ../../../..
+	fi
+	
+	if use watcherplugin; then
+		cd src/plugins/generic/watcherplugin
+		qmake
+		make
+		cd ../../../..
+	fi
+}
+
+src_install() {
+	emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
+	dodoc README TODO ChangeLog
+	
+	if use autoreplyplugin; then
+		cd src/plugins/generic/autoreplyplugin
+
+		local plugindir="/usr/$(get_libdir)/psi-plus/plugins"
+		dodir "${plugindir}"
+		insinto "${plugindir}"
+		doins libautoreplyplugin.so
+
+		cd ../../../..
+	fi
+
+	if use otrplugin; then
+		cd src/plugins/generic/otrplugin
+
+		local plugindir="/usr/$(get_libdir)/psi-plus/plugins"
+		dodir "${plugindir}"
+		insinto "${plugindir}"
+		doins libotrplugin.so
+
+		cd ../../../..
+	fi
+
+	if use watcherplugin; then
+		cd src/plugins/generic/watcherplugin
+
+		local plugindir="/usr/$(get_libdir)/psi-plus/plugins"
+		dodir "${plugindir}"
+		insinto "${plugindir}"
+		doins libwatcherplugin.so
+
+		cd ../../../..
+	fi
+}
+
 pkg_preinst() {
 	gnome2_icon_savelist
 }