diff sys-block/noflushd/noflushd-2.8.ebuild @ 256:84669d0adbe8

noflush 2.8 ebuild from holgi
author Dirk Olmes <dirk@xanthippe.ping.de>
date Fri, 01 Apr 2011 17:52:02 +0200
parents
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/sys-block/noflushd/noflushd-2.8.ebuild	Fri Apr 01 17:52:02 2011 +0200
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/noflushd/noflushd-2.7.5.ebuild,v 1.2 2009/04/11 15:18:15 vapier Exp $
+
+DESCRIPTION="A daemon to spin down your disks and force accesses to be cached"
+HOMEPAGE="http://noflushd.sourceforge.net/"
+SRC_URI="mirror://sourceforge/noflushd/${PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_compile() {
+	econf \
+		--with-docdir=/usr/share/doc/${PF} \
+		--with-initdir=/etc/init.d
+	emake || die
+}
+
+src_install() {
+	emake install DESTDIR="${D}" || die
+	dodoc NEWS
+	prepalldocs
+
+	newinitd "${FILESDIR}"/noflushd.rc6 noflushd
+	newconfd "${FILESDIR}"/noflushd.confd noflushd
+}
+
+pkg_postinst() {
+	ewarn "noflushd works with IDE devices only."
+	ewarn "It has possible problems with reiserfs, too."
+}