diff app-crypt/veracrypt/veracrypt-1.13.ebuild @ 397:a13344a4a7bb

add an ebuild for the latest veracrypt release
author Dirk Olmes <dirk@xanthippe.ping.de>
date Mon, 31 Aug 2015 05:48:32 +0200
parents
children 442474170ed1
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/app-crypt/veracrypt/veracrypt-1.13.ebuild	Mon Aug 31 05:48:32 2015 +0200
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit unpacker
+
+DESCRIPTION="VeraCrypt is a free disk encryption software based on TrueCrypt"
+HOMEPAGE="https://veracrypt.codeplex.com"
+SRC_URI="https://github.com/veracrypt/VeraCrypt/archive/VeraCrypt_1.13.tar.gz -> ${P}.tar.gz"
+
+LICENSE="truecrypt-3.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RESTRICT="mirror"
+
+DEPEND="
+	sys-devel/make
+	dev-lang/nasm
+	app-arch/makeself
+	sys-fs/fuse
+	x11-libs/wxGTK:3.0
+"
+
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}
+
+src_unpack() {
+	unpack ${A} || die "Could not unpack!"
+	mv ${WORKDIR}/* ${WORKDIR}/${PN} || die "Could not move directory!"
+	return
+}
+
+src_compile() {
+	cd ${WORKDIR}/${PN}/src
+	make || die "Could not make VeraCrypt!"
+	return
+}
+
+src_install() {
+    exeinto /usr/bin
+	doexe ${WORKDIR}/${PN}/src/Main/veracrypt || die "Could not install veracrypt executable!"
+	insinto /usr/share/pixmaps
+	doins "${FILESDIR}"/veracrypt.png || die "Could not copy veracrypt.png"
+	return
+}
+
+pkg_postinst() {
+	xdg-desktop-menu install --novendor "${FILESDIR}"/veracrypt.desktop || die "Could not register a menu item!"
+	return
+}
+
+pkg_postrm() {
+	xdg-desktop-menu uninstall "${FILESDIR}"/veracrypt.desktop || die "Could not de-register a menu item!"
+	return
+}