view net-misc/zmq/zmq-0.3.1.ebuild @ 79:7165b0bc5268

initial import of zeromq ebuild
author holger@hoho.dyndns.org
date Mon, 13 Oct 2008 19:00:52 +0200
parents
children 6da0c8668e7e
line wrap: on
line source

# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

inherit eutils

DESCRIPTION="ZeroMQ is a brokerless messaging kernel with extremely high performance."
HOMEPAGE="http://www.zeromq.org/"
SRC_URI="http://www.zeromq.org/local--files/area:download/${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~x86"
IUSE="c java python profile"

DEPEND=""
RDEPEND="${DEPEND}"

# Source directory; the dir where the sources can be found (automatically
# unpacked) inside ${WORKDIR}.  The default value for S is ${WORKDIR}/${P}
# If you don't need to change it, leave the S= line out of the ebuild
# to keep it tidy.
#S="${WORKDIR}/${P}"

src_compile() {
	econf || die "econf failed"
	emake || die "emake failed"
}

src_install() {
	emake DESTDIR="${D}" install || die "emake install failed"
}