view dev-python/potr/potr-1.2.0.ebuild @ 440:d27b7787b1f8

revive the eric ebuild - cannot update due to hard masked dependencies
author Dirk Olmes <dirk@xanthippe.ping.de>
date Wed, 26 Apr 2017 08:38:22 +0200
parents 4b67abbaacee
children
line wrap: on
line source

# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

MY_P="python-otr-release-${PV}"

# compile errors with python3 ... skip for now
#PYTHON_COMPAT=( python2_7 python3_4 )
PYTHON_COMPAT=( python2_7 )

inherit distutils-r1

DESCRIPTION="Pure Python OTR implementation"
HOMEPAGE="https://github.com/AGProjects/python-otr/"
SRC_URI="https://github.com/AGProjects/python-otr/archive/release-${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="LGPL-3+"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""

CDEPEND=">=dev-python/pycrypto-2.1[${PYTHON_USEDEP}]
	dev-python/gmpy[${PYTHON_USEDEP}]
"
DEPEND="${CDEPEND}
	dev-python/setuptools[${PYTHON_USEDEP}]
	"
RDEPEND="${CDEPEND}"

S="${WORKDIR}/${MY_P}"