changeset 429:01e0c9f33853

add an ebuild for the latest python-sipsimple version
author Dirk Olmes <dirk@xanthippe.ping.de>
date Sat, 03 Dec 2016 05:24:42 +0100
parents 1901aeaa2706
children 71a79165eb75
files dev-python/python-sipsimple/Manifest dev-python/python-sipsimple/python-sipsimple-3.1.0.ebuild
diffstat 2 files changed, 58 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-python/python-sipsimple/Manifest	Sat Dec 03 05:24:42 2016 +0100
@@ -0,0 +1,2 @@
+DIST python-sipsimple-3.1.0.tar.gz 4786269 SHA256 4cc33f5373f40148d0c07db6c43f6c9ec973593fada6a6082fea42d8326711c3 SHA512 dc0425e77c1e42839ebac81171754840da88c36fb0dc322b3fd961e9c86bff69e77746ac2ee2c3bf75438a64f02229a2c0745103aff6931dcc289070d8668ed7 WHIRLPOOL 3eb2da40de33aa9e23131fdeb2e65e000e13564528d87a2eab8f7407a20ee54d9859a0603889ea0d0c2ea649b220b234fa581e4aa4d22e06380ace778ba71445
+EBUILD python-sipsimple-3.1.0.ebuild 1437 SHA256 5a924401750e11f5f5113f68ea7fb01cfdf52f3ce32111089b56d115ee009be2 SHA512 8ee9e61ab95ceb5e224008d26317a200eb0bf06dcd34802aa639dff052a27b2126a80938fefd73dcbec82cd1901870b54f0530e4cc4988c1b65d1f2c15c72c12 WHIRLPOOL 66a22571762ec7ed9afa850074b66476af5e49a6056d07834f0071a157511ca7750b23d4ae8ccd4f001952d531ce6caca8fcbacd192af33bde11f8896548135a
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-python/python-sipsimple/python-sipsimple-3.1.0.ebuild	Sat Dec 03 05:24:42 2016 +0100
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="SIP SIMPLE client SDK is a Software Development Kit"
+HOMEPAGE="http://sipsimpleclient.org"
+SRC_URI="https://github.com/AGProjects/python-sipsimple/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="libressl"
+
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="
+	dev-db/sqlite:3
+	!libressl? ( dev-libs/openssl:0[-bindist] )
+	libressl? ( dev-libs/libressl )
+	dev-python/python-application[${PYTHON_USEDEP}]
+	media-libs/alsa-lib
+	media-libs/libv4l
+	media-libs/libvpx
+	sys-apps/util-linux
+	virtual/ffmpeg
+"
+RDEPEND="${CDEPEND}
+	virtual/python-dnspython[${PYTHON_USEDEP}]
+	dev-python/python-cjson[${PYTHON_USEDEP}]
+	dev-python/python-dateutil[${PYTHON_USEDEP}]
+	dev-python/python-eventlib[${PYTHON_USEDEP}]
+	dev-python/greenlet[${PYTHON_USEDEP}]
+	dev-python/python-gnutls[${PYTHON_USEDEP}]
+	dev-python/lxml[${PYTHON_USEDEP}]
+	dev-python/python-msrplib[${PYTHON_USEDEP}]
+	dev-python/python-xcaplib[${PYTHON_USEDEP}]
+	dev-python/twisted-core[${PYTHON_USEDEP}]
+	dev-python/zope-interface[${PYTHON_USEDEP}]
+	dev-python/potr[${PYTHON_USEDEP}]
+"
+DEPEND="${CDEPEND}
+	dev-python/cython[${PYTHON_USEDEP}]
+	virtual/pkgconfig
+"
+
+S="${WORKDIR}/${PN}-release-${PV}"
+
+src_prepare() {
+	chmod +x ${S}/deps/pjsip/configure
+	chmod +x ${S}/deps/pjsip/aconfigure
+}