changeset 428:1901aeaa2706

add an ebuild for the latest python-otr version
author Dirk Olmes <dirk@xanthippe.ping.de>
date Sat, 03 Dec 2016 05:24:24 +0100
parents 18fecfcfbe40
children 01e0c9f33853
files dev-python/potr/Manifest dev-python/potr/potr-1.2.0.ebuild
diffstat 2 files changed, 31 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-python/potr/Manifest	Sat Dec 03 05:24:24 2016 +0100
@@ -0,0 +1,2 @@
+DIST potr-1.2.0.tar.gz 21440 SHA256 df17b17e5d56dc472d59c59190951ddb67952a0ac02cb4fd64ccbef9b211f790 SHA512 45326b3cb1f02eca0cc96d545c862acc87c25e0f1d3f0146bae51953fccba485b264b89143b4d00b9f8f9133c2811dee6dc255c7ebb2375ed70bd49a2feb1f71 WHIRLPOOL 0ab2a8894c8df10f225dc6ca604cbdd03c1f375c510c21368d290603fd4da7178e872604e3544d1cb3b2b23b4bc2a751c5a5231b1854d74d57f495c7c10ac3bf
+EBUILD potr-1.2.0.ebuild 652 SHA256 f3fd0872577f594839715735e64263046afad030cc5f00f5c36bac55808fcdc1 SHA512 091281df92d454507454e428fa5ec7c9296dd4bda58b7b3bb48fc5fe4954224f94c92e49c1a05831167334b1fd4c06af8a57b8f8361257d2658f60666cfb98f4 WHIRLPOOL 43928e396cc40fb2732d8dfddba13a0b4fa7e940f8bbc57c85ab47bfd0e8eac6d5574a85b4d576f5e8234ebd275cc674b15f955c93a0878913ba5843ab3a9eb2
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-python/potr/potr-1.2.0.ebuild	Sat Dec 03 05:24:24 2016 +0100
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P="python-otr-release-${PV}"
+
+#PYTHON_COMPAT=( python{2_7,3_4} )
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure Python OTR implementation"
+HOMEPAGE="https://github.com/AGProjects/python-otr/"
+SRC_URI="https://github.com/AGProjects/python-otr/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+CDEPEND=">=dev-python/pycrypto-2.1[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+	dev-python/setuptools[${PYTHON_USEDEP}]
+	"
+RDEPEND="${CDEPEND}"
+
+S="${WORKDIR}/${MY_P}"