changeset 490:086a16570180

updated ebuild for vscodium
author Dirk Olmes <dirk@xanthippe.ping.de>
date Sun, 20 Oct 2019 02:51:30 +0200
parents 42fc528852c9
children 996ca3a846c3
files app-editors/vscodium/Manifest app-editors/vscodium/vscodium-1.39.2.ebuild
diffstat 2 files changed, 58 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- a/app-editors/vscodium/Manifest	Fri Oct 11 05:45:49 2019 +0200
+++ b/app-editors/vscodium/Manifest	Sun Oct 20 02:51:30 2019 +0200
@@ -3,7 +3,9 @@
 DIST vscodium-1.38.0-x64.tar.gz 82680959 BLAKE2B 538dc34744f69bdb7367a7bd85d40d70465454730658d0db722ad7fa5ecfaa14106c55379ab9ad973874b8cb79408104a6db7ed73a7182ba2fc3e7611d4592fe SHA512 9bf60f4dbf7388f4c80e4b8c489fd4f425f7a8e943f10793cf84afc337cc274eb3da52c5e934e34b8d07e5afb72fe7131bb2578eb09b6148fe0d6827c85b6edf
 DIST vscodium-1.38.1-x64.tar.gz 82681820 BLAKE2B 0354401f0fd7f66908bf571e6b7fcb23d1b83d00901dab24855487c613c9c6aff1c4edc87d1cf2a4d75266451c64505e277157bab2202cc0fe0cc7a1eb99c00c SHA512 e2e7f821fd585037868e42da81b4b394b2abce992f9d93b218a4bba0b7340dbea46f81f4ed8d71cd97ef2ad6c0d0ff87efc67f10e099c9e3155eb6228411c827
 DIST vscodium-1.39.0-x64.tar.gz 82107696 BLAKE2B 953d23fcea032b2e3053922856bb2e8d1cd45e58f5ee0192b727dd6fad17d3eae42bcc7b2e8475b619532aaf62c301a4508f2203f16d1320139460720c70d577 SHA512 27fafd54d2147183dfd68db674caf35e2716743f6cdf22272f1e0066963da8db531d539536999800da8778178a9bd769a2493eab4d2bf174aab574a4ae40c17a
+DIST vscodium-1.39.2-x64.tar.gz 82115233 BLAKE2B 85a02a2b889ac19bc72706e76640100edd26d07524fe911564fb3a0d97c71009853ad6afc2cc299f732165069a365cd421cdd79d90138587575a65723e486557 SHA512 620984e9e3930e53aba2f80549379b891ab5d644c9d4fdb7353bb40df498f15f3ba93b99a69a885647fca08fc04fb16ea9f23f28c1ac64c5ff1a0e9dad44633f
 EBUILD vscodium-1.38.0.ebuild 1396 BLAKE2B 491b49e34fa0c96db0c37734877f8bedefcae249fdae1659b86a98593a683bac378927423c276e3d9cc54805915a0d22325b692e259a97e8715d513d1aca2a7c SHA512 804b60fb1c8b54cc5fff14d6f77fc0a02c774245cde5aab1ad65727f7572a294d6a2c158771351123b7de2df052c8c46636746eb619ef67589ce9904fa465976
 EBUILD vscodium-1.38.1.ebuild 1396 BLAKE2B 491b49e34fa0c96db0c37734877f8bedefcae249fdae1659b86a98593a683bac378927423c276e3d9cc54805915a0d22325b692e259a97e8715d513d1aca2a7c SHA512 804b60fb1c8b54cc5fff14d6f77fc0a02c774245cde5aab1ad65727f7572a294d6a2c158771351123b7de2df052c8c46636746eb619ef67589ce9904fa465976
 EBUILD vscodium-1.39.0.ebuild 1396 BLAKE2B 491b49e34fa0c96db0c37734877f8bedefcae249fdae1659b86a98593a683bac378927423c276e3d9cc54805915a0d22325b692e259a97e8715d513d1aca2a7c SHA512 804b60fb1c8b54cc5fff14d6f77fc0a02c774245cde5aab1ad65727f7572a294d6a2c158771351123b7de2df052c8c46636746eb619ef67589ce9904fa465976
+EBUILD vscodium-1.39.2.ebuild 1396 BLAKE2B 491b49e34fa0c96db0c37734877f8bedefcae249fdae1659b86a98593a683bac378927423c276e3d9cc54805915a0d22325b692e259a97e8715d513d1aca2a7c SHA512 804b60fb1c8b54cc5fff14d6f77fc0a02c774245cde5aab1ad65727f7572a294d6a2c158771351123b7de2df052c8c46636746eb619ef67589ce9904fa465976
 MISC metadata.xml 362 BLAKE2B 39630aa08acc184fded8fff0b33271414fa85821700f5b6666eb14ff207a4c924e035c04c2d819daf960770c032879e2fe5cdb0040a10721495060432cad54a1 SHA512 145a66637ab9dd8cd6c2424673f1e775d850a49b0cccf3b8108b1f54489989f5ba9aab6d29e7bd931e5b70517226ae7a22c7486273ea90c314abdea67593c55c
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/app-editors/vscodium/vscodium-1.39.2.ebuild	Sun Oct 20 02:51:30 2019 +0200
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils pax-utils
+
+DESCRIPTION="Multiplatform Visual Studio Code from Microsoft"
+HOMEPAGE="https://code.visualstudio.com"
+SRC_URI="
+	amd64? ( https://github.com/VSCodium/vscodium/releases/download/${PV}/VSCodium-linux-x64-${PV}.tar.gz -> ${P}-x64.tar.gz )"
+RESTRICT="mirror strip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libsecret"
+
+DEPEND="
+	>=media-libs/libpng-1.2.46:0
+	>=x11-libs/gtk+-3.0:3
+	x11-libs/cairo
+	x11-libs/libXtst
+"
+
+RDEPEND="
+	${DEPEND}
+	>=net-print/cups-2.0.0
+	x11-libs/libnotify
+	x11-libs/libXScrnSaver
+	dev-libs/nss
+	libsecret? ( app-crypt/libsecret[crypt] )
+"
+
+QA_PRESTRIPPED="opt/${PN}/code"
+
+S="${WORKDIR}"
+
+src_install(){
+	pax-mark m code
+	insinto "/opt/${PN}"
+	doins -r *
+	dosym "../../opt/${PN}/bin/codium" "/usr/bin/${PN}"
+	make_desktop_entry "${PN}" "Visual Studio Code" "${PN}" "Development;IDE"
+	doicon "${FILESDIR}/${PN}.png"
+	fperms +x "/opt/${PN}/codium"
+	fperms +x "/opt/${PN}/bin/codium"
+	fperms +x "/opt/${PN}/resources/app/node_modules.asar.unpacked/vscode-ripgrep/bin/rg"
+	fperms +x "/opt/${PN}/resources/app/extensions/git/dist/askpass.sh"
+	insinto "/usr/share/licenses/${PN}"
+}
+
+pkg_postinst(){
+	elog "You may install some additional utils, so check them in:"
+	elog "https://code.visualstudio.com/Docs/setup#_additional-tools"
+}