changeset 219:0f64e7bb73d9

add an ebuild for apache ant
author Dirk Olmes <dirk@xanthippe.ping.de>
date Tue, 29 Jun 2010 23:52:08 +0200
parents b7f1409d82f3
children ea975b812fa2
files dev-java/ant-bin/Manifest dev-java/ant-bin/ant-bin-1.8.1.ebuild
diffstat 2 files changed, 38 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-java/ant-bin/Manifest	Tue Jun 29 23:52:08 2010 +0200
@@ -0,0 +1,2 @@
+DIST apache-ant-1.8.1-bin.tar.gz 8264796 RMD160 9b84de42f30997f845d73939002f8ea8e9981a84 SHA1 6fc40553c10f9d5a2b57b8b19ba07aeed7fe9fea SHA256 069f1bf786a6bf26c2a0bdd72f74850f12a407389bc566ff9c0dfaafb9f6c8fe
+EBUILD ant-bin-1.8.1.ebuild 791 RMD160 cc2cd799aa634e059ed66b6a2b9f359a9179de04 SHA1 0050e86e95ee2e09cd53ce0c1e0d6d2c8c075c34 SHA256 d4cdd3c580428e55bae0f4a322799bffc8c663a9917590a040cd33edcc17acf2
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-java/ant-bin/ant-bin-1.8.1.ebuild	Tue Jun 29 23:52:08 2010 +0200
@@ -0,0 +1,36 @@
+
+inherit java-pkg-2
+
+DESCRIPTION="Java-based build tool similar to 'make' that uses XML configuration files."
+HOMEPAGE="http://ant.apache.org/"
+
+MY_P="apache-ant-1.8.1"
+SRC_URI="mirror://apache/maven/binaries/${MY_P}-bin.tar.gz"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+SLOT="0"
+RDEPEND=">=virtual/jdk-1.5"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+ANT_SHARE="/usr/share/${PN}"
+
+src_unpack() {
+    unpack ${A}
+
+    rm -v "${S}"/bin/*.bat || die
+    rm -v "${S}"/bin/*.cmd || die
+}
+
+src_install() {
+    dodir "${ANT_SHARE}"
+    cp -Rp bin etc lib fetch.xml get-m2.xml "${D}/${ANT_SHARE}" || die "failed to copy"
+
+    java-pkg_regjar "${D}/${ANT_SHARE}"/lib/*.jar
+
+    dodoc INSTALL KEYS LICENSE NOTICE README WHATSNEW || die
+
+    dodir /usr/bin
+    dosym "${ANT_SHARE}/bin/ant" /usr/bin/ant
+}